Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: A2000 with A2630 / DKB 2632 not recognising all RAM  (Read 348 times)

0 Members and 1 Guest are viewing this topic.

Offline gazsp

A2000 with A2630 / DKB 2632 not recognising all RAM
« on: June 29, 2020, 09:46:31 AM »
Hi all,

My A2000 has an A2630 and a DKB 2632 with 112Mb of RAM. Just recently not all of the RAM is showing up - this was happening only every now and then, but now it's 100% of the time. Instead of 112Mb, only 14Mb (!!) is added to the system when running the A2632 command. Looking at the output from ShowConfig, it looks like it's added as 7 * 2Mb.

Has anybody seen this before or have any ideas what's up? Faulty SIMM maybe?

Cheers,
Gaz.

 

Offline Matt_H

Re: A2000 with A2630 / DKB 2632 not recognising all RAM
« Reply #1 on: June 29, 2020, 10:26:37 PM »
Do you have the 2632 command in your startup-sequence? I thought some RAM configs needed the command and others didn't.

My own 2632 (not maxed out) is extremely unstable, to the point of it being unusable. I wonder if there's something about these boards that's especially prone to failure?

Offline gazsp

Re: A2000 with A2630 / DKB 2632 not recognising all RAM
« Reply #2 on: June 30, 2020, 11:08:16 AM »
I do indeed.

What's weird is that it always starts with 112Mb showing, but after a few power cycles it'll drop down to 12Mb.

It's not really unstable (just doesn't show the correct amount of RAM every time). Very odd.
 

Offline Oldsmobile_Mike

Re: A2000 with A2630 / DKB 2632 not recognising all RAM
« Reply #3 on: June 30, 2020, 08:24:29 PM »
Overheating maybe?  Checked that all connectors are tight?
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline gazsp

Re: A2000 with A2630 / DKB 2632 not recognising all RAM
« Reply #4 on: July 07, 2020, 02:02:55 PM »
Turns out to be bad SIMMs (surprise!) Bought two new (old) Crucial SIMMs for it and it's now working fine.

Cheers,
Gaz.
 

Offline Matt_H

Re: A2000 with A2630 / DKB 2632 not recognising all RAM
« Reply #5 on: July 08, 2020, 03:56:40 AM »
Love it when it's that simple!