Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: IBrowse 2.5.3 with Wireless Adapter - DNS Error  (Read 188 times)

0 Members and 1 Guest are viewing this topic.

Offline giZmo350

IBrowse 2.5.3 with Wireless Adapter - DNS Error
« on: July 01, 2020, 04:45:47 PM »
Hi all, hope everyone is okay these days.

Maybe this is a question for Oliver but maybe someone else has run into this also.

I have a 3rd internet capable machine (an A1200 w/ACA1233N) that I'm testing IBrowse 2.5.3 (with AmiSSL 4.6) that I use a Netgear MA401 wireless adapter with AmiTCP and EasyNet. The other 2 machines work perfect with IBrowse 2.5.3 - they are wired adapters.

Installation went fine updating from IBrowse 2.4. At first I couldn't navigate any secure sites. So I checked the following in the User-Startup and all good there.

;BEGIN AmiSSL
Assign AmiSSL: "SYS:Internet/AmiSSL"
If Exists AmiSSL:Libs
Assign LIBS: AmiSSL:Libs ADD
EndIf
Path AmiSSL: ADD
;END AmiSSL

So then I ran the command "setenv save AmiSSL/SSL_CLIENT_VERSION tls1" and verified the file was created and that seemed to fix navigating to secure websites.

However, now each time I navigate a secure site the page will start loading but after X amount of bytes the page stops loading and I eventually get "Host Lookup Failed - No DNS Entry Found. I have to reboot to recover from the error.

The only info I found that might be relevant is here at AW.net.

https://amigaworld.net//modules/newbb/viewtopic.php?viewmode=flat&order=0&topic_id=27944&forum=32&post_id=473636&refresh=Go

I tried using two different wireless routers using both ISP DNS and the routers DNS IP address. I get the same results with both routers. Could this be related to bsdsocket.library?

Like I said, this is he only updated machine that I'm getting this error and the machine previously worked fine with secure sites using IBrowse 2.4.

Any thoughts?
A500: 2MB Chip, 8MB Fast, IndiECS, MiniMegi, IDE4ZorroII on Z-500, KS1.3/KS3.1, WB3.1&BWB
 
A2000HD: 2MB Chip, 128MB Fast, P5:Blizz 2060@50MHz, PCD-50B/4GBCF, XSurf100, RapidRoad, IndiECS, Matze RTG, MiniMegi, CD-RW, SunRize AD516, WB3.9
 
A1200: 2MB Chip, 64MB Fast, 4GBCF, GVP Typhoon 030 @40MHz w/FPU, Subway USB, EasyNet Ethernet, Indi AGA MKI, FastATA MK-IV, Internal Slim CD/DVD-RW, WB3.5

Surfing The Web With AMIGA Is Fun Again!