Welcome, Guest. Please login or register.

Author Topic: Amissl  (Read 1469 times)

Description:

0 Members and 1 Guest are viewing this topic.

Offline bradhansen1Topic starter

  • Full Member
  • ***
  • Join Date: Jan 2019
  • Posts: 187
  • Country: us
  • Gender: Male
    • Show only replies by bradhansen1
Amissl
« on: April 21, 2023, 11:55:31 PM »
Hi All, running OS3.2.1 on A1200 with latest IBrowse and Amissl 5.8. But the Amissl won't run,  There was an extra line about Setting up a link, can't remember and can't find it. Was running before no problem, but started over with 3.2.1 and not no go. Any advise would be most helpful and appreciated, Thank you, Brad Hansen
 

Offline kolla

Re: Amissl
« Reply #1 on: April 22, 2023, 12:23:35 AM »
What do you mean by "AmiSSL won't run" - exactly what isn't working? Accessing sites over https with IBrowse?

AmiSSL just needs and assign for its stuff, AmiSSL:, where it keeps its libs and various cert directories. Do you have this assign?

If you do, and IBrowse still doesn't load sites of https, it could be worthwhile testing with the openssl binary and see what it says...


amissl:openssl s_client -connect forum.amiga.org:443 -CApath AmiSSL:certs
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC
---
A3000/060CSPPC+CVPPC/128MB + 256MB BigRAM/Deneb USB
A4000/CS060/Mediator4000Di/Voodoo5/128MB
A1200/Blz1260/IndyAGA/192MB
A1200/Blz1260/64MB
A1200/Blz1230III/32MB
A1200/ACA1221
A600/V600v2/Subway USB
A600/Apollo630/32MB
A600/A6095
CD32/SX32/32MB/Plipbox
CD32/TF328
A500/V500v2
A500/MTec520
CDTV
MiSTer, MiST, FleaFPGAs and original Minimig
Peg1, SAM440 and Mac minis with MorphOS
 

Offline bradhansen1Topic starter

  • Full Member
  • ***
  • Join Date: Jan 2019
  • Posts: 187
  • Country: us
  • Gender: Male
    • Show only replies by bradhansen1
Re: Amissl
« Reply #2 on: April 22, 2023, 07:35:56 PM »
Thanks for the feedback. If I try to start NetSurf it says Can’t find AmiSSL If I try to load a page, this page, in IBrowse, it says AmiSSL software is too old or not running. I have not had any problem with the software until I updated to OS3.2.1.
Brad Hansen
 

Offline kolla

Re: Amissl
« Reply #3 on: April 23, 2023, 06:03:41 AM »
Sounds like lacking assign, maybe you had in startup-sequence which was replaced by the 3.2.2 update. Put it in user-startup instead. And if this all is cryptic to you, reinstall AmiSSL, it will add an entry to user-startup itself.
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC
---
A3000/060CSPPC+CVPPC/128MB + 256MB BigRAM/Deneb USB
A4000/CS060/Mediator4000Di/Voodoo5/128MB
A1200/Blz1260/IndyAGA/192MB
A1200/Blz1260/64MB
A1200/Blz1230III/32MB
A1200/ACA1221
A600/V600v2/Subway USB
A600/Apollo630/32MB
A600/A6095
CD32/SX32/32MB/Plipbox
CD32/TF328
A500/V500v2
A500/MTec520
CDTV
MiSTer, MiST, FleaFPGAs and original Minimig
Peg1, SAM440 and Mac minis with MorphOS
 

Offline bradhansen1Topic starter

  • Full Member
  • ***
  • Join Date: Jan 2019
  • Posts: 187
  • Country: us
  • Gender: Male
    • Show only replies by bradhansen1
Re: Amissl
« Reply #4 on: April 23, 2023, 10:42:38 PM »
Hi, You must be a very busy Amiga guy! Ok, I am now using AmiSSl with
IBrowse. But when I try to load NetSurf it say it can not find AmiSSlmaster.library and kills everything else. So any idea why NetSurf cannot find this Library, must it be in some special place so NetSurf can find it. Or is there a special version of the library to use?
Thanks for all the help!
Brad Hansen
 

Offline Tygre

Re: Amissl
« Reply #5 on: April 23, 2023, 11:10:31 PM »
Hi Bradhansen1!

I'm not familiar with NetSurf but you could check where it's looking for AmiSSL using SnoopDOS? :)

Cheers!

Offline Thomas

Re: Amissl
« Reply #6 on: April 24, 2023, 11:43:33 AM »

According to the Aminet readme Netsurf requires version 4.3 of AmiSSL. http://aminet.net/package/comm/www/netsurf_os3

AFAIK AmiSSL is not backwards compatible. But different versions can coexist in the same directory. This means you have to install the older version first and then the newer version on top of it. Then you have an installation which is compatible with programs requiring the old version as well as with programs like IBrowse which need the latest one.