Welcome, Guest. Please login or register.

Author Topic: Looking for VS-Code + Amiga Assembly advice  (Read 915 times)


0 Members and 1 Guest are viewing this topic.

Offline Jim90Topic starter

  • Newbie
  • *
  • Join Date: Mar 2023
  • Posts: 1
  • Country: gb
Looking for VS-Code + Amiga Assembly advice
« on: March 12, 2023, 05:37:53 PM »
I've recently booted up my old A1200 after nearly 30 years (that went waaay too fast!). This A1200 has an HDD and 68030 + memory add in-card. On the HDD is a platform game designer I was working on. It still assembles (written in assembly using AsmOne) and the small demo game runs. After all these years the game designer and demo are not too bad. Looking at modern options to play about with the code I see WinUAE, which I downloaded and created a virtual A1200 with HDD for Workbench and a folder on my PC to hold the source code + gfx & sfx files. The game successfully runs here via AsmOne in WinUAE.
AsmOne, however, is a wee bit cumbersome to develop on, and so some more Googling took me to VS-Code and the Amiga Assembly extension. It looks fantastic and promises a lot. I then dropped my source, redirected its Incbins as appropriate and tried to assemble and run it via the FS-UAE option. Unfortunately, while it assembles with no error, the game is corrupt on the first game screen. The 'intro' screen (text only) screen appears ok and allows me to click to start the game. After some playing around with VS-Code I'm now thinking vasm (Amiga Assembly's assembler) might have an unannounced issue with my source, and/or FS-UAE needs to be configured better. Or something else. I've also tried selecting VS-Code's WinUAE run option but still no joy. I've also tried dropping the VS-Code assembled game executable into the A1200 configuration I made in WinUAE itself, but no joy here - the same corruption happens in the first game screen. Again, the same source in VS-Code will assemble and run inside AsmOne in WinUAE itself, so I'm thinking the issue is likely with Amiga Assembly's vasm assembler.

I initially turned to the English Amiga Board (eab.abime.net) after seeing the vasm and Amiga Assembly developers still active on this site. Unfortunately, my site registration process has come to a halt - I've registered using the same "Jim90" username as here, and the same email as I used to register here, but, for some time now my registration status has been saying I'm "currently in the moderation queue to be added to the forum". Despite sending a few emails to this site, I've had no reply.
If anyone is registered over there, is there any chance someone could contact a moderator to see if they could complete my registration (I can log onto the site but not post).

[EDIT] All good, I've now registered with eab.
« Last Edit: March 26, 2023, 04:50:26 PM by Jim90 »