Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: Unable to format any floppies...  (Read 1130 times)

0 Members and 1 Guest are viewing this topic.

Offline Vstech

Unable to format any floppies...
« on: May 05, 2019, 02:44:49 AM »
I have a trio of 1200’s... a 3000 two 1000’s, and a defunct 2000... I am restoring them all, but wanted to play with the new 3.1.4 os, but I am unable to create floppies...

I built a dedicated win7 machine with a floppy drive and successfully formatted the disks, so I know they aren’t bad, but I get bad sector errors, on the amigas...

I suppose the drives are dirty, I will hit them with IPA, and some microfiber, or cotton swabs, and see if it improves, but ALL my amigas have the same issue?
 

Offline scuzzb494

Re: Unable to format any floppies...
« Reply #1 on: May 05, 2019, 03:52:13 AM »
I basically purchased an external USB drive for my Win7 machine.

I'm guessing you have the newer plastic HD disks and are using them on the lower capacity Amiga drives. Kinda hit and miss to be honest. Try and get some DD disks from second hand older stuff off Ebay. That's assuming you don't already have some DDs.

Be very careful with the floppy drives not to muck around with the drive head worm. See this blog of mine where I mend an internal floppy drive for the 1200.

Mainly I just get a disk drive cleaner off Ebay and that does the trick.

The fact that it is happening on all your Amigas points to the media and not the machines. Have you got Workbench disks and do those work.

Try and get an external floppy drive and see if that works better. Really would be so much bad luck having that many drives fail. I get the odd one that struggles but would never anticipate so many not working.

http://www.scuzzscink.com/amiga/scuzzblog_september18/scuzzblogdseptember18_0401.htm

http://www.scuzzscink.com/amiga/scuzzblog_september18/scuzzblogdseptember18_0402.htm

scuzz
« Last Edit: May 05, 2019, 03:57:11 AM by scuzzb494 »
 

Offline SACC-guy

Re: Unable to format any floppies...
« Reply #2 on: May 05, 2019, 10:25:15 PM »
If you're using hd floppies.. you need to tape off the second hole (not the write protect hole) in order to make 880k floppies.

What program are you using to get the ADF images to the floppy?

Did you get 3.1.4 from a dealer? Maybe they will can help you or buy the actual floppies and rom?
 

Offline Vstech

Re: Unable to format any floppies...
« Reply #3 on: May 06, 2019, 04:08:48 AM »
Nope, all DD disks,
No issue formatting them to 720k in windows... the amigas simply fail with bad sectors...
now... I don’t have any workbench disks, the drives epseem to load game disks ok, not always though.
I can load the Amiga vision disks, but cannot format any disks...
my battle chess disk loads, but won’t run past some German name screen on the chess board...
the 3000 will boot from the he, but, again, will not format the disks...

I only have the one drive for the 1200’s, but no bootable media. The HD in it isn’t complete we, so the format command will not come up.
After some reading, I am thinking my 3000 needs a specific cable to work... I do have an old 1000 external drive I could try...
 

Offline midway

Re: Unable to format any floppies...
« Reply #4 on: May 06, 2019, 11:01:14 AM »
Are you using the correct driver on the amiga side to read ms dos formatted disks? You can activate it by looking under storage/dosdrivers if i remember right
 

Offline paul1981

Re: Unable to format any floppies...
« Reply #5 on: May 06, 2019, 11:59:58 AM »
I have a trio of 1200’s... a 3000 two 1000’s, and a defunct 2000... I am restoring them all, but wanted to play with the new 3.1.4 os, but I am unable to create floppies...

I built a dedicated win7 machine with a floppy drive and successfully formatted the disks, so I know they aren’t bad, but I get bad sector errors, on the amigas...

I suppose the drives are dirty, I will hit them with IPA, and some microfiber, or cotton swabs, and see if it improves, but ALL my amigas have the same issue?

Yes if you've had crumby disks in them it could easily do what you describe. Disks stored in damp garages or sheds or steamy lofts are prime candidates. A cleaning disk and solution is the easiest method with appropriate software from aminet. I can tell you exactly what program I use for this later on tonight.
 

Offline goldfish

Re: Unable to format any floppies...
« Reply #6 on: May 06, 2019, 07:33:32 PM »
Hi

Check PSU I had this issue and it turned out to be a crappy psu.
 

Offline SACC-guy

Re: Unable to format any floppies...
« Reply #7 on: May 06, 2019, 11:56:29 PM »
Since you have no workbench disk..

It might be wise to buy at least one set of the system disks!

Again, how are you going to send the adf's to floppy? Maybe cf card? maybe sd card? maybe parnet?

I don't know where you are but if in Sacramento, SACC will get you some working disks and help with most hardware.

May just a local amigan with a working machine can help?
« Last Edit: May 07, 2019, 12:20:34 AM by SACC-guy »
 

Offline Vstech

Re: Unable to format any floppies...
« Reply #8 on: May 08, 2019, 03:35:43 AM »
My plan was to setup wb314 on an SD card with Wingate... but I’m too stupid for that apparently... block0 unable to save the hdo/hd1 info to the card...

 

Offline SACC-guy

Re: Unable to format any floppies...
« Reply #9 on: May 08, 2019, 10:28:24 AM »
Try this blog for outstanding how to's

http://amigax1000.blogspot.com/2018/12/
 

Offline Vstech

Re: Unable to format any floppies...
« Reply #10 on: May 11, 2019, 03:41:36 AM »
I finally got my SD to ide in, and setup a SD card boot of workbench 3.1, then successfully connected Amiga explorer and SLOOOOOOOWLY transferred the adf files to blank floppies on my 1200... success... 2 hours of my day wasted, but success!

Now I need to understand why winuae won’t let me mount a pc folder and transfer data to the SD...
 

Offline paul1981

Re: Unable to format any floppies...
« Reply #11 on: May 11, 2019, 11:09:26 AM »

Yes if you've had crumby disks in them it could easily do what you describe. Disks stored in damp garages or sheds or steamy lofts are prime candidates. A cleaning disk and solution is the easiest method with appropriate software from aminet. I can tell you exactly what program I use for this later on tonight.

I use 'Head Cleaner' from aminet, it has a simple GUI and works: http://aminet.net/package/disk/misc/headcleaner372
 

Offline Vstech

Re: Unable to format any floppies...
« Reply #12 on: May 13, 2019, 12:12:18 AM »
Ok, I have my 1200 internal and external disks formatting nicely.
The 3000 is a different matter.
Neither the internal drive, nor the external drive that works fine on my 1200 will format disks. I’m thinking the Gary circuit is damaged... any ideas where to look on it?
 

Offline vince_6

Re: Unable to format any floppies...
« Reply #13 on: May 13, 2019, 06:00:01 PM »
CIA or bad caps also.
http://partsfromthepast.blogspot.gr/ A1200 Black Project
To blit, or not to blit?