Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Successfully Installing a SCSI2SD V6.0  (Read 1615 times)

0 Members and 1 Guest are viewing this topic.

Offline cehofer

  • Full Member
  • ***
  • Join Date: Jan 2009
  • Posts: 133
  • Country: us
  • Total likes: 0
  • Gender: Male
Successfully Installing a SCSI2SD V6.0
« on: December 31, 2018, 02:17:58 AM »
I have looked all over the net and there isn't much on help for if you want to add a SCSI2SD V6 to your Amiga.  I can only talk with any authority with my Amiga 4000T with the built in SCSI.

My equipment:

A4000T 3.9 BB2 to start then I upgraded to BB4.
HDtools 1999 version.  FFS 45.13 to start with then moved to 45.16
Amigakit SCSI2SD V6.0 firmware 6.2.1
32 gig Sandisk SD card

First you need the scsi2sd-util6.exe.  There is a special utility for Version 6 Cards!!!!  THE VERSION 5 WILL NOT WORK !!!!
For Windoze, you need a special driver scsi2sd-driver.zip in order to access the SD card.
I tried attaching them here but it fails security checks.  Here is the website link to download the utility and driver for Windoze, MAC and Linux

My CD is address 1 and HD Address 3 so I made the V6 card SCSI Address 5.

I tried a couple combinations of placement in the SCSI chain but it worked best as the last device with the SCSI terminations on.  The 4000T has an activate termination card at the end of the cable so I unplugged that and plugged it into my Version 6 card.

Another thing I ran into is that the Version6 card has a micro USB cable.  I had to try 3 cables before I found one that had power and data connected.  If you don't have one 5 Below Store has them for $5 in the US.

Once you have it plugged in and the utilility up, select from "FILE" "Load from device" if you want to see how it is currently configured.  I selected "File" "Load Defaults".  I did this to start with a clear card.  I made the following selections:  I should mention I did this before I installed and connected it to the Amiga.  I have also successfully made changes to the card settings with the Amiga connected to the drive and turned off.  I will also note that my Windoze box did not recognize the 32 gig SD card until I selected the correct SD size of 32 gig and saved it to the card.  A Second note:  you will not be able to access the SD card from the USB on a Windoze machine until you install the driver.  Once you have partitioned and formatted in FFS, Windowz will no longer see the SD card.

Enable SCSI Terminator
Enable Parity - Parity should match your other device settings. 
Enable SCSI 2 mode -  All my devices are SCSI 2 capable.
Enable Respond to Short SCSI selections pulses.

Make sure all other device tabs are disabled.  I then went to Device 6 address 5 tab.

Checked:   "enable SCSI Target"
Device type:   "Harddrive"
SD card start sector:  0
Checked :  Auto - this is to let it calculate the drive size.
Sector count:  I left this alone because it will be calculated when you enter Device size later.
Sector size (bytes):  512 - this is default
Device size:  32
Pulldown:  GB
 I left the rest default values.

Be sure to go to "File" and "Save to Device".

I booted the Amiga and found the new drive with both 3.9 toolbox and the 1999 HDtools.   I then partitioned the disk:

2 gig Boot
4 gig Workbench
8 gig Data
18 gig MoreData

Before I updated 3.9 to BB4, these drives would not auto mount even though I had "automount" selected.  I would have to use the "mounter" in tools.  After I upgraded to BB3&4, they would automount no problem.

Be sure and do a "Quick Format".  I hear that is recommended.  It worked for me.

I am getting over 8MB/sec between my HD and SCSI2SD drive per Sysinfo.

I have tried to add screen shots of my settings for the card but I have not been successful as I get an error to upload pngs and jpgs.  Maybe the Admin can help me out.

You can also configure and split the SD card by LUN.  I don't quite understand why you would want to do this.  Maybe speed but I was not successful at this.  This was the only way I could get it to work reliably.  Maybe somebody else could shed light as to why.
« Last Edit: December 31, 2018, 05:57:16 AM by cehofer »