Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: I got my A500 working again!  (Read 925 times)

0 Members and 1 Guest are viewing this topic.

Offline Dynamic_Computing

I got my A500 working again!
« on: December 08, 2018, 02:02:19 AM »
My poor Amiga 500 that I bought in 1987 has been neglected since '92 when I bought my A3000. Over the years after I got my A1200 and A4000, I just never had a reason to turn her on anymore. A few months back, I wanted to do a "10 Minute Amiga Retro Cast) all about my A570 CD Drive and its CDTV features, so I took out the old A500, booted her up, and no keyboard response! All the normal troubleshooting came up negative, so I took the Keyboard apart, and the Membrane was broken in three places! I tried a bit of jury-rigging, with no success. So - Vesalia.de had new membranes in stock - less that $20 shipped to the USA! And Voila! It works perfect now! So it got me thinking about the extra MegAchip 2 MB CHIP RAM expansion card I found in my Amiga Storage a few months back - It was a perfect fit! So now my old girl is humming along nicely with 2 MB of CHIP RAM!
Why do I do this to myself. I have plenty of really fast working Amigas - but I went ahead and ordered a new ACA500 for my A500. Do I need it? no... Could I have spent the money on food for the children? Sure... But she will be a really nice Amiga when it comes in!
 
The following users thanked this post: Fat Barry

Offline David Wright

Re: I got my A500 working again!
« Reply #1 on: December 08, 2018, 03:46:41 AM »
Just make sure there are some soda crackers and cereal in the pantry for the kids and forget the guilt.
Priorities.

Offline paul1981

Re: I got my A500 working again!
« Reply #2 on: December 09, 2018, 08:35:06 PM »
Or sell the kids and buy an AmigaOne X5000.

Offline trekiej

Re: I got my A500 working again!
« Reply #3 on: December 09, 2018, 08:46:39 PM »
Congratulations, I hope to get to work on my A1000 next week.
Amiga 2000 Forever :)
Welcome to the Planar System.
 

Offline Dynamic_Computing

Re: I got my A500 working again!
« Reply #4 on: December 10, 2018, 05:53:37 AM »
Crazy - I got the A500 up and running like a champ, and then I find out the darn drive assembly in my A570 CD Drive is jammed! I had to take the entire thing apart just to get the disk out, then spent abut an hour cleaning and lubricating everything. Luckily, she works like a champ now, too! If it's not one thing...
It is a shame I won't be able to use my new ACA500 that is coming in with my A570, but I really don't need a CD-ROM for anything anymore. I am curious, though. The A570 supports CD+G, and that is what a lot of the Karaoke machines support. I am going to get a disk or two in and see if they work in the A570. Then, i can bypass the Paula passthru jacks, hook up a mic to the inputs, and my A500 is a Karaoke machine!