Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: NetSurf OS3.x Issues  (Read 586 times)

0 Members and 1 Guest are viewing this topic.

Offline Acill

NetSurf OS3.x Issues
« on: December 31, 2015, 10:29:28 PM »
Ive installed the latest available release on OS3.9 with BB1-4 installed. I am using Picasso96 screens on an A4000T and mediator using a Voodoo 5 at 1440x900 24 bit. Also tried it on 1024x768.

Problem is the window it opens displays the browser pushed to the left with corrupted graphics. I cant select anything in it and its unusable. It does this on all the versions contained in the archive. I'll submit a photo later this evening.
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline Oldsmobile_Mike

Re: NetSurf OS3.x Issues
« Reply #1 on: December 31, 2015, 11:10:57 PM »
NetSurf is not 100% stable on any of the classic platforms.  There's a thread here with over 600 responses where many others have already posted screenshots.  Take a look at these:

http://www.amiga.org/forums/showpost.php?p=794444&postcount=623

http://www.amiga.org/forums/showpost.php?p=794183&postcount=612

http://www.amiga.org/forums/showpost.php?p=794194&postcount=616

http://www.amiga.org/forums/showpost.php?p=794201&postcount=617

http://www.amiga.org/forums/showpost.php?p=794024&postcount=574

http://www.amiga.org/forums/showpost.php?p=794029&postcount=579

I've only tested up to I believe it was 3.2 or 3.3, don't know if it's gotten any better under the latest 3.4 DEV, I haven't had a chance to test it yet.

In any case, your best bet for a browser on classic systems is still, sadly, Ibrowse.  Which actually wouldn't be that danged bad of a browser if it could be updated...  *sigh*

Also recommend the WarpDT's for better performance:  http://www.warpdt.co.uk/
(you can still register those as the author is still active in the community)
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline utri007

Re: NetSurf OS3.x Issues
« Reply #2 on: January 01, 2016, 12:23:30 AM »
Oldsmobile_Mike : Prety much every link you gave is about Chris trying to port Netsurf to OS3.x. It is not even near to be useable, though it had some promising features already. It doesn't lock Computer, it has a real gui, it requires quite few memory, uses standard system libraries, etc. It is not publicly availlable.

Acill has tried most likely Arthur's version wich can be downloaded from aminet it uses SDL and is based to debugging/no gui version of Netsurf.

It is not usefull, you can load maybe one or two page before it crash.
« Last Edit: January 01, 2016, 12:29:17 AM by utri007 »
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline Oldsmobile_Mike

Re: NetSurf OS3.x Issues
« Reply #3 on: January 01, 2016, 12:36:38 AM »
Quote from: utri007;801127
Oldsmobile_Mike : Prety much every link you gave is about Chris trying to port Netsurf to OS3.x. It is not even near to be useable, though it had some promising features already. It doesn't lock Computer, it has a real gui, it requires quite few memory, uses standard system libraries, etc. It is not publicly availlable.

Sure it's publicly available.  Here's Chris's 3.3 right here on Aminet:  http://aminet.net/package/comm/www/netsurf

Not sure where 3.4 went, I recall seeing links to it somewhere a few months ago, but haven't had time to dig into it any further.  Or maybe my memory's just playing tricks on me, lol.  ;)

Edit - disregard that last, 3.4 is Artur's.  Google to the rescue again!  ;)

Edit again - Chris's 3.3 on Aminet is for OS4.  Remind me again why I hate NetSurf?  You can still get his version for classic systems though, otherwise how would I have gotten it?  :banana:
« Last Edit: January 01, 2016, 01:07:41 AM by Oldsmobile_Mike »
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Acill

Re: NetSurf OS3.x Issues
« Reply #4 on: January 01, 2016, 01:09:18 AM »
The 3.4 version is the one I have tried. So its not working for anyone? Strange its even an option to download if that is the case.
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline Oldsmobile_Mike

Re: NetSurf OS3.x Issues
« Reply #5 on: January 01, 2016, 01:13:33 AM »
Quote from: Acill;801131
The 3.4 version is the one I have tried. So its not working for anyone? Strange its even an option to download if that is the case.

It's still very, very, very beta.

The fact that there's like 50 different versions (okay, I'm exaggerating that number by a bit, but not by much) doesn't help ease the confusion any.  :(
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Acill

Re: NetSurf OS3.x Issues
« Reply #6 on: January 01, 2016, 02:41:58 AM »
So Ibrowse is still the best usable browser on a 3.x machine?
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline Oldsmobile_Mike

Re: NetSurf OS3.x Issues
« Reply #7 on: January 01, 2016, 02:48:19 AM »
Quote from: Acill;801135
So Ibrowse is still the best usable browser on a 3.x machine?

IMHO, yes.  :)
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline chris

Re: NetSurf OS3.x Issues
« Reply #8 on: January 01, 2016, 09:23:26 PM »
Quote from: Oldsmobile_Mike;801129
Edit again - Chris's 3.3 on Aminet is for OS4.  Remind me again why I hate NetSurf?  You can still get his version for classic systems though, otherwise how would I have gotten it?  :banana:

Try http://homepage.ntlworld.com/cdyoung/tmp/netsurf_os3.lha

btw v3.4 of NetSurf isn't released yet. Anything versioned 3.4 is a post-3.3 development snapshot.
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline utri007

Re: NetSurf OS3.x Issues
« Reply #9 on: January 01, 2016, 11:04:59 PM »
Have you created new version to test?
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline Acill

Re: NetSurf OS3.x Issues
« Reply #10 on: January 01, 2016, 11:57:53 PM »
Thanks for the version to test. Its VERY SLOW on my A4000T 060/PPC and looks like this when a page finally loads.






Quote from: chris;801164
Try http://homepage.ntlworld.com/cdyoung/tmp/netsurf_os3.lha

btw v3.4 of NetSurf isn't released yet. Anything versioned 3.4 is a post-3.3 development snapshot.
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline utri007

Re: NetSurf OS3.x Issues
« Reply #11 on: January 02, 2016, 12:46:46 AM »
-
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline fishy_fiz

Re: NetSurf OS3.x Issues
« Reply #12 on: January 02, 2016, 02:34:48 AM »
Not really sure what to advise here, but Arti's port of Netsurf works fine for me. By far and away the best browser for 68k amigas.
Chris's version is thus far next to unusable, but hopefully one day usability will be up to that of Arti's version.

Chances are you'll hear a bunch of crap about "sdl framebuffer, non-gui, debug, etc." while enquiring about 68k Netsurf. Ignore it. It'll come from Chris, who obviously is going to promote his own version, and from other people who don't really understand what theyre talking about parroting him. Ask said people what those terms even mean, or how they influence (or not) things and they wont be able to answer you (sans Chris, who understands, but twists and contorts truths so as to promote his own version), but give it a little time and they'll be parroting again  :-)

All in all though it's not a very good browser anyway compared to pretty much everything out there, but if you want a no frills, basic browser that renders partway correctly it's ok. Don't expect to be able to do even simple stuff like uploading images though. A complete lack of javascript makes these things nigh on impossible. Even 68k OWB is more capable.
« Last Edit: January 02, 2016, 02:41:51 AM by fishy_fiz »
Near as I can tell this is where I write something under the guise of being innocuous, but really its a pot shot at another persons/peoples choice of Amiga based systems. Unfortunately only I cant see how transparent and petty it makes me look.
 

Offline QuikSanz

Re: NetSurf OS3.x Issues
« Reply #13 on: January 02, 2016, 03:29:14 AM »
I wouldn't be so quick to dismiss Chris's work. He has made some steady progres
 

Offline Acill

Re: NetSurf OS3.x Issues
« Reply #14 on: January 02, 2016, 05:21:42 AM »
Quote from: QuikSanz;801175
I wouldn't be so quick to dismiss Chris's work. He has made some steady progres


Hope to see more of it too, it was nearly functional.
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics