Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: The Os 3.1.4 Thread  (Read 124800 times)

0 Members and 1 Guest are viewing this topic.

Offline NorthWay

 

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #166 on: October 04, 2018, 09:45:19 PM »
Yes, this was fixed.
 

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #167 on: October 04, 2018, 09:48:09 PM »
So if I took an IDE CD-ROM and connected it to an A4000D's IDE port it should theoretically work just with the CDFS that is included in 3.1.4?
I haven't tested, but ATAPI is there, and SCSI support is also there in CDFS.

Offline Amon_RA

Re: The Os 3.1.4 Thread
« Reply #168 on: October 04, 2018, 10:47:45 PM »
You need to update the installation readme.

For installing the new intuition library you also need to copy the loadmodule from the modules file

It also seems like you need to do
C:LoadModule module libs:intuition.library

as romupdate will stop once it finds out filesystem is already v 46

I found the same issue. Loading it via LoadModule ROMUPDATE just doesn't work (pure bit correctly set).
 

Offline BozzerBigD

Re: The Os 3.1.4 Thread
« Reply #169 on: October 04, 2018, 11:42:58 PM »
@Thomas Richter
Quote
No. Many components included in 3.1.4 are more advanced than those shipped with 3.9. All the datatypes are post-3.9, the workbench and icon library are post-3.9, all libraries are post-3.9, the printer device is a hybrid, and the preferences are reworked 3.1 preferences as we do not have reaction. Some of the tools are also somewhere in between 3.1 and 3.9 such as the calculator, the clock, the icon editor, and HDToolbox.

Thanks. So it's a partial update with no Reaction but with better Datatypes , libraries etc? Why now if not to coinside with the Vampire? Why was a bug fix deemed necessary? The Vampire is the only fuel for Classic development so it's resonable to suspect Hyperion's rush is motivated by the Vampire and has caused them to instigate the update to the code for the new machines to increase cash flow at a difficult time for the company. That is an obvious assumption. What is less obvious is the real world benefits of installing O3.1.4 instead of OS3.9 with third party software? Is the plan to get third party developers to support OS3.1.4 going forwards instead of OS3.9? How many copies would need to be sold for ongoing development?
« Last Edit: October 04, 2018, 11:44:34 PM by BozzerBigD »
"Art challenges technology. Technology inspires the art."

John Lasseter, Co-Founder of Pixar Animation Studios
 

Offline ronniebeck

Re: The Os 3.1.4 Thread
« Reply #170 on: October 05, 2018, 08:28:56 AM »
.....Why now if not to coinside with the Vampire? Why was a bug fix deemed necessary? The Vampire is the only fuel for Classic development so it's resonable to suspect Hyperion's rush is motivated by the Vampire....
Why is any bug fix deemed necessary.  Maybe you mean "why was this bug fix done now and not years ago?".
Rush? The Vampire has been around quite sometime and Hyperion had, according to Wikipedia, to "an exclusive license to develop and market AmigaOS 4 and subsequent versions with the name AmigaOS" since 2009.  A blind man typing on his keyboard via a 4 meter long stick could produce a fix faster than that.  It is hardly a rush.  I would like to hear the motivations for 3.1.4 and why it comes now from horses mouth (Hyperion and the developers) rather than pure speculation.  The guys behind the development are well known and well respected within the community.  Maybe they could explain their own motivations behind this here (if they haven't already).

How many copies would need to be sold for ongoing development?

Yes how many indeed.  If sales revenue of 3.1.4 could ever be commercially interesting.........
 

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #171 on: October 05, 2018, 11:33:45 AM »
Thanks. So it's a partial update with no Reaction but with better Datatypes , libraries etc?
Yes.

Why was a bug fix deemed necessary?
Huh? "Necessary"? Look, once again, I cannot tell you why you want the update or not. It was necessary because there are plenty of bugs or annoyances in the distribution, including the latest Os 3.9. For example the 4GB boot partition necessary with 3.9 is such an annoyance that will go away. The reboot will go away. The printer.device will work again.... there are plenty small bugs here and there.

The Vampire is the only fuel for Classic development so it's resonable to suspect Hyperion's rush is motivated by the Vampire and has caused them to instigate the update to the code for the new machines to increase cash flow at a difficult time for the company.
Oh my. Seriously... 3.1.4 is hardly on a rush. The whole thing is under development for 3 years now, so nobody was on a rush creating it. The original idea, put forward by Olaf back then, was to fix only seriously broken issues of 3.1 such as the HDToolbox which could not handle partitions or drives larger than 4GB. Actually, while at it, more and more components were reviewed and fixed. The whole thing is completely unrelated to the Vampire at all. It is a bugfix release that really went overboard because much more was touched than originally planned. 3.1.4 should have been a much smaller release in the beginning, but issue after issue appeared.

Is the plan to get third party developers to support OS3.1.4 going forwards instead of OS3.9?
I'm sorry, I really don't get your attitude. There is no "instead of". 3.1.4 is not incompatible to 3.9. So an application running on 3.1.4 will surely work on 3.9 as well. An application running on 3.9 that does not depend on reaction also works on 3.1.4. We'd love to include reaction, but we cannot.

How many copies would need to be sold for ongoing development?
No company would publically discuss its long term product and management strategy, not even with its developers. This is a management issue, not a development issue. I'm not a Hyperion employee, and even if I would, I wouldn't know the plans of the management. My best guess is that Hyperion doesn't know at this point either, and by best guess is that it would be rather stupid to stop a product line if it sells well. How well is "good enough" I can hardly tell and it is not on me to make this decision. It is a decision that will most likely be taken as soon as the plans for yet another release are on schedule. It's a little bit early to do that as even this one hasn't been rolled out completely (i.e. physical ROMs and disks).

Offline ronniebeck

Re: The Os 3.1.4 Thread
« Reply #172 on: October 05, 2018, 11:42:10 AM »
Is the plan to get third party developers to support OS3.1.4 going forwards instead of OS3.9?
I'm sorry, I really don't get your attitude.

Me neither.  From my perspective, the update is a welcome release and much appreciated by myself.  Thank you! Nice work!  :-)
 

Offline stefcep2

Re: The Os 3.1.4 Thread
« Reply #173 on: October 05, 2018, 12:43:47 PM »
Well done Thomas and the team. Another option for users is always good.

@ronniebeck: don't buy it.  you won't be happy

Offline madgrizzle

Re: The Os 3.1.4 Thread
« Reply #174 on: October 05, 2018, 02:11:51 PM »
You posted this on your bug fix thread (I didn't want to post there...)

"First, if you have a 060 processor, you no longer need an F-Space fix to turn off the FPU. Exec no longer crashes on a 060 FPU. Yet, you still need the 68060.library to enable it. This was to avoid incompatibilities."

So if I understand this correctly, when physical roms are available, they will work as is with my 3000 and 3640 w/060+FPU.  Correct?  This "F-Space fix" is what was done to the ROM I used currently?  I know I can thick, but I'd hate to purchase something (when available) to find out I'm wrong.
Only Amiga *woo-woo* Makes It Possible
Only Amiga   ... Makes.. It .. Happen!
Amiga 2000, 2MB Chip RAM, OS3.9, GVP Combo 030/22 13 MB, Supra 4MB
Amiga 3000, 16 MB RAM, OS3.9, A3640 v3.2 with 060 Processor, Picasso II, A2065, PCD-50B
Dead VA2000/CX :(
 

Offline vxm

Re: The Os 3.1.4 Thread
« Reply #175 on: October 05, 2018, 02:19:02 PM »
First, thanks for your fantastic work!
Is it planned to include the latest upgrades of the OS39 Shell-seg?
« Last Edit: October 05, 2018, 02:22:30 PM by vxm »
 

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #176 on: October 05, 2018, 02:30:44 PM »
So if I understand this correctly, when physical roms are available, they will work as is with my 3000 and 3640 w/060+FPU.  Correct?
Yes, though you still need to install a 68060.library. There is none included, but you know where to find one.

This "F-Space fix" is what was done to the ROM I used currently?
The F-Space fix was something vendors did to work around the issue in exec, i.e. such a fix is on all 060 cards I'm aware of. Of course, it does not apply if you hacked up a 040 card with a 060 adapter. Such cards will now work out of the box, a 68060.library provided.

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #177 on: October 05, 2018, 02:34:30 PM »
First, thanks for your fantastic work!
Is it planned to include the latest upgrades of the OS39 Shell-seg?

3.1.4 includes Shell V46, which is (of course) based on the V45 shell. There is one new feature in the shell which is not part of the V45 shell, and that is "pipes". There is no external "Pipe" command required anymore, and components have been updated to work with pipes. So for example, the following

Code: [Select]
list | sort | more

gives you a sorted directory listing that is paged through "more". In addition to the "|" pipe, we have "||" for concatenation, and "(" for grouping. Actually, "(" is a built-in command. So you can write things like

Code: [Select]
( list || dir ) | more
which concatenates the output of list and dir, and then pages it through more.


Offline nicholas

Re: The Os 3.1.4 Thread
« Reply #178 on: October 05, 2018, 02:46:13 PM »
Anyone know why the Hyperion page still charges VAT for those that live outside the EU?

Source

Only Hyperion's "fullfillment partner" will respond to that apparently.

#6

Not exactly an explanation, but I recently learned how complicated the VAT issue has become for services rendered and goods delivered both within the European Union and from the European Union to non-member states. In my opinion it is quite likely for a payment processor such Avangate to slip up here.

Within the European Union the VAT added on top of the net price used to be the rate current in the country from which it was sold. For example, with the seller in Germany the standard rate of 19% VAT rate would be applied to a customer in Denmark. This was changed recently, and now the VAT rate of the customer has to be applied to the net price, e.g. for a seller in Germany and the customer in Denmark, the standard rate of 25% would have to be applied. Sounds sufficiently complicated, and it certainly is (and gets more so because you have to keep track of the specific payments made and the taxes you charged on top of the net price). It gets more complicated still because of exceptions the individual countries apply to taxation. Luckily, these tend not to affect services and goods rendered through payments made through online service because this has been standardized.

It gets really tricky when you sell from the European Union to a non-member state such as Switzerland or Norway. Services and goods may be taxed differently or not at all, for example. So the buyer may have to pay import taxes on floppy disks and EPROMs, but not on the digital download which contains the same information as the floppy disks and EPROMs (or it might be a reduced tax rate).

There's plenty of opportunity for things to go wrong.

The payment portal thinks it's clever and uses geolocation on your IP. I disabled my VPN and it didn't charge me VAT.

It's been an hour though and I still haven't received a confirmation email let alone the actual OS files.

Patience isn't my strong point though lol
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini
 

Offline nicholas

Re: The Os 3.1.4 Thread
« Reply #179 on: October 05, 2018, 03:05:34 PM »
Is it possible to make a Super Kickstart Disk with the A3000 ROM images using your tool Olsen?


http://aminet.net/package/util/misc/MakeSuperDisk
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini