Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: WinUAE writing HDD images to CF card  (Read 541 times)

0 Members and 1 Guest are viewing this topic.

Offline arongooch

WinUAE writing HDD images to CF card
« on: January 16, 2020, 10:36:55 AM »
Hi all,

Got an issue with writing a WinUAE HDD image to a CF card.

So basically for the last few years and on different systems like my A2000 with SCSI2SD or my A600 with CF to IDE adapter, I have been able to write and read a whole CF or SD card image to and from my PC. So I set the card up the way I like on the real machine, backup the card to my PC as a HDD image and it loads in WinUAE etc then if I wish to write it back I use Win32DiskImager to write the image back to the card. For quite some time ive had no problems with this and it always works on the real machine. Very convenient for backing up system drives.

So my problem. Recently I got an ACA500Plus for my A500 machine. I wrote out a 4GB HDD image of WB3.1 full of WHDLoad games etc like ive done with said A600 and A2000 machines, put the CF card in my ACA and sure enough it boots up and works to some degree. After running for a few minutes I start to get checksum errors and read/write errors on the drive. At first I thought it was because I had super high CPU speed of 41MHz selected but reimaging the CF once it goes corrupt and trying more sensible CPU speeds of 14MHz still yields the same results, a corrupt HDD. It gets that bad it eventually destroys the entire partition and I have to image and start all over again. Ive tried messing with the global settings CF PIO mode but I still get these issues.

As mentioned, ive been using this method on my A2000 with A2091 and SCSI2SC adapter and my A600 with IDE to CF arrangement for quite some time and those machines don't have a problem with the drives becoming corrupt on the real machine.

Interestingly enough, once the drive has checksum errors etc and I put the CF card in the reader on my PC and open the drive in WinUAE ie boot from the CF card live the exact same errors and issues present themselves running in WinUAE. It seems to suggest for some reason my ACA500 setup somehow is corrupting the drive when running.

Any ideas what might be going wrong here? Appreciate any suggestions.
 

Offline efrenmgp

Re: WinUAE writing HDD images to CF card
« Reply #1 on: January 16, 2020, 02:34:28 PM »
Just to try to narrow it down... does this happen with different CF Cards regardless of their age / brand? Or is it just one particular card?
 

Offline Thomas

Re: WinUAE writing HDD images to CF card
« Reply #2 on: January 16, 2020, 05:49:41 PM »
After running for a few minutes I start to get checksum errors and read/write errors on the drive.

Do you say you get checksum errors by just *reading* from the CF card (running programs, starting games and so on) or do you do heavy copy operations after you put the card into the Amiga?

And it only starts after a certain time? Such as you run program A and it works ok and a few minutes later you run program A again and it fails to load?

Are there certain actions which trigger the errors?

If after the first boot you leave the Amiga running for a few minutes and only then start testing, do the errors appear immediately? (which might indicate a heat issue)

Did you set MaxTransfer to a good value for all partitions (0x1fe00 is a good value for example).


Offline arongooch

Re: WinUAE writing HDD images to CF card
« Reply #3 on: January 17, 2020, 05:24:00 AM »
Unfortunately ive only got this CF card handy but I could probably dig my A600 one out and see if it does the same thing. That system is a 3.1.4 setup so would have to reimage the drive etc. Worth a try though. Also the CF card im using now in my ACA500 is a supplied AmigaKit CF card (unknown brand?) but has shown to work perfectly fine in my A600 without issue but of course I do realise this is a different setup to that.


I should have specified that more. I get Checksum errors when I try writing to the drive i.e. editing a startup-sequence etc or general copying/moving files. This eventually leads to general read/write errors later on, so for example say I tried to open a program Hippo Player after the mentioned Checksum errors earlier then I get the general Workbench Read/Write error for the drive. It then degrades rather quickly the more I play around with the drive, usually from writing data, to a point where the drive ends up becoming not a dos disk anymore and I cannot read it at all and the system wont boot. The drive is setup as FFS. There are 2 partitions of around just under 2GB each. I thought this might be a problem running with FFS but I have my A2000 setup that has the exact same setup and runs perfectly fine with FFS and these size partitions and the upgraded roms for the A2091 card. The max transfer is set to 0xfffffe, perhaps this could be an issue? Im going to rebuild the CF card as a drive again on the real machine so might try a max transfer of 0x1fe00 as you suggest.
 

Offline arongooch

Re: WinUAE writing HDD images to CF card
« Reply #4 on: January 17, 2020, 05:48:30 AM »
A little additional information. I just tried using the ACA500Plus inbuilt installer utility to format the CF card and install WB3.1 onto. Running that it gets half way through the installation and comes up with a PFS-III Error Requester saying "Device: CF1: ALERT: Wrong ablock id". I tried this install using different CPU speeds and CF PIO settings but all fail the installation at the same point. I really am suspecting an issue with this particular CF Card with the ACA500Plus now. Might have to look at trying a different CF Card when I get the chance. Could be what is causing the issue all along I suspect.
 

Offline arongooch

Re: WinUAE writing HDD images to CF card
« Reply #5 on: January 25, 2020, 08:26:13 AM »
Ok, if anyone reads this in the future, the problem was infact the CF card I was using. It looks like efrenmgp was onto something there. That particular CF card works in other systems with no problems but on the ACA500Plus it becomes corrupt before too long. Buying a brand new SanDisk 16GB 333x CF card for the ACA500Plus completely fixed the problem. It certainly looks like the ACA500Plus can be picky with its CF card types.