Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: Amiga 4000D fast ram issue  (Read 694 times)

0 Members and 1 Guest are viewing this topic.

Offline arttu80

Amiga 4000D fast ram issue
« on: February 27, 2019, 07:12:30 PM »
If anyone have time to read my previous related topic, will have better understanding what's going on...;

https://forum.amiga.org/index.php?topic=73939.0

Well, after taking Amiga apart (again), I actually did not find any visible issues using continuity tester, except got RTC working reliably after found one more damaged trace near battery. I assembled it again and left only Chip RAM simm in the socket, it booted allright. After that, I installed other Fast RAM simms, and it did same crashing after setpatch was run while executing other startup-sequence commands. Well, removed these and installed only BigRamPlus card with exact same result!
So, is there possibly any reasonable way to troubleshoot this problem? I'm thinking, can A3640 (recapped, Rev 3.1)be at fault somehow? Because before setpatch command it runs flawlessly...
 

Offline arttu80

Re: Amiga 4000D fast ram issue
« Reply #1 on: May 11, 2019, 09:24:26 PM »
After using Amiga for some time, one day it finally gave up on RTC, so now I have NO real time clock in my machine, which buggers me quite a bit.. On the bright side, AOS 3.1.4 now boots without any crashes, so stability issue was indeed related to RTC circuit. Now I go figure out and make RTC present again. Maybe try to change new latch chip (U177), as it had corroded pins.