Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: GVP SCSI Guru ROM  (Read 1825 times)

0 Members and 1 Guest are viewing this topic.

Offline Cyberus

GVP SCSI Guru ROM
« on: February 03, 2004, 04:00:18 AM »
I thought 4.13, or 4.31 or whatever was the latest version. In fact, still available from gvp.
So what's this?

http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=2783825954&category=8142
I like Amigas
 

Offline voxel

Re: GVP SCSI Guru ROM
« Reply #1 on: February 03, 2004, 07:32:14 AM »
It's Ralph Babel's OmniSCSI device in a rom adaptater for the GVP scsi controlers.

With that you can use HDs of more than 4 Gb capacity and you will not have any of the transfers problems the GVP controller had. :-)

I have the model for my A2091 and it's great!
Amigalement,
Jean-François Bachelet, Amiga nuts since 1985.
-------------------------------------------------
Welcome to Happy Computing : Amiga! (© 2K4-2K8 voxel)
 

Offline Cyberus

Re: GVP SCSI Guru ROM
« Reply #2 on: February 03, 2004, 01:23:58 PM »
Thanks for your reply.

So I can stick this in my old GVP A500 HD-8 Series II, and use HDs bigger than 4GB with KS1.3?
Does it improve transfer speeds?
I like Amigas
 

Offline voxel

Re: GVP SCSI Guru ROM
« Reply #3 on: February 06, 2004, 01:29:44 PM »
Never tryied that, but I don't think so as only the gvpscsi.device is "upgraded", to handle over 4Gb drives you need a filsystem able to do it too, and wb1.3 is too old in my opinion.

But trying it would not cause any harm, you could just have a not working controler, reverting to the old rom would do it to work again in that case :-)
Amigalement,
Jean-François Bachelet, Amiga nuts since 1985.
-------------------------------------------------
Welcome to Happy Computing : Amiga! (© 2K4-2K8 voxel)
 

Offline machinehead

Re: GVP SCSI Guru ROM
« Reply #4 on: February 08, 2004, 03:21:16 AM »
Now that you mention GVP HD8+, I have to ask you a question.
Why is my GVP HD8+ giving errors such as"
"Unexpected Status $06 $07" ?
It is trashed I think, but maybe I am doing something wrong?
 

Offline voxel

Re: GVP SCSI Guru ROM
« Reply #5 on: February 08, 2004, 11:13:19 AM »
Hi machinehead :-)

>It is trashed I think, but maybe I am doing something wrong?

Not at all :-) it's one of the reason that makes we needed the Guru Rom upgrade, just another bug of the GVPSCSI.device ;-).
Amigalement,
Jean-François Bachelet, Amiga nuts since 1985.
-------------------------------------------------
Welcome to Happy Computing : Amiga! (© 2K4-2K8 voxel)
 

Offline thebajaguy

Re: GVP SCSI Guru ROM
« Reply #6 on: August 29, 2018, 03:40:19 AM »
Actually, gvpscsi.device v4.x forms the basis for GuruROM, with the latter supporting SCSI Sync on the 33C93A.  v3.x is the same as v4.x (for the A500/A2000 Zorro boards), but the earlier version level supports the buffered DMA Series I boards.  The 4.x series removed the old card support to make room for the newer CPU+SCSI+RAM products.  GuruROM makes use of the adapter as the driver code to support both controllers and Sync exceeds 16K, which is the available space provided for ROM on the A2091 and GVP Series II boards.

If Unexpected Status errors are coming up, SCSI termination is probably at fault (or a bad cable), and GuruROM will encounter the same thing, if not be worse due to speed.

« Last Edit: August 29, 2018, 03:42:25 AM by thebajaguy »
Former GVP Tech Support 1989-1993 - Bloodied in the original trenches of the Amiga Wild Wild West.