Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: NetSurf 3.4 released!  (Read 2272 times)

0 Members and 1 Guest are viewing this topic.

Offline chris

NetSurf 3.4 released!
« on: February 22, 2016, 08:31:14 AM »
NetSurf is a small, fast CSS capable web browser for AmigaOS and other platforms.

NetSurf 3.4 features many optimisations to improve performance over previous releases. It also contains many bug fixes, including improvements to page layout. This is also the first release to contain the Duktape JavaScript engine. While our JavaScript bindings have seen a lot of development for this release, JavaScript remains disabled by default as the support is incomplete. We recommend all users upgrade to NetSurf 3.4.

*** Download (AmigaOS 4) ***

Additionally I have released a beta version of an AmigaOS 3.5+ build based on the AmigaOS 4 native frontend.  I need help to improve this.  Download (AmigaOS 3.5/9)
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline Dandy

Re: NetSurf 3.4 released!
« Reply #1 on: June 24, 2016, 01:14:29 PM »
Quote from: chris;804398


NetSurf is a small, fast CSS capable web browser for AmigaOS and other platforms.
...
Additionally I have released a beta version of an AmigaOS 3.5+ build based on the AmigaOS 4 native frontend.  I need help to improve this.  Download (AmigaOS 3.5/9)



How is the speed of this "beta version of an AmigaOS 3.5+ build" on an Amiga 4000 with CSPPC (MC68060@50mHz/PPC604e@200mHz; 128 mB ram) under OS 3.9/WarpOS 16.1?

Is an PUP/WarpOS version available or planned?

Is my hardware setup (see above) sufficiently fast, or does Netsurf only run fast enough on an AmigaForever/UAE environment on a fast WIntel box (i.e. Core i5 quadcore@3.2 gHz)?

If my hardware is sufficient, how can I help to improve Netsurf?
All the best,

Dandy

Website maintained by me

If someone enjoys marching to military music, then I already despise him. He got his brain accidently - the bone marrow in his back would have been sufficient for him! (Albert Einstein)
 

Offline Acill

Re: NetSurf 3.4 released!
« Reply #2 on: June 24, 2016, 02:58:10 PM »
Chris,  since it's you're now able to setup WinUAE with a CSPPC I would love to see you compile builds for WarpOS too. I'd be glad to test them for you.
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline chris

Re: NetSurf 3.4 released!
« Reply #3 on: June 24, 2016, 04:35:05 PM »
Quote from: Dandy;810310
How is the speed of this "beta version of an AmigaOS 3.5+ build" on an Amiga 4000 with CSPPC (MC68060@50mHz/PPC604e@200mHz; 128 mB ram) under OS 3.9/WarpOS 16.1?

No idea, try it.  It should run OK.

Quote
Is an PUP/WarpOS version available or planned?

Nope.

Quote
If my hardware is sufficient, how can I help to improve Netsurf?

Report bugs, fix code :)

Quote from: Acill;810311
Chris,  since it's you're now able to setup WinUAE with a CSPPC I would love to see you compile builds for WarpOS too. I'd be glad to test them for you.

That's not the problem, I need a compiler which can build for WarpOS and have absolutely no idea how to set one up (and I really, really, don't want to have to set up a third build environment to do this - ie. I'd like my gcc to build both 68k and WarpOS code if possible).
« Last Edit: June 24, 2016, 04:38:02 PM by chris »
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline utri007

Re: NetSurf 3.4 released!
« Reply #4 on: June 24, 2016, 04:45:16 PM »
Chris: Test build is still unavaillable.

Dandy: Test build is quite much faster than aminet build, but it requires guicfx and render libraries from aminet. It has color problems with AGA

RTG systems you need to edit user/choises file manually and add friend_bitmap:1 to get colors displayed correctly.

Problem with both builds is memory fragmention / memory leak wich slows down surfing after few pages.

Generally saying, it is fast amiga.org is displayed less than 20 seconds.
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline chris

Re: NetSurf 3.4 released!
« Reply #5 on: June 24, 2016, 05:53:49 PM »
Quote from: utri007;810317
Chris: Test build is still unavaillable.

Turns out Virgin Media have closed down webspace without telling me.

Try here: http://cy2.uk/netsurfos3

That could be an old or broken version, I didn't look.
« Last Edit: June 24, 2016, 05:56:40 PM by chris »
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline Dandy

Re: NetSurf 3.4 released!
« Reply #6 on: July 12, 2016, 06:18:15 PM »
Quote from: utri007;810317


...
Dandy: Test build is quite much faster than aminet build, but it requires guicfx and render libraries from aminet.



O.K. - I downloaded and extracted Netsurf 3.6 dev and copied the ENV-content to envarc:. Then I rebooted. I also have the guigfx.library_68060 and the render.library_68060 in Libs:.
But when I try to start Netsurf, nothing happens. Tried it via DOpus and by clicking the icon. Nothing.
But I made SnoopDos logs of both approaches. If anone can see from the logs what goes wrong I can mail them. Just send mew an PM with e-mail address.

Quote from: utri007;810317


It has color problems with AGA



No problem - I use a Voodoo 4 in my Mediator in my towered A4k with CSPPC. 128 mB RAM, OS 3.9 with BBs 1 & 2/WarpOS 16.1.

Quote from: utri007;810317


RTG systems you need to edit user/choises file manually and add friend_bitmap:1 to get colors displayed correctly.



Hmmm - I cannot find this file in the extracted directory.

Quote from: utri007;810317


Problem with both builds is memory fragmention / memory leak wich slows down surfing after few pages.



Well, my problem is to get it running first...

Quote from: utri007;810317


Generally saying, it is fast amiga.org is displayed less than 20 seconds.



As I said - I have to get it running first...
All the best,

Dandy

Website maintained by me

If someone enjoys marching to military music, then I already despise him. He got his brain accidently - the bone marrow in his back would have been sufficient for him! (Albert Einstein)
 

Offline utri007

Re: NetSurf 3.4 released!
« Reply #7 on: July 12, 2016, 06:33:37 PM »
You need to rename those libraries. Remove _68060 from end.

New version :

http://cy2.uk/netsurfos3

Didn't you use installer?
« Last Edit: July 13, 2016, 01:17:58 AM by utri007 »
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline chris

Re: NetSurf 3.4 released!
« Reply #8 on: July 12, 2016, 07:49:28 PM »
Quote from: Dandy;811009
O.K. - I downloaded and extracted Netsurf 3.6 dev and copied the ENV-content to envarc:. Then I rebooted. I also have the guigfx.library_68060 and the render.library_68060 in Libs:.
But when I try to start Netsurf, nothing happens. Tried it via DOpus and by clicking the icon. Nothing.
But I made SnoopDos logs of both approaches

Run it with -v, it might give some clues. ("netsurf -v")
But try what utri007 suggests first!
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline Dandy

Re: NetSurf 3.4 released!
« Reply #9 on: July 13, 2016, 08:30:52 AM »
Quote from: utri007;811010


You need to rename those libraries. Remove _68060 from end.



Thanks for the hint! I will try this tonight...

Quote from: utri007;811010


New version :

http://cy2.uk/netsurfos3



Thanks for this info as well!

Quote from: utri007;811010


Didn't you use installer?



Ummm - which installer?
There was no installer included in the 3.6 dev Archive.
All there was was the instruction in the readme to copy all the content from the archive's ENV: Folder to Envarc: and the advice to edit a file (that I'm unable to locate in the achive) manually for the use with graphics cards.
No information on how to install NetSurf.
All the best,

Dandy

Website maintained by me

If someone enjoys marching to military music, then I already despise him. He got his brain accidently - the bone marrow in his back would have been sufficient for him! (Albert Einstein)
 

Offline Dandy

Re: NetSurf 3.4 released!
« Reply #10 on: July 13, 2016, 08:34:10 AM »
Quote from: chris;811011


Run it with -v, it might give some clues. ("netsurf -v")
But try what utri007 suggests first!



Thank you - I will try both!
All the best,

Dandy

Website maintained by me

If someone enjoys marching to military music, then I already despise him. He got his brain accidently - the bone marrow in his back would have been sufficient for him! (Albert Einstein)
 

Offline chris

Re: NetSurf 3.4 released!
« Reply #11 on: July 13, 2016, 10:38:30 AM »
Quote from: Dandy;811041
Ummm - which installer?
There was no installer included in the 3.6 dev Archive.
All there was was the instruction in the readme to copy all the content from the archive's ENV: Folder to Envarc: and the advice to edit a file (that I'm unable to locate in the achive) manually for the use with graphics cards.
No information on how to install NetSurf.


That's not my version.
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline utri007

Re: NetSurf 3.4 released!
« Reply #12 on: July 13, 2016, 10:45:21 AM »
Quote from: Dandy;811041

Ummm - which installer?
There was no installer included in the 3.6 dev Archive.
All there was was the instruction in the readme to copy all the content from the archive's ENV: Folder to Envarc: and the advice to edit a file (that I'm unable to locate in the achive) manually for the use with graphics cards.
No information on how to install NetSurf.


You have tested Arhurs fork, wich is based Framebuffer / SDL / version of  Netsurf, wich is meant to be used to debuggin and with no GUI systems ie. DOS. It uses ixemul libraries etc. It is hevily modified and original Netsurf team has asked that could it be renamed to something else than Netsurf. It works nicely with emulators.

Chris version is targeted to real Amigas.
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline wawrzon

Re: NetSurf 3.4 released!
« Reply #13 on: July 13, 2016, 03:55:35 PM »
@utri

could you stop bashing arturs work on each and every occasion just because you are involved with another option? it really doesnt make one want to help with it.
 

Offline wawrzon

Re: NetSurf 3.4 released!
« Reply #14 on: July 13, 2016, 03:59:07 PM »
edit:sorry, post in a wrong thread..