Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Help: Poseidon 4.5 MUI Stack Error  (Read 1289 times)

0 Members and 1 Guest are viewing this topic.

Offline Acill

Help: Poseidon 4.5 MUI Stack Error
« on: December 22, 2015, 04:12:41 PM »
When I installed Poseidon 4.5 on my A4000T with 3.9 BB1 and BB2 and MUI 3.9 I got a stack error from the MUI stack check at boot up. The first one was for Trident telling me the 8k was to low and it recommended 32400. So I went into prefs and took care of that in the icon information.

The 2nd one was for the Poseidon PopUp Notification App called (PoPO) which I have been combing through my system to find!!!! I cant locate this anywhere and I cant get my USB working and suspect its related to the warning.

Can anyone please tell me where to change the stack size for this Poseidon PoPo thing?
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline mechy

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #1 on: December 22, 2015, 07:56:21 PM »
Quote from: Acill;800578
When I installed Poseidon 4.5 on my A4000T with 3.9 BB1 and BB2 and MUI 3.9 I got a stack error from the MUI stack check at boot up. The first one was for Trident telling me the 8k was to low and it recommended 32400. So I went into prefs and took care of that in the icon information.

The 2nd one was for the Poseidon PopUp Notification App called (PoPO) which I have been combing through my system to find!!!! I cant locate this anywhere and I cant get my USB working and suspect its related to the warning.

Can anyone please tell me where to change the stack size for this Poseidon PoPo thing?

I thought this was part of the main stack program, its what pops up alerts. I think you can adjust it in the main program prefs,but unfortunately i cant help other than that. i had a few odd things happen with 4.5 so i dropped back to 4.4 and all is smooth.
 

Offline Acill

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #2 on: December 22, 2015, 08:10:49 PM »
I haven't even tried 4.4 but have it now. Can I just install it over 4.5 to replace it?
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline Oldsmobile_Mike

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #3 on: December 22, 2015, 10:23:24 PM »
I have Poseidon 4.5.  From what I recall I updated from 4.4 when I got my RapidRoad.  It wasn't much of a change, just a few classes and hardware drivers, more than anything, from what I recall.

For what it's worth, PoPo is started by PsdStackloader

Specifically, the command should be in your S:User-Startup file, as:

Code: [Select]
ENVARC:PsdStackloader
I confirm that commenting that command out kills the "PoPo" commodity on reboot.

I swear there was a setting for stack size somewhere within Prefs:Trident preferences program, but I'll be damned if I can find that now.

Will try to poke around a little more for you but am buried at work right now.  In any case, I wouldn't recommend rolling back to 4.4 - 4.5 does work!  ;)
« Last Edit: December 22, 2015, 10:29:04 PM by Oldsmobile_Mike »
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Oldsmobile_Mike

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #4 on: December 22, 2015, 10:28:20 PM »
Side thought - if you get the error message again can you take a screenshot?  Maybe that would help someone else identify where it was coming from?
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Acill

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #5 on: December 22, 2015, 10:34:51 PM »
Can try later yup.  Can do file uploads at work. Its an MUI error though. Specifically it reads:

MUI application "PoPo -- Poseidon Popup Provider"

The stack size of 8192 bytes is lower than the
recommended minimum size of 32000 bytes.
Please raise the stack size to at least 32000 bytes,
otherwise the application might crash unexpectedly.

Continue nevertheless                            Exit immediately
« Last Edit: December 22, 2015, 10:39:45 PM by Acill »
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline Oldsmobile_Mike

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #6 on: December 22, 2015, 11:31:39 PM »
Where did you get MUI 3.9?  I use a heavily updated 3.8 on my classics, and I think there's a 4.0 for MorphOS and maybe OS4.  I heard there was a 4.0 for classics but that it was unstable as h*** and had obscenely high system requirements.  I think 3.9 was just a beta.

I'd roll it back to stock 3.8 if possible, then if it works you can update the individual pieces later.

Edit:  I don't think your application is compatible with 3.9:  https://muidev.de/ticket/123
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Acill

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #7 on: December 23, 2015, 01:34:09 AM »
You can get 3.9 from the MUI dev site. Its here: https://muidev.de/downloads

Here is the screen shot as well.
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline Oldsmobile_Mike

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #8 on: December 23, 2015, 03:04:01 AM »
Roll back to 3.8.  I bet your problem will disappear.  ;)
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Oldsmobile_Mike

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #9 on: December 23, 2015, 07:06:00 AM »
Well hey, check this out:

http://aminet.net/package/util/boot/ShellUpdate

Just showed up on Aminet.  Do I think it will help you?  Probably not, but being as it's to correct bugs in stack size, it couldn't hurt.  ;)

And thanks, THoR!  :D
« Last Edit: December 23, 2015, 07:10:13 AM by Oldsmobile_Mike »
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Geit

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #10 on: December 23, 2015, 08:50:29 AM »
Popo ist a runtime created component in Poseidon. If you want to disable go to "poseidon settings (Trident)" and select "PopUps".  

There you can disable and modify the requesters as well as the audio output for usb connect/disconnect.

Disabling "PSDStackloader" of course disables the Popo stuff, because it disables the entire Poseidon USB Stack.
« Last Edit: December 23, 2015, 08:53:13 AM by Geit »
 

Offline Oldsmobile_Mike

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #11 on: December 23, 2015, 10:26:13 AM »
Quote from: Geit;800635
Popo ist a runtime created component in Poseidon. If you want to disable go to "poseidon settings (Trident)" and select "PopUps".  

There you can disable and modify the requesters as well as the audio output for usb connect/disconnect.

Disabling "PSDStackloader" of course disables the Popo stuff, because it disables the entire Poseidon USB Stack.

Yes. Point was that there's no separate executable for PoPo. No separate icon to adjust it's stack size. And unless I didn't look far enough, no option in Trident prefs, either. The amount of stack is hard-coded into the runtime with no option to change.

Still sticking with my previous suggestion: MUI 3.9 is a memory hog (as mentioned in the muidev link).  Try going back to 3.8 and see if that helps. ;)
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Acill

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #12 on: December 23, 2015, 02:59:03 PM »
I ended up using MinStack and setting it in my startup to 32400. Seems to have done the trick. I have USB working now as well. Although if I boot with anything in the USB ports my system will come up to workbench fine for about a half second and reboot by itself. If I take out all USB items it works fine and I can put my mouse or flash dive back in and all is well.

Strange stuff. As for MUI I need some help figuring out how to remove 3.9 so I can put in 3.8 because the 3.8 installer will tell you it has a more recent version installed.
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline mechy

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #13 on: December 23, 2015, 03:53:31 PM »
Quote from: Acill;800658
I ended up using MinStack and setting it in my startup to 32400. Seems to have done the trick. I have USB working now as well. Although if I boot with anything in the USB ports my system will come up to workbench fine for about a half second and reboot by itself. If I take out all USB items it works fine and I can put my mouse or flash dive back in and all is well.

Strange stuff. As for MUI I need some help figuring out how to remove 3.9 so I can put in 3.8 because the 3.8 installer will tell you it has a more recent version installed.

remove all the mui assigns in s:user-startup,reboot then delete the mui drawer.
that should allow you to do a fresh 3.8 install.
 

Offline Ancalimon

Re: Help: Poseidon 4.5 MUI Stack Error
« Reply #14 on: January 14, 2017, 12:21:56 AM »
I have encountered the same problem but I have inserted poseidon stack into my blizkick line (so it's inside my rom). What do you suggest to fix this problem?

I am using psdstackloader as a blizkick module. I wonder if there is a stack command that works inside blizkick and only for one file.
« Last Edit: January 20, 2017, 04:42:25 AM by Ancalimon »
A4000T, 604e@400&060@66, 128MB+16MB+Zorram256, CVisionPPC, VLabMotion, Toccata, XSurf100&RapidRoad, Prisma Megamix

A1200, Blizzard060@50, 256MB, Blizzard IV SCSI, FastATA mk4