Welcome, Guest. Please login or register.

AuthorTopic: LhA year 2011+ issues  (Read 4092 times)

0 Members and 1 Guest are viewing this topic.

Offline Piru

  • \' union select name,pwd--
  • Hero Member
  • *****
  • Join Date: Aug 2002
  • Posts: 6946
  • Total likes: 0
    • http://www.iki.fi/sintonen/
LhA year 2011+ issues
« on: January 02, 2011, 12:14:25 AM »
LhA archiver has a bug in it that results in year beyond 2010 to get archived as 1980. All Amiga LhA versions have this issue.

Until LhA fix is provided you should be aware of this issue for example when using LhA for backup purposes. Similarly you should be careful when uploading LhA archives to aminet or other collections.

MorphOS LhA 2.7.10 fixes this issue. MorphOS users can download the new LhA command from: http://www.morphos-team.net/downloads.html.

Other vendors will hopefully provide similar fixes soon.

UPDATE: AmiNET has new bug fixed LhA now: http://aminet.net/package/util/arc/lha_68k
« Last Edit: January 04, 2011, 03:21:17 PM by Piru »
 

Offline itix

Re: LhA year 2011+ issues
« Reply #1 on: January 02, 2011, 03:30:22 AM »
Now that was quick!
My Amigas: A500, Mac Mini and PowerBook
 

Offline HammerD

Re: LhA year 2011+ issues
« Reply #2 on: January 02, 2011, 05:18:01 AM »
Quote from: itix;603324
Now that was quick!

Actually it was at least a day too late for me :-/  Didn't see this until now.
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
 

Offline Matt_H

Re: LhA year 2011+ issues
« Reply #3 on: January 02, 2011, 05:35:23 AM »
Quote from: utri007;603310
When we get x86 version of morphos? x86 is future an we want to have future OS. I'm sure that Msi range of mobos would be good choise.

Currently morphops supports only DEAD mobos, that is not a good thing


Meanwhile, back on topic...

Thanks for the update, Piru et al.!
 

Offline ChaosLord

Re: LhA year 2011+ issues
« Reply #4 on: January 02, 2011, 06:05:08 AM »
Fast work Piru! :ThumbsUp:

Did you have to change the format of lha archives to implement the fix?

How did you fix it?

What year will the next lha bug strike?
Wanna try a wonderfull strategy game with lots of handdrawn anims,
Magic Spells and Monsters, Incredible playability and lastability,
English speech, etc. Total Chaos AGA
 

Offline Piru

  • \' union select name,pwd--
  • Hero Member
  • *****
  • Join Date: Aug 2002
  • Posts: 6946
  • Total likes: 0
    • http://www.iki.fi/sintonen/
Re: LhA year 2011+ issues
« Reply #5 on: January 02, 2011, 10:27:13 AM »
Quote from: ChaosLord;603341
Did you have to change the format of lha archives to implement the fix?
No.

Quote
How did you fix it?
There was a bogus comparison against the datestamp year being greater than 2010. I can only presume the original author meant 2100. Anyhow, now it correctly compares against 2107 which is the last year the date format used can present.

Quote
What year will the next lha bug strike?
2108 the latest.
« Last Edit: January 02, 2011, 10:32:44 AM by Piru »
 

Offline ChaosLord

Re: LhA year 2011+ issues
« Reply #6 on: January 02, 2011, 10:50:09 AM »
@Piru
Quote
There was a bogus comparison against the datestamp year being greater  than 2010. I can only presume the original author meant 2100. Anyhow,  now it correctly compares against 2107 which is the last year the date  format used can present.
Thanx for the .info!


@All Haxx0rz out there:
Can anyone hackpatch the old lha v1.38r 680x0 asm coded version?

The 1.3x series of LHA commands by Stefan Boberg were coded in asm and were noticeably faster than the lha 2.x series coded in C by various ppl.

I need a lha1.3x for use on slow old Real Amigas.  Thanx a Megabyte! :)
Wanna try a wonderfull strategy game with lots of handdrawn anims,
Magic Spells and Monsters, Incredible playability and lastability,
English speech, etc. Total Chaos AGA
 

Offline Cosmos

Re: LhA year 2011+ issues
« Reply #7 on: January 02, 2011, 12:00:20 PM »
Ok, I'll fix the 68k version...

The lastest is the 2.12 ?

Offline Piru

  • \' union select name,pwd--
  • Hero Member
  • *****
  • Join Date: Aug 2002
  • Posts: 6946
  • Total likes: 0
    • http://www.iki.fi/sintonen/
Re: LhA year 2011+ issues
« Reply #8 on: January 02, 2011, 12:10:27 PM »
Quote from: Cosmos;603377
Ok, I'll fix the 68k version...

The lastest is the 2.12 ?
Don't bother with 2.x. There's already 2.15 being uploaded to aminet.

These are the versions that require binary patching:
http://aminet.net/util/arc/LhA_e138.run
http://aminet.net/util/arc/lha150r.run

You'll probably find the spot easily by looking for "cmp.s #2010,dn"
« Last Edit: January 04, 2011, 03:20:24 PM by Piru »
 

Offline whose

Re: LhA year 2011+ issues
« Reply #9 on: January 02, 2011, 01:20:35 PM »
No need for error prone patching using outdated versions of lha...

Sven Ottemann already made the necessary fixes, including the 68k version.

It will hit Aminet shortly.

OS4 version is in the upload queue of os4depot already.
 

Offline Cosmos

Re: LhA year 2011+ issues
« Reply #10 on: January 02, 2011, 01:31:23 PM »
Please, first, explain the bug : all .lha created with the v2.12 or the v1.38 give me the correct date : 2/2/2011

(WinUAE is used)

Offline Piru

  • \' union select name,pwd--
  • Hero Member
  • *****
  • Join Date: Aug 2002
  • Posts: 6946
  • Total likes: 0
    • http://www.iki.fi/sintonen/
Re: LhA year 2011+ issues
« Reply #11 on: January 02, 2011, 01:35:37 PM »
Quote from: whose;603383
No need for error prone patching using outdated versions of lha...

Sven Ottemann already made the necessary fixes, including the 68k version.

Did you read the post by ChaosLord?
 

Offline Piru

  • \' union select name,pwd--
  • Hero Member
  • *****
  • Join Date: Aug 2002
  • Posts: 6946
  • Total likes: 0
    • http://www.iki.fi/sintonen/
Re: LhA year 2011+ issues
« Reply #12 on: January 02, 2011, 01:37:40 PM »
Quote from: Cosmos;603384
Please, first, explain the bug : all .lha created with the v2.12 or the v1.38 give me the correct date : 2/2/2011
Both 1.38 and 2.12 give 1980 here. BTW 2/2 doesn't sound correct it's january still.
 

Offline whose

Re: LhA year 2011+ issues
« Reply #13 on: January 02, 2011, 01:41:44 PM »
@piru:

No, I referred to Cosmos.

I think that you should be able to perform the correct patches to the Boberg Amiga lha versions ;-)

Would be a nice move to still support unaccelerated 68k machines.
 

Offline Cosmos

Re: LhA year 2011+ issues
« Reply #14 on: January 02, 2011, 01:45:59 PM »
>Both 1.38 and 2.12 give 1980 here.

With WinUAE ??


> BTW 2/2 doesn't sound correct it's january still.

Oups... I wanna say 2/1 of course !