Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: MicroBotics M1230 XA - Any thoughts?  (Read 847 times)

0 Members and 1 Guest are viewing this topic.

Offline quarkx

MicroBotics M1230 XA - Any thoughts?
« on: May 26, 2009, 07:31:49 AM »
In the other thread, I mentioned that I had got a M1230 XA. Anyone has this Card? Thoughts? Input?
Is the Driver disk called "MBX 1200"?
Can I use EDO ram in it?
I have Amiga stuff for sale at http://amigalounge.com. You can follow my builds there also.
 


Offline quarkx

Re: MicroBotics M1230 XA - Any thoughts?
« Reply #2 on: May 26, 2009, 08:22:36 AM »
I have Amiga stuff for sale at http://amigalounge.com. You can follow my builds there also.
 

Offline MozzerFan

Re: MicroBotics M1230 XA - Any thoughts?
« Reply #3 on: May 26, 2009, 09:20:52 AM »
Yes, it can take EDO simms.

You only need the driver disk if you have 3.0 ROMS, because RAM isn't automatically recognized under 3.0 Under 3.1 the board autoconfigs.

If you get random lockups or gurus, try a heavier powersupply.
I used it with a "heavy" a500 PSU (the one with +5V @ 4.5A) with no problems.

I just recently bought the card, and my first impression is that it's a great card.
Haven't tested it much with games yet.

The only disadvantage is that you can't easily disable the card like you can with a Blizzard.
Regards,
Lloyd
 

Offline JimmySage

Re: MicroBotics M1230 XA - Any thoughts?
« Reply #4 on: May 26, 2009, 10:18:40 AM »
I have been running with one of these cards until very recently until I upgraded to an 060. Mine worked fine with the 128Mb SIMMS from AmigaKit.

For workbench 3.0 you need to run with AutoXA or AddXAMem in the startup to add the fast mem to the system. The software isn't needed on 3.1, but the config program is quite useful as it allows to you set the memory / processor type / speed, or reset the card back to the factory defaults. They can be downloaded from http://amiga.resource.cx/exp/mbx1230.

I had a few incompatabilities with WHDLoad though. Firstly you'll need to set both the NoAutoVec and NoMemReverse flags in your global config or you will get random crashes, and I never had much success with AGA games such as Banshee (though they all work with my Apollo 1260).

James
 

Offline AmigaHeretic

Re: MicroBotics M1230 XA - Any thoughts?
« Reply #5 on: May 28, 2009, 05:18:00 PM »
Yeah, that's the board I use to have in my A1200.  50mhz 030 and 50mhz fpu.  I believe it worked with EDO.  Had lots of different RAM though the thing.  Back then 2meg was expensive.  So I probably had a 2, 4, 8, and I think the largest I ever could afford was 16mrg.  Everything I threw at it worked.   There was a little program that had to be run at startup to get the RAM to be recognized with 3.0 rom.  Believe once I had the 3.1 rom it did this automagically :)

Totally rock solid and FAST!  Well, for a 50mhz 030 anyway.  

I'd buy one again if I had an A1200.
A3000D (16mhz, 2MB Chip, 4MB Fast, SCSI (300+MB), SuperGen Genlock, Kick 3.1)
Back in my day, we didn\'t have water. We only had Oxygen and Hydrogen, and we\'d just have to shove them together.
 

Offline quarkx

Re: MicroBotics M1230 XA - Any thoughts?
« Reply #6 on: May 28, 2009, 08:25:30 PM »
Thanks everyone.
I got it up and running yesterday. It will only see 16 megs of ram untill you run the config program in 3.9. the biggest stick I could find in my stash was a 32meg. Once the program was run, then you got a full 32. AutoXA wouldn't work at all (just an FYI) in 3.9
I have Amiga stuff for sale at http://amigalounge.com. You can follow my builds there also.