Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: PPS Mercury 040 install help  (Read 918 times)

0 Members and 1 Guest are viewing this topic.

Offline Ideal

PPS Mercury 040 install help
« on: December 04, 2008, 07:05:54 AM »
Recently aquired a PPS Mercury 040 for Amiga 3000.

However I am unable to find a manual for it anywhere online.

Does anyone know anything about this thing? What are the two connectors on the back of it that look like power connectors?

http://amiga.resource.cx/photos/mercury

PS: I have Ramsey 07 and DMac 04.
 

Offline Computolio

Re: PPS Mercury 040 install help
« Reply #1 on: December 04, 2008, 07:46:52 AM »

    They actually are power connectors. They provide power to the fan.
 

Offline Ideal

Re: PPS Mercury 040 install help
« Reply #2 on: December 04, 2008, 07:58:03 AM »
Ok, so they should both have floppy type power connectors connected to them? I was afraid they might be something else and I'd fry the card. Is it only power for the fan though?
 

Offline Computolio

Re: PPS Mercury 040 install help
« Reply #3 on: December 26, 2008, 12:16:40 AM »

    Only one should be plugged in. I think the leftmost one (as viewed from the pic on The Big Book) should be fine.
 

Offline rkauer

Re: PPS Mercury 040 install help
« Reply #4 on: December 26, 2008, 08:20:19 PM »
Quote

Computolio wrote:

    Only one should be plugged in. I think the leftmost one (as viewed from the pic on The Big Book) should be fine.


 Any of those connectors are fine. Take power from floppy power connector (motherboard or power supply), then hook a second power connector from the accelerator to the floppy itself.
Goodbye people.

I\'ll pop on from time to time, RL is acting up.