Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Error when Compiling UAE  (Read 1106 times)

0 Members and 1 Guest are viewing this topic.

Offline Emufreak

Error when Compiling UAE
« on: July 15, 2003, 11:55:54 AM »
I tried to configure UAE with the following options:

./configure --enable-ui

But I get an error who states that it wasn't possible to configure UAE with all the selected options. As I went to the output which was generated by the configure command I found a line who states, that gtk+ is not available and therefor the userinterface won't be configured.

So I went to yast to checkout wether gtk+ is installed and it is.  I also installed the development-package for gtk, but it didn't help.

If somebody could help i would really appreciate it.
 

Offline olegil

Re: Error when Compiling UAE
« Reply #1 on: July 15, 2003, 12:23:46 PM »
Under Debian, you need libgtk1.2 and libgtk1.2-dev

Since you never wrote ANYTHING about what system this is running on, check this again.

There's something odd about how configure-scripts detect gtk, they use the presence of a tool which I forget the name of to see if gtk is installed. I've cursed over this before :-)
 

Offline Emufreak

Re: Error when Compiling UAE
« Reply #2 on: July 15, 2003, 12:37:10 PM »
I use SUSE 7.1. But it could still be a problem with the version of gtk. How to I check the version of gtk. I can't find any Information about that in yast2.
 

Offline olegil

Re: Error when Compiling UAE
« Reply #3 on: July 15, 2003, 04:36:58 PM »
gtk-config --version will tell you what version is installed (this is the application used by the configure script, it can also tell you what compiler and linker options you need, automagically :-) ).

Check for the existence of /usr/include/gtk-1.2/gtk/ directory with header files (.h extension) to see if you have the right development package installed.
 

Offline Emufreak

Re: Error when Compiling UAE
« Reply #4 on: July 15, 2003, 10:02:13 PM »
There is a directory /usr/include/gtk with .h files and no subdirectorys. There is no /usr/include/gtk-1.2 directory. gtk-config --version returns 1.2.8. SO the Version of gtk seems to be alright. I looked at the error message a bit more closely and it states this:

The gtk-config script installed by gtk could not be found. If GTK was installed in PREFIX make sure PREFIX/bin is in your path, or set the GTK_CONFIG environment variable to the full path to gtk-config.

So I set the variable to /usr/bin where gtk-config is located. But it still brought up the same error.
 

Offline jack

Re: Error when Compiling UAE
« Reply #5 on: July 15, 2003, 11:32:02 PM »
Have you tried to remove config.cache if  exists?
"/usr/bin" is always component of  the path (if path contents weren't changed explicitly). It looks that you installed the  dev package after the first run of ./configure which  didn't picked it up after installation.
You can try  to remove the source directory and to start over  with clean one.

Jack
 

Offline Emufreak

Re: Error when Compiling UAE
« Reply #6 on: July 16, 2003, 09:01:46 PM »
Thanks!! This actually helped. After I deleted the file config.cache. Compilation went through fine.