Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: LhA year 2011+ issues  (Read 4222 times)

0 Members and 1 Guest are viewing this topic.

Offline Piru

  • \' union select name,pwd--
  • Hero Member
  • *****
  • Join Date: Aug 2002
  • Posts: 6946
  • Total likes: 0
    • http://www.iki.fi/sintonen/
Re: LhA year 2011+ issues
« Reply #15 on: January 02, 2011, 01:51:30 PM »
Quote from: Cosmos;603388
>Both 1.38 and 2.12 give 1980 here.

With WinUAE ??

No, MorphOS.

Just to clarify: the files added to the archive have a wrong year, not the archive file itself.
 

Offline XDelusion

Re: LhA year 2011+ issues
« Reply #16 on: January 02, 2011, 11:11:53 PM »
Thankx Twat!!! ;)

Sorry, that word is stuck in my head now.

Really though, thankx a lot for all you've done Piru!
Earth has a lot of things other folks might want... like the whole planet. And maybe these folks would like a few changes made, like more carbon dioxide in the atmosphere and room for their way of life. - William S. Burroughs
 

Offline ChaosLord

Re: LhA year 2011+ issues
« Reply #17 on: January 03, 2011, 06:10:41 AM »
Quote from: Cosmos;603388
Oups... I wanna say 2/1 of course !
On lha 1.38

lha a -rade t:Cosmos.lha #?

cd t:
lha x Cosmos.lha

Now look at the extracted files.  You will have just time travelled back to 1980. :lol:

Make sure not to use the -E option.  -E is different from -e and causes extracted files to be touched.



My lha2.12 has a -Or option that "skips datestamp check".   Does anyone know what that does?
Wanna try a wonderfull strategy game with lots of handdrawn anims,
Magic Spells and Monsters, Incredible playability and lastability,
English speech, etc. Total Chaos AGA
 

Offline hardlink

Re: LhA year 2011+ issues
« Reply #18 on: January 03, 2011, 07:08:50 PM »
Quote from: ChaosLord;603517
...  You will have just time travelled back to 1980. :lol:


Maybe not so bad - all the girls I knew then seemed like 30 years younger than the ones I know now.
On the other hand, no Amigas, just Jay Miner Atari 800's, which were fun at the time.
 

Offline fitzsteve

Re: LhA year 2011+ issues
« Reply #19 on: January 03, 2011, 10:58:59 PM »
Could this be why some file I UN-LHA'd today we're locking up my system?
 

Offline Piru

  • \' union select name,pwd--
  • Hero Member
  • *****
  • Join Date: Aug 2002
  • Posts: 6946
  • Total likes: 0
    • http://www.iki.fi/sintonen/
Re: LhA year 2011+ issues
« Reply #20 on: January 04, 2011, 03:04:10 PM »
Quote from: fitzsteve;603630
Could this be why some file I UN-LHA'd today we're locking up my system?

No
 

Offline Matt_H

Re: LhA year 2011+ issues
« Reply #21 on: January 04, 2011, 04:57:57 PM »
Fixed OS4, 68K and WOS versions are now on Aminet.
 

Offline Karlos

Re: LhA year 2011+ issues
« Reply #22 on: January 04, 2011, 05:40:40 PM »
Quote from: Matt_H;603795
Fixed OS4, 68K and WOS versions are now on Aminet.


Sweet.
int p; // A
 

Offline Mark

Re: LhA year 2011+ issues
« Reply #23 on: January 05, 2011, 01:52:30 AM »
Quote from: ChaosLord;603517

My lha2.12 has a -Or option that "skips datestamp check".   Does anyone know what that does?


I think that should be -Qr

Quote from: The Manual Included With All Versions of lha

       `-Qr' (add) Skip datestamp check  

          This option,  when  on, disables the datestamp comparison for
       the  update  (`u') and freshen (`f') commands, so that the files
       that  already  exist  in the archive will be replaced regardless
       of file modification dates.  

          This option is OFF by default for all commands but `r'.

 

Offline Sidewinder

Re: LhA year 2011+ issues
« Reply #24 on: January 09, 2011, 03:07:58 AM »
Quote from: ChaosLord;603372

@All Haxx0rz out there:
Can anyone hackpatch the old lha v1.38r 680x0 asm coded version?

The 1.3x series of LHA commands by Stefan Boberg were coded in asm and were noticeably faster than the lha 2.x series coded in C by various ppl.

I need a lha1.3x for use on slow old Real Amigas.  Thanx a Megabyte! :)


In version 1.38 the offending instruction is cmpi.l #$7DA,d6 and can be located at offset $BC1A.  The actual incorrect data is at offset $BC1E.

The simple fix is to load your favorite hex editor and change the 2 byte word at offset $BC1E from $07DA (2010) to $083B (2107).  This worked like a charm for me.

I did find another problem when listing the contents of an lha archive with v1.38.  The year portion of the date in the final summary line contains 3 digits, so that 08-Jan-11 reads as 08-Jan-111.  I've found the location of this bug in the code also.  It appears that the rounding function is not called when printing the date for the last line, but it is called when printing the archived files list.  I'm working on a fix for this also and I'll upload it when I'm done.
Sidewinder
 

Offline chris

Re: LhA year 2011+ issues - XAD issue
« Reply #25 on: January 09, 2011, 11:32:39 PM »
I forgot to post this here, and it hasn't been mentioned:

xadmaster.library's internal LhA has a bug which shows up when extracting archives created with the new LhA - spaces in filenames are converted to underscores.  A workaround is to use -H0 when creating archives.

The LhA client has been updated, MorphOS has the update already and OS4 users can download my externally-compiled version of the LhA client here.

OS3 users do not have a fix as yet.  Ideally, somebody needs to build xadmaster.library v13 for OS3; The source is available here.

Chris
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz