Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Total Chaos problems  (Read 2955 times)

0 Members and 1 Guest are viewing this topic.

Offline pubzombie

Total Chaos problems
« on: December 31, 2009, 04:47:10 PM »
Hi folks.
I am running Total Chaos from flashcard on my accelerated 1200. The first time i ran it it took about 10mins to compile but ran fine. However, when I try to run it now all the sound and music is badly distorted and i have to play it with the volume off. Any ideas whats going on here and how to fix it?
cheers for your time
PZ
The Truth is but a construct; empowering creator and subjugating consumer. Zombie Apocalypse now please
 

Offline SamuraiCrow

Re: Total Chaos problems
« Reply #1 on: December 31, 2009, 05:28:32 PM »
Check your AHI installation and preferences.  There were some experiments with trying to get retargetable audio working with Total Chaos but I don't know if any of them made it to a current release.

Also, the first time you run Total Chaos it takes a while to unpack all of the music files and sound samples except the music file it plays while it's unpacking.
 

Offline ChaosLord

Re: Total Chaos problems
« Reply #2 on: December 31, 2009, 05:57:49 PM »
In order to prevent the death of Aminet, all the audio in the game is supplied in a heavily compressed format.  This greatly reduces the archive filesize.

The first time you run the game, the game notices that the audio is compressed and decompresses it.  That was the 10 minute wait you experienced.

The only explanation for the problem you are experiencing is that the decompression process failed.

Ok, so the audio failed to decompress.  But why did it fail?

Hmmm....

What filesystem does your flashcard use?  FAT?
How much ram does your A1200 have?
Were you running other large programs at the same time that you first ran the game?

p.s. you can ignore AHI.  AHI is not allowed to affect the game.
Wanna try a wonderfull strategy game with lots of handdrawn anims,
Magic Spells and Monsters, Incredible playability and lastability,
English speech, etc. Total Chaos AGA
 

Offline pubzombie

Re: Total Chaos problems
« Reply #3 on: January 06, 2010, 01:39:10 AM »
Hi Chaos Lord,
I have fat32 file system, an 030 blizzard with maths co-processor and was booting using WBlite boot disk with the pcmia card attached. should i try deleting it and downloading a new copy?
thanx man
The Truth is but a construct; empowering creator and subjugating consumer. Zombie Apocalypse now please
 

Offline SamuraiCrow

Re: Total Chaos problems
« Reply #4 on: January 06, 2010, 01:46:38 AM »
The Fat32 filesystem doesn't support all of the Amiga-specific flags that are used by Total Chaos.  You'll have to reformat it to be an Amiga-compatible filesystem.  If you have another hard drive I'd suggest running it on the harddrive first and then exit right away and copy the entire unpacked directory to your flash card to save wear and tear on it.

Also, be sure that you use a version of LHA that compatibly unpacks large archives successfully such as the one contained in http://aminet.net/util/arc/LhA_e138.run .
 

Offline pubzombie

Re: Total Chaos problems
« Reply #5 on: January 06, 2010, 02:28:28 AM »
ahhh i see said the blind bat.
what do i need to do with the lha file you posted me.
noob alert!!!!
can i just reformat my flashcard and then copy all my files back across?
thanxs for your time
pz
The Truth is but a construct; empowering creator and subjugating consumer. Zombie Apocalypse now please
 

Offline SamuraiCrow

Re: Total Chaos problems
« Reply #6 on: January 06, 2010, 04:15:16 AM »
I'm not familiar with wblite.  If you link me to it I can give more exact instructions.

The LhA file I linked you to was a stable version of the LhA archiver.  To dearchive a file it would be something you first drag the .run file I pointed you to to the ram disk.  Then double-click the ram disk icon, from the Windows menu go to the Show item and select All Files from the submenu.  When workbench refreshes the window with all the icons visible, double-click the .run file you just dragged there.  There should pop up a requester with the filename that you just double-clicked on.  Click on the button that tells you to execute the program.  The .run file will uncompress itself onto the Ram Disk.

The next step is to copy the lha program to your boot disk.  To do that, highlight the window for your boot disk or if it isn't open, double click on your wblite disk.  If it looks empty, do the Show All Files menu thing again.  Drag the lha program from the RAM disk to the C directory.

Now comes the part I can't really steer you through by remote control:  reformatting your flash card.  On a standard workbench install there is a utility called HDToolbox that lets you reformat and partition hard-drive like devices.  I suspect wblite doesn't have it, in which instance you may be in trouble.

Before I try to help you through the rest of your install process, you'd better post more information about your system boot disk.
 

Offline F1Lupo

Re: Total Chaos problems
« Reply #7 on: October 06, 2010, 07:34:49 PM »
@ ChaosLord

I'm having trouble responding to you via PM as I tried twice but nothing shows up in my sent folder?? anyhow here's my response in case you didnt get the PM's:

"hehe ya I said before I wanted to play because I'm a big Ultima fan and Total Chaos looks better !
problem is right now I'm having problems with my IDE HD connector..can't  see any drive either old 3.5" or my 4GB cf card?? I have a Blizzard  030@50 with 32MB ram so hopefully thats enough juice to give her a good  go :-)

anyhow I tried loading it up with my OS4.1 machine under E-UAE but it hangs at the start screen??
any ideas on setings for UAE to make it run properly??

thanks,"
____________________________________________________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Indivision AGA & Catweasel MK4+= Amazing
! My Master Miggies-Amiga 1000 & AmigaOne X1000 !
--- www.mancave-ramblings.blogspot.ca ---
  -AspireOS.com & Amikit- Amiga for your netbook-
***X1000- I BELIEVE *** :angel:
 

Offline x303

Re: Total Chaos problems
« Reply #8 on: October 06, 2010, 09:55:42 PM »
Quote from: klx300r;583297
I'm having trouble responding to you via PM as I tried twice but nothing shows up in my sent folder??
That's because under 'edit options' you have to tick "Save a copy of sent messages in my Sent Items folder by default".
 

Offline F1Lupo

Re: Total Chaos problems
« Reply #9 on: October 06, 2010, 10:30:34 PM »
@ x303

ahh but that would make too much sense for the likes of me nowadays :-)
____________________________________________________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Indivision AGA & Catweasel MK4+= Amazing
! My Master Miggies-Amiga 1000 & AmigaOne X1000 !
--- www.mancave-ramblings.blogspot.ca ---
  -AspireOS.com & Amikit- Amiga for your netbook-
***X1000- I BELIEVE *** :angel:
 

Offline cgutjahr

Re: Total Chaos problems
« Reply #10 on: October 06, 2010, 10:51:09 PM »
Quote from: ChaosLord;535584
In order to prevent the death of Aminet, all the audio in the game is supplied in a heavily compressed format.  This greatly reduces the archive filesize.
What would be the size of an archive with uncompressed audio tracks?

Oh, and whats the shareware fee, btw.? Readme doesn't even mention it's shareware.
 

Offline ChaosLord

Re: Total Chaos problems
« Reply #11 on: October 07, 2010, 06:32:20 AM »
Quote from: cgutjahr;583339
Oh, and whats the shareware fee, btw.? Readme doesn't even mention it's shareware.
It isn't shareware. It is donation ware.

Quote
What would be the size of an archive with uncompressed audio tracks?
To be clear, it isn't just the music that is specially compressed, but also all soundfx and speech.  Without that compression the archive size grows by +35MB
Wanna try a wonderfull strategy game with lots of handdrawn anims,
Magic Spells and Monsters, Incredible playability and lastability,
English speech, etc. Total Chaos AGA
 

Offline ChaosLord

Re: Total Chaos problems
« Reply #12 on: October 07, 2010, 07:31:36 AM »
Quote from: klx300r;583297
@ ChaosLord

I'm having trouble responding to you via PM as I tried twice but nothing shows up in my sent folder?? anyhow here's my response in case you didnt get the PM's:
I got your pms but I was in tooo much pain to quickly type out any kind of an answer, sorry mate. :(


Quote
"hehe ya I said before I wanted to play because I'm a big Ultima fan and Total Chaos looks better !
That is because Total Chaos is better ;)

Once upon a time, back in 1984, I did have a dream of making an Ultima remake.


Quote
problem is right now I'm having problems with my IDE HD connector..can't  see any drive either old 3.5" or my 4GB cf card??
That is over my head.  I am just a lowly asm coder.  But there is a hardcore Total Chaos fan out there from Brazil who loves to help ppl with hardware problems.  Sadly, I think he might have quit Amiga.org :(


Quote
I have a Blizzard  030@50 with 32MB ram so hopefully thats enough juice to give her a good  go :-)
Yes, a lot of ppl play the game on such hardware with no complaint. :)

Of course I personally recommend an 060 for greatly improved framerate and special fx during large battles. :)


Quote
anyhow I tried loading it up with my OS4.1 machine under E-UAE but it hangs at the start screen??
What does the start screen say at bottom?
How do you know it has "hung"?

EUAE has no JIT so its virtual 680x0 cpu is very very very very slow.

The first time u run the game, all sfx and music and speech must be audio decompressed.  This takes 6 mins on a real Amiga but it could easily take 2 hours on EUAE.

Thankfully, the decompression is only done one time ever.  The 2nd time you start the game it is reasonably quick.

Quote
any ideas on setings for UAE to make it run properly??
I never used EUAE or UAE.  I only have used WinUAE.  When I play Total Chaos I use the following settings:
CPU 68020
FPU YES
Immediate Blits YES
64MB Fastram
8MB Chipram
Kicstart 3.1
AGA YES


Probably some other settings i forgot(?)

Here are some known ways to kill the game:
1. The OS4 Screenblanker will murder the game every time.  Delete it or the game will hang.

2. Trying to load the game without workbench will cause screwey flaws in the game.  Total Chaos is a 100% AmigaOS game.  It needs the OS running.

3. FBLIT will stop the game from working.

4. P96 will lock up the machine at some point when pressing Amiga-m/n so be sure your EUAE workbench is not running P96.

5. I can't remember anyone ever saying the game worked from an SFS partition.  So AFAIK SFS kills the game.  Total Chaos is guaranteed to work 100% perfectly from an FFS partition and has been reported to work perfectly on a PFS partition by many ppl.

6. The Evil Trojan known as Executive will lock up the game but this normally only happens when quitting.

7. All WindowToFront style hacks break the game.  But that only happens while playing the game, not at startup.

8. Trying to hijack the Total Chaos screen and force it into some other mode will completely break the game.

9. The OS4 GUI way of unlhaing files is bugged.  Ditto for OS3.  It does not actually extract ALL the files.  So if you want any large archive to work 100% you need to use the lha CLI command from the shell such as:
Code: [Select]
cd DOWNLOADS:
lha x TotalChaosAGAr6.lha
10. I suppose you could kill the game by starving it of HD space.  So please make sure you have at least 200 MB free space before you unlha the archive.

Making use of the above knowledge,
I advise you to delete your old TotalChaosAGA directory then freshly unlha the archive and run the game again.

Loads of ppl are having fun playing the game.  I know you can to. :)
« Last Edit: October 07, 2010, 07:56:20 AM by ChaosLord »
Wanna try a wonderfull strategy game with lots of handdrawn anims,
Magic Spells and Monsters, Incredible playability and lastability,
English speech, etc. Total Chaos AGA
 

Offline SamuraiCrow

Re: Total Chaos problems
« Reply #13 on: October 07, 2010, 03:09:33 PM »
Quote from: ChaosLord;583386
EUAE has no JIT so its virtual 680x0 cpu is very very very very slow.

The first time u run the game, all sfx and music and speech must be audio decompressed.  This takes 6 mins on a real Amiga but it could easily take 2 hours on EUAE.

Thankfully, the decompression is only done one time ever.  The 2nd time you start the game it is reasonably quick.

I never used EUAE or UAE.  I only have used WinUAE.  When I play Total Chaos I use the following settings:
CPU 68020
FPU YES
Immediate Blits YES
64MB Fastram
8MB Chipram
Kicstart 3.1
AGA YES


One comment:  EUAE on an Intel 32-bit machine has a JIT (eg. Intel Mac).  Running on AMD64 or PPC doesn't have a JIT.  It's for that reason that I never tried running it on my OS 4 box.
 

Offline Im>bE

Re: Total Chaos problems
« Reply #14 on: October 07, 2010, 08:11:20 PM »
I cant wait for the survival mode!!
Its gonna be AwEsOmE!!!!

WOOOOHOOOOO!!!!!
Hopelessly addicted to the world\'s best strategy game.
Total Chaos on YouTube