Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Internal floppy works, but not detecting new disks.  (Read 598 times)

0 Members and 1 Guest are viewing this topic.

Offline Beast96GT

Internal floppy works, but not detecting new disks.
« on: May 12, 2021, 04:22:46 AM »
Hello, when I boot my A4000 it reads/boots from a disk in the floppy drive no problem.  However, it will not detect when the disk is ejected and a new one popped it.    This is a fresh install of 3.1.4 (Thanks, Hyperion!).   Is there any thing user serviceable inside this drive I can mess with or do I just need to replace the drive?
 

Offline Matt_H

Re: Internal floppy works, but not detecting new disks.
« Reply #1 on: May 12, 2021, 06:11:50 AM »
It could be a problem with the cable or the motherboard, but I think the most likely explanation is that the drive is dirty after decades of service. If the drive is reading disks the read/write heads are probably fine, but some of the sensors could be blocked/stuck. If you feel confident enough to take the top cover of the drive off it should be easy to see where dust/dirt has built up. Pay particular attention to a series of little black posts. Give them a little scrub with a q-tip/cotton bud and isopropyl alcohol and they should free up. Be careful not to disrupt the read/write heads and thus misalign the drive.

Offline Beast96GT

Re: Internal floppy works, but not detecting new disks.
« Reply #2 on: May 12, 2021, 06:51:29 AM »
Thanks, Matt.   I just watched a handy video that pointed out the little black posts in the front left of the drive that you're talking about.    They suggested some contact cleaner, but I'm hoping you're right and it's just something small like this.
 

Offline Pat the Cat

Re: Internal floppy works, but not detecting new disks.
« Reply #3 on: May 12, 2021, 06:54:23 PM »
There is a workaround if you can't get the switch working properly (or whatever the fault is). Which would at least let you install onto hard drive.

Prior to running the install script, open up a shell. When you get the prompt to change disks, do so, then get the shell window to the front, and type

Diskchange DF0:

Then hit the return key. That prompts the Amiga to update and re-read the floppy contents.

It does mean flipping back and forth, clicking on the requesters and the shell window. Handy use for multitasking though.

Type

Endcli

and hit return when you are finished with the shell window.
"To recurse is human. To iterate, divine."

A1200, Vanilla, Surf Squirrel, SD Card, KS 3.0/3.z, PCMCIA dev
A500, Vanilla, A570, Rev 5, KS 1.2/1.3 Testbench system
Rasp Pi, UAE4ARM, 3D laser scanner, experimental, hoping for AmigaOS4Arm, based on Watterott Fabscan Pi
 

Offline Beast96GT

Re: Internal floppy works, but not detecting new disks.
« Reply #4 on: May 13, 2021, 03:08:46 AM »
That's good to know, for sure.   I've never even heard of that!   

The good news is that some compressed air and a little DeOxIt seems to have fixed it right up.    Thanks guys!

-Chris

Offline Matt_H

Re: Internal floppy works, but not detecting new disks.
« Reply #5 on: May 14, 2021, 02:09:04 AM »
Nice! Love it when it's that simple! :)