Welcome, Guest. Please login or register.

Author Topic: What *nix is compatible?  (Read 10960 times)

Description:

0 Members and 1 Guest are viewing this topic.

Offline HardStep

  • Full Member
  • ***
  • Join Date: Apr 2005
  • Posts: 147
    • Show only replies by HardStep
Re: What *nix is compatible?
« Reply #14 from previous page: December 31, 2017, 01:49:35 AM »
Subscribing as well
A1200/Blizzard1260+SCSI Mediator-Voodoo3-Radeon9250
A1200/ACA1233-55
A1200/ACA1231-42
A500
CD32
MOS3.7 registered, Mac Mini+IBook G4
 

Offline johnklos

  • Full Member
  • ***
  • Join Date: Feb 2010
  • Posts: 190
    • Show only replies by johnklos
Re: What *nix is compatible?
« Reply #15 on: December 31, 2017, 03:59:06 AM »
Well, there's some good news. It seems that FS-UAE can now properly boot and run a NetBSD image with a few extra options to set the controller type and the disk type to be SCSI. What I haven't figured out yet is how to network with the emulated A2065 ethernet card, and searches offer almost nothing that talks about host side networking configuration.

Perhaps I'll make a separate post about that...
 

Offline LoadWB

  • Hero Member
  • *****
  • Join Date: Jul 2006
  • Posts: 2901
  • Country: 00
    • Show only replies by LoadWB
Re: What *nix is compatible?
« Reply #16 on: December 31, 2017, 05:21:15 AM »
I would like to run BSD on my 68060 2000 so I am definitely interested in your work.
 

Offline pjhutch

  • Sr. Member
  • ****
  • Join Date: Mar 2002
  • Posts: 452
  • Country: england
  • Gender: Male
  • Amiga user and developer
    • Show only replies by pjhutch
    • http://www.pjhutchison.org
Re: What *nix is compatible?
« Reply #17 on: December 31, 2017, 11:50:16 AM »
 

Offline trekiej

Re: What *nix is compatible?
« Reply #18 on: December 31, 2017, 05:38:55 PM »
I believe Amiga Unix is available some where.
Amiga 2000 Forever :)
Welcome to the Planar System.
 

Offline johnklos

  • Full Member
  • ***
  • Join Date: Feb 2010
  • Posts: 190
    • Show only replies by johnklos
Re: What *nix is compatible?
« Reply #19 on: December 31, 2017, 10:36:00 PM »
Quote from: trekiej;834541
I believe Amiga Unix is available some where.


Sure, but 1) compiling modern software on AMIX is hardly straightforward, and 2) it only runs on pre-AGA Amigas, and not on m68040 or m68060 accelerators, and only supports certain SCSI, graphics and networking cards.

NetBSD/amiga runs on any Amiga with an MMU and at least 8 megabytes of memory. Want to run nginx, Apache, python, et cetera? Want to run an email server? Not a problem.

We should have a NetBSD/amiga image soon :)
 

Offline B00tDisk

  • VIP / Donor - Lifetime Member
  • Hero Member
  • *****
  • Join Date: Dec 2002
  • Posts: 1670
    • Show only replies by B00tDisk
    • http://www.thedelversdungeon.com
Re: What *nix is compatible?
« Reply #20 on: December 31, 2017, 10:36:41 PM »
If someone does pull this off (NetBSD for m68k) could you possibly upload a good quality video to either youtube or Vimeo of the desktop environment?  I've always been fascinated by the idea of running modern-ish *nix on Amiga, and I've never actually seen it done.
Back away from the EU-SSR!
 

Offline trekiej

Re: What *nix is compatible?
« Reply #21 on: January 01, 2018, 12:00:19 AM »
NetBSD for the Amiga sounds great.
I guess one could make an Amix theme. :)
Yet there are better looking themes.
Amiga 2000 Forever :)
Welcome to the Planar System.
 

Offline kolla

Re: What *nix is compatible?
« Reply #22 on: January 01, 2018, 12:11:43 AM »
It's just twm, though, isn't it.
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC
---
A3000/060CSPPC+CVPPC/128MB + 256MB BigRAM/Deneb USB
A4000/CS060/Mediator4000Di/Voodoo5/128MB
A1200/Blz1260/IndyAGA/192MB
A1200/Blz1260/64MB
A1200/Blz1230III/32MB
A1200/ACA1221
A600/V600v2/Subway USB
A600/Apollo630/32MB
A600/A6095
CD32/SX32/32MB/Plipbox
CD32/TF328
A500/V500v2
A500/MTec520
CDTV
MiSTer, MiST, FleaFPGAs and original Minimig
Peg1, SAM440 and Mac minis with MorphOS
 

Offline johnklos

  • Full Member
  • ***
  • Join Date: Feb 2010
  • Posts: 190
    • Show only replies by johnklos
Re: What *nix is compatible?
« Reply #23 on: January 01, 2018, 11:59:46 PM »
I thought it deserved its own thread:

http://www.amiga.org/forums/showthread.php?t=73126

Packages and window managers will come soon :)