Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: OS 4 software on OS 3.9???  (Read 703 times)

0 Members and 1 Guest are viewing this topic.

Offline Brutus

OS 4 software on OS 3.9???
« on: March 14, 2004, 12:08:51 AM »
I am still not sure, about the gap between fx Amiga 4000 and the new AmigaOne.
One of my thoughts goes on, wheater software (fx office programs ect.) developed for AmigaOne, will work on fx Amiga 4000T OS 3.9, or the systems are to different.
Amiga will NEVER die!!!!!!!!!!
- For there is a better way......
 

Offline takemehomegrandma

Re: OS 4 software on OS 3.9???
« Reply #1 on: March 14, 2004, 12:40:37 AM »
If the software is specifically developed for OS4 it will not work on
Amigas. But chances are that the other way around may work; Amiga
programs that are completely system friendly (non hardware banging)
may work on OS4. If the Amiga compatibility in OS4 is at least as good
as in MorphOS, then most of the more important Amiga programs will
work on the new system. And nothing is stopping the application
programmers from using the AmigaOS3.1 API only (which both Amiga and
OS4 shares (and MorphOS and AROS too)). Then it will be a simple
matter of compiling the application for both 68k and PPC, thus having
a program that runs on both (all) platforms.
MorphOS is Amiga done right! :)
 

  • Guest
Re: OS 4 software on OS 3.9???
« Reply #2 on: March 14, 2004, 01:02:09 AM »
> If the software is specifically developed for OS4 it will not work on Amigas.

More specifically, it won't work on 68K Amigas running OS 3.9 or older. Any "classic" Amiga with PowerPC card should be able to run OS4.

I'd imagine that OS4-specific software will be, like OS4 will ultimately become, PowerPC native and use the newer OS4 APIs.

 

Offline Van_M

Re: OS 4 software on OS 3.9???
« Reply #3 on: March 14, 2004, 01:17:03 AM »
On the other side of the fence now, it is heard quite oftenly that, keeping your A4000/PPC will privilege you in using your old applications/games... how can that be possible under OS4? Won't there have to be drivers, that explain to the OS how to use the legacy hardware present?
The new Megadeth album rules!
 

Offline Van_M

Re: OS 4 software on OS 3.9???
« Reply #4 on: March 14, 2004, 01:24:44 AM »
Quote
Any "classic" Amiga with PowerPC card should be able to run OS4.


At least in theory! OS4 will have to be adapted to boot a A1200/ppc right? Can anyone make a rough prediction on what things should be changed to boot on 1200/PPC and how long hyperion would take to port them (judging from the time it took them to reach the present point)?  
The new Megadeth album rules!
 

Offline rayt

Re: OS 4 software on OS 3.9???
« Reply #5 on: March 14, 2004, 02:26:10 AM »
Quote

At least in theory! OS4 will have to be adapted to boot a A1200/ppc right? Can anyone make a rough prediction on what things should be changed to boot on 1200/PPC and how long hyperion would take to port them (judging from the time it took them to reach the present point)?  


Hyperion already confirmed that Os4 runs on blizzard cards a few months ago. But it will still be the last version to be released (after csppc and a1 version). And there will be no grex support, so everyone who wants to use os4 on classic amiga should get a mediator or prometheus.
 

Offline Effy

Re: OS 4 software on OS 3.9???
« Reply #6 on: March 14, 2004, 02:41:36 AM »
Damn, then I´ve got to upgrade from my BPPC+Bvision+Zorro4 ... can´t anybody write drivers for Zorro3 amd other Zorro2/4 stuff ??? Can´t those drivers be ported from 68k to PPC ???

Offline Acill

Re: OS 4 software on OS 3.9???
« Reply #7 on: March 14, 2004, 04:20:12 AM »
We just need more PPC software period. I never noticed just how few good titles are out for PPC classic systems. I dont use much in mine at all. I gave up looking for them. Now when OS4 comes out all that should change.
Proud Retired Navy Chief!

A4000T - CSPPC - Mediator
Powerbook G4 15", 17"
Powermac G5 2GHZ
AmigaOne X5000
Need Amiga recap or other services in the US? Visit my website at http://www.acill.com and take a look or on facebook at http://facebook.com/acillclassics
 

Offline Jupp3

Re: OS 4 software on OS 3.9???
« Reply #8 on: March 14, 2004, 08:17:53 AM »
Quote
And there will be no grex support, so everyone who wants to use os4 on classic amiga should get a mediator or prometheus.

afaik, AmigaOS 4 will not require PCI busboard... But it likely will require some graphics card (other than ECS/AGA) so...

But I guess that at least BVision and Cvision will be supported...
 

Offline voxel

Re: OS 4 software on OS 3.9???
« Reply #9 on: March 14, 2004, 08:48:25 AM »
>But I guess that at least BVision and Cvision will be supported...

Sure it are :-)

G-Rex support is a matter of not having documentation for,
BTW, G-Rex has been discontinued by DCE so...

As for AmigaOS 4 natives softwares it will run on any Amiga able to run AmigaOS4 : Amiga Classic with PPC cards CyberStorms AND Blizzard PPC, with or without PCI expansion, and already uses CyberVison and BlizzardVision PPC cards or AmigaONEs series.

All you have to do is programming that AOS4 softwares in a clean way, as ALL Amiga software MUST ever be programmed :-)
Amigalement,
Jean-François Bachelet, Amiga nuts since 1985.
-------------------------------------------------
Welcome to Happy Computing : Amiga! (© 2K4-2K8 voxel)