Welcome, Guest. Please login or register.

Author Topic: Using plipbox with Emu68 & pistorm32 lite on a 1200  (Read 1197 times)

Description:

0 Members and 1 Guest are viewing this topic.

Offline tlgroomsTopic starter

  • Jr. Member
  • **
  • Join Date: Dec 2008
  • Posts: 72
  • Country: us
  • Gender: Male
    • Show only replies by tlgrooms
    • CIA Amiga BBS
Using plipbox with Emu68 & pistorm32 lite on a 1200
« on: May 09, 2023, 10:15:49 PM »
I have recently set up my pistorm32 lite in my 1200 and installed os3.2, on the latest emu68 and the RTG picasso96 drivers.  I own Roadshow also and have tried installing the plipbox.device driver and Roadshow on it.  It installs OK and starts OK.  I have set a fixed ip and set up the dns servers and gateway, all configured properly but can't get it to work.  The debug shows it sets the ip address properly and netmask but I can't get out.  Tried pinging names and direct ips.  Not getting anywhere.  Tried pinging my router directly with it's ip and cannot ping it. I can ping localhost and my ip and it shows working ok, just can't get out.

Is there any kind of problem with using the plipbox with emu68 and the pistorm32 lite?  I have set up the hard drives and installed os 3.2 and everything else appears to be working fine.  Is there something I am missing?  I have used the plipbox on my 1200 before without a pistorm without any problems.
Try my Amiga BBS -> telnet ciaamiga.org:6400 or www.ciaamiga.org
 

Offline G4DDS

  • Newbie
  • *
  • Join Date: Feb 2020
  • Posts: 3
  • Gender: Male
    • Show only replies by G4DDS
Re: Using plipbox with Emu68 & pistorm32 lite on a 1200
« Reply #1 on: June 02, 2023, 12:48:44 PM »
I'm having problems as well.

Got a plipbox v0.6 firmware on an A1200 kickstart 3.1. I have my own little "test" distribution based on workbench 3.1 containing just the plipbox drivers, roadshow etc. (basically just all the networking stuff). With the PiStorm32 lite plugged in but no Pi distro (so it boots natively from the A1200), plipbox configures itself and Roadie displays the IP address and network access is fine.

If I then install distro Emu68-pistorm32lite-20230510-bdffce.zip (latest as of a couple of days ago) on the Pi 4 (2Gb RAM), the plipbox fails to configure with the error message:
Interface "plipbox" configuration attempt timed out.

I have tried commenting out the last line of the config file so that the PiStorm32 lite uses the onboard Kickstart 3.1 to mimic the working system as closely as possible but still no luck. I also legally own OS 3.2 so I've tried it with the PiStorm loading the 3.2.2 ROM as well.

I posted this on the PiStorm FB group if you want to see if there are any replies.
 

Offline G4DDS

  • Newbie
  • *
  • Join Date: Feb 2020
  • Posts: 3
  • Gender: Male
    • Show only replies by G4DDS
Re: Using plipbox with Emu68 & pistorm32 lite on a 1200
« Reply #2 on: June 02, 2023, 03:25:41 PM »
Adding NOBURST to the config file has fixed it on my setup. I still suspect the inherent problem is in the PiStorm builds but at the moment I'm just happy to have it working.
 

Offline tlgroomsTopic starter

  • Jr. Member
  • **
  • Join Date: Dec 2008
  • Posts: 72
  • Country: us
  • Gender: Male
    • Show only replies by tlgrooms
    • CIA Amiga BBS
Re: Using plipbox with Emu68 & pistorm32 lite on a 1200
« Reply #3 on: June 02, 2023, 03:40:38 PM »
NOBURST also worked for me. Thanks for the info.

When I reboot the machine I have to power off the plipbox to get it to reset and work. Is that normal? Anyway to do it without restarting it every time as well?
Try my Amiga BBS -> telnet ciaamiga.org:6400 or www.ciaamiga.org
 

Offline G4DDS

  • Newbie
  • *
  • Join Date: Feb 2020
  • Posts: 3
  • Gender: Male
    • Show only replies by G4DDS
Re: Using plipbox with Emu68 & pistorm32 lite on a 1200
« Reply #4 on: June 02, 2023, 04:38:25 PM »
I added a diode from the reset pin on the parallel port to the reset pin on the Arduino board so when the Amiga was reset it so did the Arduino.

However, I have an Omniport board as I also have an Indivision AGA MK3:

https://www.amiga-shop.net/en/Amiga-Hardware/Amiga-classic-hardware/OmniPort-Multi-port-adapter-for-Amiga-1200::1095.html

and I've connected the two USB ports upto the Raspberry Pi and I use one of these for the power feed for the Plipbox and I've discovered by chance that when you reset the Amiga, the power on the Pi (and hence the Plipbox) momentarily drops. I use the other USB port for the Pi distribution as an alternative to the SD card so its easy to get access to.
 

Offline Hammer

  • Hero Member
  • *****
  • Join Date: Mar 2002
  • Posts: 1996
  • Country: 00
    • Show only replies by Hammer
Re: Using plipbox with Emu68 & pistorm32 lite on a 1200
« Reply #5 on: June 05, 2023, 02:40:33 PM »
I'm using  3COM 3CCE589ET LAN 10Mbit Ethernet PCMCIA card + MiamiTCP  on PiStorm32 Lite-Emu68 A1200 instead of plipbox.

I recycled my PCMCIA cards from my old laptop PC.
Amiga 1200 PiStorm32-Emu68-RPI 4B 4GB.
Ryzen 9 7900X, DDR5-6000 64 GB, RTX 4080 16 GB PC.