Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: The Os 3.1.4 Thread  (Read 130748 times)

0 Members and 1 Guest are viewing this topic.

Offline kreciu

Re: The Os 3.1.4 Thread
« Reply #285 on: October 29, 2018, 02:31:17 PM »
Yes... Thank goodness there is no other software out there that updates and you receive a slightly new version. Like on your phone, or computer, or watch, or almost all software that is currently created... :-\

I don't remember when I had to purchase software update for my phone, computer etc. Maybe after support time is over, I do pay for updates/upgrades.

Personally, I don't care "what is out there".

It was not clear to me what type of updates are for 3.1.4 and it seemed to me strange that tweaks are being made to released version. In general I got used to that there are "strange things" in Amiga World, so I don't care about those thing to much (or basically at all). So, I simply wanted to know what is happening there.

I will wait for boxed version with ROMs, I have no way to burn ROMs on my own and this will be my "final version" of 3.1.4 :).
A1200inE/BOX/3.1.4/AmigaOS3.9+BB1,2,3,4/060/66Mhz+603+/330Mhz/256Mb/FAST-ATA V /MediatorTX/R9200SE/SpiderUSB/LAN/SB128/16Gb-CF/DVD-ROM/ZIP-250/FDD-HD
PC/AmigaOS4.1/Xeon 1265Lv3  with Amiga Forever 2016!!!.
Dell T600/Win98SE/XP/256Mb/Radeon9600Pro/SBLive!/80Gb/DVD-ROM
Color Classic/System 7.1/030/16Mhz/FPU/10Mb/80Mb HDD
Performa 6400/System 8.6/PPC 603ev180Mhz+G3 350Mhz/Rage128Pro/136Mb/80GB HDD
IBM PC :)
 

Offline Romanujan

Re: The Os 3.1.4 Thread
« Reply #286 on: October 29, 2018, 05:11:20 PM »
Yes... Thank goodness there is no other software out there that updates and you receive a slightly new version. Like on your phone, or computer, or watch, or almost all software that is currently created... :-\

All I have seen so far (like MS Windows) warn about this in their EULA - AmigaOS 3.1.4 is the first one I have seen that did not. And, you have just mentioned one of the reasons why I switched from Windows to Linux at home, and why I use Android or iOS devices as secondary devices only, when I want mobile net access or navigation.
 

Offline kreciu

Re: The Os 3.1.4 Thread
« Reply #287 on: October 29, 2018, 07:57:48 PM »
I actually think that I will like 3.1.4 more then 3.9. Simpler, cleaner and way newer. With few of my own "additions" it should work very well. I just can't wait for physical version with ROMs. I will get at least two :).
A1200inE/BOX/3.1.4/AmigaOS3.9+BB1,2,3,4/060/66Mhz+603+/330Mhz/256Mb/FAST-ATA V /MediatorTX/R9200SE/SpiderUSB/LAN/SB128/16Gb-CF/DVD-ROM/ZIP-250/FDD-HD
PC/AmigaOS4.1/Xeon 1265Lv3  with Amiga Forever 2016!!!.
Dell T600/Win98SE/XP/256Mb/Radeon9600Pro/SBLive!/80Gb/DVD-ROM
Color Classic/System 7.1/030/16Mhz/FPU/10Mb/80Mb HDD
Performa 6400/System 8.6/PPC 603ev180Mhz+G3 350Mhz/Rage128Pro/136Mb/80GB HDD
IBM PC :)
 

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #288 on: October 30, 2018, 09:05:45 AM »
I just can't wait for physical version with ROMs. I will get at least two :).
Alinea seems to have them from Nov. 3rd on: https://www.amiga-shop.net/Amiga-Software/AmigaOS-Amiga-Betriebssysteme/AmigaOS-3-1-4::859.html

 

Offline kreciu

Re: The Os 3.1.4 Thread
« Reply #289 on: October 30, 2018, 12:58:24 PM »
Great to see those. I've never shopped with them, I will wait for Amigakit.com.

BTW. It reminds me old good days when you got floppies and ROMs :).

PS. Just don't update ROMs to often, I "hate" disassembling my monster A1200 ;).
« Last Edit: October 30, 2018, 01:01:09 PM by kreciu »
A1200inE/BOX/3.1.4/AmigaOS3.9+BB1,2,3,4/060/66Mhz+603+/330Mhz/256Mb/FAST-ATA V /MediatorTX/R9200SE/SpiderUSB/LAN/SB128/16Gb-CF/DVD-ROM/ZIP-250/FDD-HD
PC/AmigaOS4.1/Xeon 1265Lv3  with Amiga Forever 2016!!!.
Dell T600/Win98SE/XP/256Mb/Radeon9600Pro/SBLive!/80Gb/DVD-ROM
Color Classic/System 7.1/030/16Mhz/FPU/10Mb/80Mb HDD
Performa 6400/System 8.6/PPC 603ev180Mhz+G3 350Mhz/Rage128Pro/136Mb/80GB HDD
IBM PC :)
 

Offline kreciu

Re: The Os 3.1.4 Thread
« Reply #290 on: October 30, 2018, 01:00:07 PM »
(double post)
« Last Edit: October 30, 2018, 01:02:01 PM by kreciu »
A1200inE/BOX/3.1.4/AmigaOS3.9+BB1,2,3,4/060/66Mhz+603+/330Mhz/256Mb/FAST-ATA V /MediatorTX/R9200SE/SpiderUSB/LAN/SB128/16Gb-CF/DVD-ROM/ZIP-250/FDD-HD
PC/AmigaOS4.1/Xeon 1265Lv3  with Amiga Forever 2016!!!.
Dell T600/Win98SE/XP/256Mb/Radeon9600Pro/SBLive!/80Gb/DVD-ROM
Color Classic/System 7.1/030/16Mhz/FPU/10Mb/80Mb HDD
Performa 6400/System 8.6/PPC 603ev180Mhz+G3 350Mhz/Rage128Pro/136Mb/80GB HDD
IBM PC :)
 

Offline kolla

Re: The Os 3.1.4 Thread
« Reply #291 on: December 18, 2018, 12:16:56 PM »


Meh.



In comparison to shell v45 that does not throw "CONSOLE:" requesters when running scripts with pipes in the background.

This, along with the failat/abort bug, makes the shell in OS 3.1.4 really annoying to make script for.
« Last Edit: December 19, 2018, 12:10:15 PM by kolla »
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC
---
A3000/060CSPPC+CVPPC/128MB + 256MB BigRAM/Deneb USB
A4000/CS060/Mediator4000Di/Voodoo5/128MB
A1200/Blz1260/IndyAGA/192MB
A1200/Blz1260/64MB
A1200/Blz1230III/32MB
A1200/ACA1221
A600/V600v2/Subway USB
A600/Apollo630/32MB
A600/A6095
CD32/SX32/32MB/Plipbox
CD32/TF328
A500/V500v2
A500/MTec520
CDTV
MiSTer, MiST, FleaFPGAs and original Minimig
Peg1, SAM440 and Mac minis with MorphOS
 

Offline wmaciv

Re: The Os 3.1.4 Thread
« Reply #292 on: December 23, 2018, 05:34:37 PM »
Just installed 3.1.4 (ROM and disks). Previous install was patched exec 3.1 (to allow full 060 to boot), running Thor's MuLIb suite with zero problems. Now, using Thor MuLib (latest) with 3.1.4, unless I set SetPatch to "NOCACHE", the CPU CHECKINSTALL command on the very next line of the Startup-sequence will crash the system without fail.

If I then boot into WB the only way that seems to work, with SetPatch NOCACHE QUIET, then open a shell window and type "CPU", it returns the correct CPU setup, but the Data Cache and Data Burst are disabled (off).

If I then try to command "CPU CACHE", about 75% of the time the system will lock up and guru, the other 25% I am able to activate the Data Cache and Burst.

Everything worked great with the previous 3.1 installation (patched exec) and latest distribution of MUlibs, but now, this...

Anyone have any ideas? Thomas?

Thanks.
   
« Last Edit: December 23, 2018, 05:48:54 PM by wmaciv »
 

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #293 on: December 23, 2018, 08:07:03 PM »
Just installed 3.1.4 (ROM and disks). Previous install was patched exec 3.1 (to allow full 060 to boot), running Thor's MuLIb suite with zero problems. Now, using Thor MuLib (latest) with 3.1.4, unless I set SetPatch to "NOCACHE", the CPU CHECKINSTALL command on the very next line of the Startup-sequence will crash the system without fail.
There is no difference concerning the memory setup between 3.1 and 3.1.4 that would explain this. You can also LoadModule 3.1.4 on top of a 3.1 ROM. If this solves the problem, then probably the ROM chip is not compatible to the hardware. I would try the 3.1 ROM with a LoadModule installation and continue from there.
 

Offline wmaciv

Re: The Os 3.1.4 Thread
« Reply #294 on: December 23, 2018, 08:40:54 PM »
Egregious error in the post; forgot to mention that this is an A2000 with a GVP A2000-040 combo with 060 adapter, 64MB GVP SIMM RAM, and GuruROM.  I looked around a1k.org and found a few mentions of possible problems with this card setup?  Still do not understand how 3.1 ROM with your MuLIbs works flawlessly, but the new SetPatch / CPU command in 3.1.3 seems to make the system unstable when any attempt to enable Data Cache is made.
 

Offline Jeff

  • VIP / Donor - Lifetime Member
  • Hero Member
  • *****
  • Join Date: Dec 2003
  • Posts: 1380
  • Total likes: 0
Re: The Os 3.1.4 Thread
« Reply #295 on: December 24, 2018, 12:20:27 AM »
Amiga OS 3.1.4 is available as a download again. I just bought all of the versions :D What a nice Christmas gift! Thank you to whoever made this happen.
 

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #296 on: December 24, 2018, 12:36:18 AM »
Still do not understand how 3.1 ROM with your MuLIbs works flawlessly, but the new SetPatch / CPU command in 3.1.3 seems to make the system unstable when any attempt to enable Data Cache is made.
As stated, there is no difference in setpatch as far as the memory or mmu setup is concerned, and the CPU command does not change that either. The only thing it does is that it may, upon request, change the state of the CPU caches. If the system does not work stable with CPU caches, you have a hardware problem, probably because the ROM you received has a lower speed-grade than the one present before. There is no difference as far as the CPU setup is concerned.

Offline outlawal2

Re: The Os 3.1.4 Thread
« Reply #297 on: December 24, 2018, 03:48:47 AM »
OK just installed the ROMs in my 3000 and reinstalled the OS from the new floppies...   But it still says my disk is 2 GIG even though it is 16.  Could this be because it was formatted before as 2 GIG?  No matter what I try it only shows up as 2 GIG.
This is a Sandisk MicroSD and the adaptor is a SCSI 2 SD adaptor...   Other than the size issue it works fine..

Just wondering what I am doing wrong as everyone I have seen thus far says the new OS detects the disks perfectly..
 

guest11527

  • Guest
Re: The Os 3.1.4 Thread
« Reply #298 on: December 24, 2018, 08:26:16 AM »
OK just installed the ROMs in my 3000 and reinstalled the OS from the new floppies...   But it still says my disk is 2 GIG even though it is 16.  Could this be because it was formatted before as 2 GIG?
If you haven't repartitioned with HDToolbox, then the partition sizes stay exactly as they were before. To use the full disk size, you can either repartition which would require a full install, or you can add another partition that uses the remaining 14GB.

Offline outlawal2

Re: The Os 3.1.4 Thread
« Reply #299 on: December 25, 2018, 12:58:39 PM »
Yeah but I DID repartition with the tools provided with the new OS..  (Hence my question)
Strange....