Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

 



rusty A2000
rusty A2000
Previous Image | Next Image
Description: This is an old A2000 that had broken PSU. I've replaced it with ATX. I also replaced floppy drive with PC one. Not seen here are: 5,25" FDD and 50Mb HDD both covered in rust. Amazingly HDD works just fine.
here is the high res version
Picture Stats:
Views: 2011
Filesize: 281.92kB
Height: 768 Width: 1024
Posted by: orange at October 13, 2006, 09:03:21 AM

0 Members and 1 Guest are viewing this picture.

Comments (7)

countzero
Posts:1938
January 24, 2008, 08:08:08 AM
hey, nice carpet. looks like turkish.
orange
Posts:2792
December 11, 2007, 07:04:34 AM
the red thing is kickstart switch.
I have used some rust remover (acid probably)
and then zinc spray. it doesn't look very good, but at least it should prevent further rusting
rkauer
Posts:3263
December 11, 2007, 12:35:05 AM
What is that red thing right of the mouse conector?

 And a tip: remove the cradle and take it to a trip to some sand-jet industry. Then go to a chrome or galvanoplastic one to re-cover it (or just paint it).
orange
Posts:2792
October 20, 2006, 01:50:20 PM
higher resolution

I haven't butchered old connector, instead I used two seperate, cheap connectors that you could buy in every radio shack. Unfortunately two wires could not fit in them, so I just used that heatshrink tube to isolate them, but it looks OK to me. I'll post a photo about it, soon. Still, I wish I could repair that old PSU, though new one is probably safer and better quality.

PS.
Of course, I bought it second hand with rust and all.. IIRC, it was 10 euros.
OTOH, that new Chieftec 300W PSU cost me about 40 euro..

[EDIT]
here is closer look on connector.
pedro7
Posts:81
October 15, 2006, 03:06:09 AM
How are you connecting the PSU to the motherboard? You've done a very neat job, not a terminal block in sight!
FrankBrana
Posts:178
October 14, 2006, 02:02:32 PM
Oh poor machine!

Check mine.

http://jacosw.zoto.com/img/7/7323d593fe49fe8151c4d75f790e9c72-.jpg
McVenco
Posts:1428
October 13, 2006, 06:24:23 PM
Wow, did you keep this in a garage in New Orleans or something?  :-o


Powered by: SMF Gallery