Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: GreaseWeazle V4 available at Amiga Kit Amiga Store  (Read 497 times)

0 Members and 1 Guest are viewing this topic.

Offline amigakit

GreaseWeazle V4 available at Amiga Kit Amiga Store
« on: October 08, 2021, 11:56:06 AM »
Keir Fraser's excellent GreaseWeazle V4 adapter board is now available from Amiga Kit Amiga Store

Read/write various disk formats to floppy disks from a Windows or Mac using this adapter and a PC floppy drive. Supports ADF too!




Direct Product Currency Links:

United States
Europe
United Kingdom
Australia
New Zealand

« Last Edit: October 08, 2021, 12:02:23 PM by amigakit »
www.AmigaKit.com - Amiga Hardware/Software Dealer

New Products  --   Customer Help & Support -- @amigakit

USA Toll Free Order Tel: 1-888-698-6758
 

Offline First Ninja

Quote from: amigakit
Read/write various disk formats to floppy disks from a Windows or Mac using this adapter and a PC floppy drive. Supports ADF too!

Unfortunately, this is only partially true. AmigaOS 4.1 isn't supported at all, which is a total dealbreaker to me. I'd love to order a GeaseWeazle, but that assumes that OS 4 has full blown support. @amigakit - how soon can we expect AmigaOS compatibility?
 

Offline F1Lupo

Quote from: amigakit
Read/write various disk formats to floppy disks from a Windows or Mac using this adapter and a PC floppy drive. Supports ADF too!

Unfortunately, this is only partially true. AmigaOS 4.1 isn't supported at all, which is a total dealbreaker to me. I'd love to order a GeaseWeazle, but that assumes that OS 4 has full blown support. @amigakit - how soon can we expect AmigaOS compatibility?
If you want full OS4.1 support I'd recommend you get a Catweasel MK4+
____________________________________________________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Indivision AGA & Catweasel MK4+= Amazing
! My Master Miggies-Amiga 1000 & AmigaOne X1000 !
--- www.mancave-ramblings.blogspot.ca ---
  -AspireOS.com & Amikit- Amiga for your netbook-
***X1000- I BELIEVE *** :angel:
 

Offline First Ninja

Re: GreaseWeazle V4 available at Amiga Kit Amiga Store
« Reply #3 on: October 12, 2021, 06:27:25 PM »
If you want full OS4.1 support I'd recommend you get a Catweasel MK4+

Thank you for your reply. Unfortunately, the Catweasel is out of stock since years ago. When they did show up on various auction sites, the asking prices are usually with a markup of several orders of magnitude. That is exactly why the Amiga platform should embrace initiatives like this one - buying the GreaseWeazle not only supports hardware developer, creating brand new hardware, but the distributor as well. It's a win-win for everyone but the scalpers.

@amigakit - I'm eagerly awaiting an answer. Thank you in advance.

Offline F1Lupo

Re: GreaseWeazle V4 available at Amiga Kit Amiga Store
« Reply #4 on: October 12, 2021, 09:41:24 PM »
@ First Ninja
sad to hear about the Catweasel MK4+ shortage as it's just an awesome product that works great under OS4.1 for quite some time now...wonder my Individual Computers wouldn't have them in stock for so long...as they are the manufacturers after all ?

« Last Edit: October 12, 2021, 09:43:01 PM by F1Lupo »
____________________________________________________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Indivision AGA & Catweasel MK4+= Amazing
! My Master Miggies-Amiga 1000 & AmigaOne X1000 !
--- www.mancave-ramblings.blogspot.ca ---
  -AspireOS.com & Amikit- Amiga for your netbook-
***X1000- I BELIEVE *** :angel:
 

Offline amigakit

Re: GreaseWeazle V4 available at Amiga Kit Amiga Store
« Reply #5 on: October 12, 2021, 10:33:46 PM »
@First Ninja

Hi

We are always prepared to re-invest in these type of software development projects.  The profits we make from our sales routinely get ploughed back every year into new Amiga hardware and software.

First a review of the dependencies would be needed.  I can see that Python 3 and pyserial libraries are required.  This is not going to be a straight forward port.  More investigation is needed.
www.AmigaKit.com - Amiga Hardware/Software Dealer

New Products  --   Customer Help & Support -- @amigakit

USA Toll Free Order Tel: 1-888-698-6758
 

Offline Matt_H

Re: GreaseWeazle V4 available at Amiga Kit Amiga Store
« Reply #6 on: October 12, 2021, 10:41:12 PM »
@ First Ninja
sad to hear about the Catweasel MK4+ shortage as it's just an awesome product that works great under OS4.1 for quite some time now...wonder my Individual Computers wouldn't have them in stock for so long...as they are the manufacturers after all ?
This surprises me, too. It certainly seems like the demand is there for another production run. I wonder if it's an RoHS/EOL component situation.
 

Offline First Ninja

@First Ninja
We are always prepared to re-invest in these type of software development projects.  The profits we make from our sales routinely get ploughed back every year into new Amiga hardware and software.

First a review of the dependencies would be needed.  I can see that Python 3 and pyserial libraries are required.  This is not going to be a straight forward port.  More investigation is needed.

Thank you for answering. Your general stance about re-investing in Amiga support is potentially good news for the GreaseWeazle. While most solutions would be welcome, building a native AmigaOS version that fully exploits the OS would likely do the GreaseWeazle even more justice.

Implementing the support as a trackdisk.device compatible AmigaOS device, allowing Workbench to access FFS formatted floppies, is strongly encouraged. Even with a basic, read-only version it would make the GreaseWeasle an instabuy item for me. Thank you for considering it 👍.
« Last Edit: October 13, 2021, 08:34:11 PM by First Ninja »