Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

Recent Posts

Pages: 1 [2] 3 4 ... 10
11
Amiga Software Issues and Discussion / Re: OS 3.9 Cannot open "resource.library"
« Last post by Michele31415 on September 25, 2021, 07:09:26 PM »
Well I got Deneb working again (it was missing FAT95 from L: which causes it to silently do nothing when you insert a USB stick, unless you run Trident to see the error message) and got the BB1 update on FS3:.  lha x claims it extracted successfully.  But when I clicked on Install I got:

Quote
Sorry... an Error Has Occurred!

Update failed.  Please check whether your AmigaDOS 3.9 CD-ROM is inserted in your CD-ROM drive and whether the download of the update archive worked correctly.

Then try again.  If it still doesn't work contact our support.

Well my 3.9 CD *is* in the drive, and it's an official copy and I can see its icon in WB and I can see files on it and lha says the update was extracted successfully.  So I tried again, and got the same error. :-(
12
Amiga Software Issues and Discussion / Re: OS 3.9 Cannot open "resource.library"
« Last post by Michele31415 on September 25, 2021, 05:44:48 PM »
Speaking to your original problem, AmiFTP or something else you installed overwrote one or more files in SYS:Classes with older versions. For some reason, this manifests as a "cannot open resource.library" error - I don't know why. But this is a very common problem, usually resulting from badly-written install scripts that do a blind copy into SYS:Classes without checking/comparing file versions. You'll need to copy the correct files back from the 3.9 CD.

As to your new problem of being unable to boot, do a cold restart (power down the machine, wait ~30 seconds, power back on). Does the exact same thing happen, i.e., it starts to boot with disk activity and then crashes?  What I'm trying to diagnose here is whether your partition is damaged (the NDOS error) or whether SetPatch (more accurately: one of the ROM module updates that SetPatch kicks in) is causing the crash.

Once you get your system bootable again, make sure to install both of the Boing Bag updates in order (available here). They include important bugfixes.
Thanks.  The NDOS got resolved by doing a cold boot (I keep forgetting about that).  Now I'm trying to get those BoingBag files onto the Amiga.  I have the net up but AmiFTP doesn't work.  So I either need a different FTP client or I'll try to get the Deneb running, or maybe I can write them to a CD and read that (at least the CD-ROM is working).

What if I just copy all the classes from the 3.9 CD onto FS3, or will that mess up soemthing else.
13
Amiga Software Issues and Discussion / Re: OS 3.9 Cannot open "resource.library"
« Last post by Michele31415 on September 25, 2021, 05:07:26 PM »
Now it starts sounding like FS3: is a larger than 2GB partition… that may have been corrupted in all this messing around with rom updates and setpatch.
By golly, it looks like you're right.  I could have sworn it was 2 GB but HDtoolBox says 4 GB.

But - it turns out that after a cold boot, I was able to boot into FS3: using the new SetPatch from the CD after all.

I'm only using about 400 MB on FS3:.  Can I change the partition size using HDToolBox or is this a lost cause?

SetPatch now reports:

Code: [Select]
AMIGA ROM Operating System and Libraries
Copyright M-) 1985-2000 Amiga International, Inc.
All Rights Reserved.

SetPatch (V44.16) has already been installed.  Patch list:
        BOOL CheckIO() workaround
        Enabled Advanced Graphics Modes
        AmigaOS Copyright
        ramlib signal usage
        stack size check for CON:, RAW:, RAM:, PAR:, PRT:, SER:
        graphics/WritePixelLine8()
        graphics/WriteChunkyPixel()
        Memory Pools
        Enabled data cache
No ROM updates have been installed by SetPatch.
14
Amiga Hardware Issues and discussion / Re: Amiga File System
« Last post by trekiej on September 25, 2021, 02:34:46 AM »
Thanks a lot, I will have to check it out.
I am thinking of re-installing 3.1 on my other machine.
OS 3.2 pulls a Guru Meditation due to lack of ram.
15
Amiga Hardware Issues and discussion / Re: My A600
« Last post by trekiej on September 25, 2021, 02:16:52 AM »
I have not.
Will continue to try.
edit:
I decided to put OS 3.1 back on due to a Guru Meditation, low ram.
16
Amiga Hardware Issues and discussion / Re: Amiga File System
« Last post by Matt_H on September 24, 2021, 11:29:24 PM »
SFS is a bit faster than FFS but slower than PFS. It needs a 68020 CPU. And it is a catastrophy regarding support. It can run stable over years, but if something goes wrong you usually lose everything. There is no repair tool and the only salvage tool does not work.

I can speak to this exact scenario. MorphOS uses SFS by default and even there the situation there is not much better, despite being actively maintained, unlike the 68K SFS. I ran the MorphOS SFS repair/salvage tool to fix a directory block problem; it failed and destroyed the entire partition. Fortunately I had just done a full backup before tinkering. Good thing!
17
Amiga Software Issues and Discussion / Re: OS 3.9 Cannot open "resource.library"
« Last post by Matt_H on September 24, 2021, 11:19:37 PM »
Speaking to your original problem, AmiFTP or something else you installed overwrote one or more files in SYS:Classes with older versions. For some reason, this manifests as a "cannot open resource.library" error - I don't know why. But this is a very common problem, usually resulting from badly-written install scripts that do a blind copy into SYS:Classes without checking/comparing file versions. You'll need to copy the correct files back from the 3.9 CD.

As to your new problem of being unable to boot, do a cold restart (power down the machine, wait ~30 seconds, power back on). Does the exact same thing happen, i.e., it starts to boot with disk activity and then crashes?  What I'm trying to diagnose here is whether your partition is damaged (the NDOS error) or whether SetPatch (more accurately: one of the ROM module updates that SetPatch kicks in) is causing the crash.

Once you get your system bootable again, make sure to install both of the Boing Bag updates in order (available here). They include important bugfixes.
18
Amiga Software Issues and Discussion / Re: OS 3.9 Cannot open "resource.library"
« Last post by kolla on September 24, 2021, 11:16:06 PM »
Now it starts sounding like FS3: is a larger than 2GB partition… that may have been corrupted in all this messing around with rom updates and setpatch.
19
Amiga Software Issues and Discussion / Re: OS 3.9 Cannot open "resource.library"
« Last post by Michele31415 on September 24, 2021, 08:07:23 PM »
So I found this in the 3.9 FAQ:
Quote
Q:    After installation, I have SetPatch v44.13 in my C: directory. Is this the latest version of SetPatch? [fixed in OS 3.9 SE CD]
A:    No. The latest version of SetPatch on the 3.9 CD (v44.16) is not copied to your hard drive during installation, and needs to be copied manually. There are five copies of SetPatch on the CD, so you'll want to copy the last entry listed in bold:

AmigaOS3.9:OS-Version3.9/First-Install/c/SetPatch ... 44.2 (04.10.99)
AmigaOS3.9:Emergency-Boot/C/SetPatch ... 44.13 (05.03.00)
AmigaOS3.9:OS-Version3.9/Workbench3.5/C/SetPatch ... 44.13 (05.03.00)
AmigaOS3.9:OS-Version3.9/Workbench3.9/C/SetPatch ... 44.13 (05.03.00)
AmigaOS3.9:OS-Version3.9/Emergency-Disk/C/SetPatch ... 44.16 (15.09.00)

As Stephen Rupprecht pointed out, you should always use the latest version of SetPatch available.

So I did that.  I copied the SetPatch from the CD-ROM to my startup-sequence and rebooted.  Now it won't boot at all.  I get seven flashes from the power LED, some flicking disk activity LED and then a red box "Software error" screen.  If I boot from the 3.9 Emergency disk, FS3 doesn't even appear in WB.  If I boot from my WB 3.1 floppy it shows up as "DH0:NDOS" and I can't do anything with it.  :-(
20
Amiga Software Issues and Discussion / Re: OS 3.9 Cannot open "resource.library"
« Last post by Michele31415 on September 24, 2021, 07:06:49 PM »
All files? I think I had missing gadgets.
 ...
A:
In many cases the problem message you received did not accurately reflect a missing or even damaged library, but rather the absence of a "#?.gadget" file that the resource.library function depends on. Check the SYS:Classes/Gadgets/ directory on your system partition and the OS3.9 directory of the install CD-ROM and manually copy any missing #?.gadget files. Ensure that all the #?.gadget files are the latest versions (do this by checking the latest Boing Bag first, then the OS 3.9 CD-ROM).

[Mike Wilson/Cor Kriekaart]

Another cause for this message may be a corrupt or incorrectly installed 68040.library and/or 68060.library file. Make sure that you're using the correct—and valid—680x0.libraries. Such a corrupt file may work under OS 3.1, but will fail in OS 3.9.

[Rob Pleak]
Yep - I did see that.  We can cross off the 040/060 comment because I only have a 68030.    I didn't know what to make of "Ensure that all the #?.gadget files are the latest versions (do this by checking the latest Boing Bag first, then the OS 3.9 CD-ROM)."  I don't know where (or what) the "Boing Bag" is, and I do have all the gadgets from the CD-ROM.  How do I tell what version they are?  I also saw some suggestions that I have the wrong SetPatch.  No idea how to address this either.  If you just type "SetPatch" in OS 3.9, what should it return?
Pages: 1 [2] 3 4 ... 10