Welcome, Guest. Please login or register.

Author Topic: Keep It Simple! (Stupid!) ;)  (Read 2269 times)


0 Members and 1 Guest are viewing this topic.

Offline darksun9210Topic starter

Keep It Simple! (Stupid!) ;)
« on: June 04, 2020, 03:20:08 PM »
Hey all,
Just thought i'd post this as it's a bit of a reminder in these tech driven times to sometimes just step back, take a breath, and look at the bigger picture.
Especially when dealing with original hardware!  ;D

So i'd just received a Lazarus board from Arananet as i've been unsuccessful in actually managing to close the lid on my A500 with all the gumph i've stuffed in it, plus i think i've gone through my allotted insertion cycles on the poor old 68k socket! So the old beast has been slumbering for a while until i could get a CPU plugged into it  - thanks again Arananet, i don't think i'd have her up and running till she goes off for re-cap and socket replace without you! ::)

after an evening of "WTH"'ing, with a still dead machine with a CPU now on the outside, turns out the Rev5 A500's don't run the 7Mhz clock to the expansion port edge connector. so a jumper lead made of a broken dupont wire from pin15 of the 68k socket to pin7 of the expansion port fixed that. yay!

but video was intermittant. or would look like it'd died/crashed at random, or just not seem to turn on. so I started trying to diag what was going on.
What made it worse was my jumper from pin 15 of the 68k socket bumped out of the socket hole and bounced into 13 and 12, missing pin 14 thank my lucky stars, as that would have sent 5Volts VCC to the 7Mhz line off the expansion port. The timing was epic as after then, i couldn't get output off of the graphics card. it'd just ficker and wobble for a sec, and then the screen would lose signal like the timing was out. So of course i was panicing i'd cooked something old and expensive.
I try to re-flash bits here, and wiggle stuff there. still the same.

so. i strip the machine down to start troubleshooting from the ground up. still no video with nothing plugged in. df0 does disk seek chug noises so there is a happy amiga at the core of this heap somewhere. i pull the minimegachip fly lead off and remove the internal expansion. still nothing.

a cat emerges from behind the screen. a thought occurs. check cables.
yup sure enough, the amiga native video has fallen out because i was lazy and didn't screw it in, and the feed from the graphics card was hanging by a thread. enough to probably get video data, but missing the timing pins.

phew. right. panic one over. we have native video and a base machine working, at the rom "insert disk" screen with nothing plugged in except i've put the minimegachip back and internal expansion.
boot off workbench floppy to see whats what. huh. 1meg chip ram and nothing else. OH SUGAR. panic number 2 is looming. What now? So i spend another evening buzzing out lines and traces. everythings working that should, and not working that shouldn't.
everything i do was just giving me one meg chipram. even with only half a meg on board actually available to the machine in various test configs...
turns out i was counting from the WRONG END of the Gary chip to find pin36 for the minimegachip and pin32 for testing for the "exram" signal. Good grief! So a few steps later, 2meg chip ram is back.

deep sigh!

so, it's taken effectively three evenings to just, "plug in one expansion slot board" and get a "working from switch on" machine. cor. with this level of stress and heart stopping moments it feels like retro electronics is an extreme sport!  ;D

plus points.
have learnt a few things, pin outs, pin numbering, lines and traces. also, put my original 68k chip in it's own socket to save the wear and tear on it's own legs.
and dead video may not mean cooked electronics, but that the cat has knocked the plug out of the socket in the back of the screen.
not really a plus-point, but a hit from the reality hammer - that my opticians threat that i'll need glasses sooner rather than later is probably actually real, as had to use the zoom function on my phone camera to double check small stuff.  :-\

thanks to AmigaPCB.org for being there as a resource to hunt board traces, and Amiga.resource.cx for hosting a PDF copy of the original minimegachip install guide. We got there.  8)

A500 Vampire2/minimegachip/lazarus/indyECS, (+GVP A530,SupraTurbo28,GVP HD8)
A600 Vampire2/604n/subway/IndyECS, (+ACA630)
A1200 Vampire2/subway/IndyAGA, (+Bliz030+scsi)
A1200 Icedrake/indyAGA
A1200 BlizPPCscsi/Bvision/subway
A3k C=040/CV64-3D/Xsurf100+RRoadUSB/Zoram256/acard scsi-ide-CF/IndyECS,
A4k CSMk3-060/CV64-3D/Xsurf100+RRoadUSB/Bigram256/IndyAGA, mediator+pci cards
CD32 TF330/IndyAGA
Plus an SGI O2 & consoles.

Offline Amigamia

  • Sr. Member
  • ****
  • Join Date: Jun 2005
  • Posts: 251
  • Country: us
    • Show only replies by Amigamia
    • http://www.arosworld.org
Re: Keep It Simple! (Stupid!) ;)
« Reply #1 on: March 27, 2021, 01:54:24 PM »
That is a lot of trouble you had to go through. I am looking for one of those Lazarus board  but I can't seem to find them available or even as a project file to request a new PCB from PCBway, etc.

Arananet and Sordan Electronics have them listed but they are out of stock.

Does anyone know where I can still find one of these boards?