Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: AmigaOS 3.2 and iBrowse  (Read 2645 times)

0 Members and 1 Guest are viewing this topic.

Offline bradhansen1@cox.net

AmigaOS 3.2 and iBrowse
« on: June 26, 2021, 08:06:46 PM »
Okay, why does it seem like I'm the only one having issues with AmigaOS 3.2.
I cannot get iBrowse to load and run on either my real Amiga or UAE. It says it
needs MUI, I have an LHA file of Mui3.8usr but when I go to unpack it, it only
displays the demo files and says other files were corrupted.  Same thing happens
when unpacking AWeb. So what gives? Why is 3.2 unable to see these files or unable
to handle the unpacking. And how has anyone else gotten iBrowse to run.
Thanks for any advise.
Brad Hansen
 

Offline TribbleSmasher

Re: AmigaOS 3.2 and iBrowse
« Reply #1 on: June 26, 2021, 08:48:14 PM »
Usually i have an additional c-plus directory with tools, unpackers etc. ready to migrate to every new install via WinUAE, so i have LHA and DMS and so on ready. Same goes with MUI, keep an installation in its own directory and use a muisetup script instead of the entries  in user-startup you write only execute s:muisetup.
So you donot need to install again, given you are using the same level of CPU, like 020+.
 

Offline AndyFC

Re: AmigaOS 3.2 and iBrowse
« Reply #2 on: June 26, 2021, 09:59:42 PM »
Do you have access to a different unpacking utility?

I've only ever experienced it once but I had an .lha file which was always corrupt after unpacking with one tool. I unpacked it with the LHA command line and it worked first time.
A1200 in DIY Tower. 3.2 ROMs, 3.5" HD, CD RW and IDE to SD adapter running off the internal IDE port (using the A4000 4-port IDE adapter from Amigakit), Blizzard 1230-IV, with 32MB 60ns RAM and 50MHz 68882 FPU. 3COM PCMCIA Network card running with Miami DX. https://www.youtube.com/watch?v=1PrGdL6XjmE

MorphOS on PowerMac G5 and ATI 9600 pro
 

Offline QuikSanz

Re: AmigaOS 3.2 and iBrowse
« Reply #3 on: June 26, 2021, 10:50:55 PM »

Didn't 3.9 come with a good all around unpacker?

Chris
 

Offline bradhansen1@cox.net

Re: AmigaOS 3.2 and iBrowse
« Reply #4 on: June 26, 2021, 11:37:16 PM »
Thanks all, I will take it all under advisement. I was using Diskmaster II as my
goto unpacker. May have been my mistake.
Brad Hansen

Offline kolla

Re: AmigaOS 3.2 and iBrowse
« Reply #5 on: June 28, 2021, 11:02:26 AM »

Didn't 3.9 come with a good all around unpacker?


3.9 came with XAD 10, from what I recall, and SYS:Tools/Unpack as ReAction frontend.
In the meantime, XAD has become free and version 12.1 is available on Aminet.
« Last Edit: June 28, 2021, 11:05:16 AM by kolla »
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC
---
A3000/060CSPPC+CVPPC/128MB + 256MB BigRAM/Deneb USB
A4000/CS060/Mediator4000Di/Voodoo5/128MB
A1200/Blz1260/IndyAGA/192MB
A1200/Blz1260/64MB
A1200/Blz1230III/32MB
A1200/ACA1221
A600/V600v2/Subway USB
A600/Apollo630/32MB
A600/A6095
CD32/SX32/32MB/Plipbox
CD32/TF328
A500/V500v2
A500/MTec520
CDTV
MiSTer, MiST, FleaFPGAs and original Minimig
Peg1, SAM440 and Mac minis with MorphOS
 

Offline Dynamic_Computing

Re: AmigaOS 3.2 and iBrowse
« Reply #6 on: July 05, 2021, 04:51:03 PM »
I have had issues with some unpacking utilities. Some work great with most archinves but chole on some newer ones. I usually go back to just using good old "LHA" from the shell and have almost no issues.
 

Offline chris

Re: AmigaOS 3.2 and iBrowse
« Reply #7 on: July 06, 2021, 04:48:15 PM »
I have had issues with some unpacking utilities. Some work great with most archinves but chole on some newer ones. I usually go back to just using good old "LHA" from the shell and have almost no issues.

There's a bug in XAD LhA when using newer header versions.  The newer versions of the LhA command line tool default to using a newer header version, so that's why you will see more problems with more recent archives.

The fix is to build xadmaster v13 for 68k.
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline bradhansen1@cox.net

Re: AmigaOS 3.2 and iBrowse
« Reply #8 on: July 12, 2021, 11:55:30 PM »
Hi, Thanks to all, after copying a couple of Library files from 3.9 CD to the OS 3.2 system I was able to get "Unarc" to work
and have had no further issues unpacking any "LHA" files.
Brad Hansen

Offline drphilxray

Re: AmigaOS 3.2 and iBrowse
« Reply #9 on: September 01, 2021, 03:23:19 AM »
funny- not really - this is my problem exactly... after finally getting pistorm online with roadshow,
I download the same mui38.lha from aminet, park it in PI0: or a temp folder (tried ram: too) in dh0:
and upack with lha x blah blah - but upon running installer, no bueno in line 299...

and i just.need.it.for.iBrowse!!! (im using boberg's lha - should i be using different with OS 3.2???)
 

Offline AndyFC

Re: AmigaOS 3.2 and iBrowse
« Reply #10 on: September 01, 2021, 08:18:36 AM »
I set up a friend's A1200 with Roadshow and IBrowse for him a couple of weeks ago on a clean 3.2 installation and used lha.run from Aminet. No problems experienced at all.
A1200 in DIY Tower. 3.2 ROMs, 3.5" HD, CD RW and IDE to SD adapter running off the internal IDE port (using the A4000 4-port IDE adapter from Amigakit), Blizzard 1230-IV, with 32MB 60ns RAM and 50MHz 68882 FPU. 3COM PCMCIA Network card running with Miami DX. https://www.youtube.com/watch?v=1PrGdL6XjmE

MorphOS on PowerMac G5 and ATI 9600 pro
 

Offline walkero

Re: AmigaOS 3.2 and iBrowse
« Reply #11 on: September 01, 2021, 10:25:07 AM »
If you are interested you can have a look at my video at https://www.youtube.com/watch?v=-G2ujYjEPgc where we discuss on how you can bring applications from OS3.9 to OS3.2 like UnArc and AmiDock, and how to set it up to work fine on your system, with a lot of other interesting software. And also, if you have issues how to recognize and fix then.

@TribbleSmasher
Instead of keeping a folder, like you do, and then copy it to every new installation, you could keep it where it is and use it on every AmigaOS installation by adding one line of code in user-startup. And that's not only for commands, but can be applied to libs, classes, devs, application assigns and anything else the OS uses. If you want to see how you can do it, have a look at my video at https://youtu.be/w_65v7lofQk?t=1095
 

Offline mechy

Re: AmigaOS 3.2 and iBrowse
« Reply #12 on: September 02, 2021, 04:08:05 AM »
I think this is the same as unarc on os3.9:
aminet.net/util/arc/MUIUnArc.lha