Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Help with 1.3 ROM For WHDLoad  (Read 686 times)

0 Members and 1 Guest are viewing this topic.

Offline madgrizzle

Help with 1.3 ROM For WHDLoad
« on: August 07, 2017, 01:59:25 AM »
Quick (hopefully) question:  It appears to me the instructions are saying, ignoring Amiga Forever option, to get a 1.3 ROM it has to come from an A500.  I have an A2000 but I have removed the 1.3 ROM and installed a 3.1 ROM.  Can I reinsert my 1.3 ROM, boot from a floppy with grabkick, grab the 1.3 kickstart image, reinsert the 3.1 ROM and copy/rename the file I made?  Or, does it have to come from a real A500?
Only Amiga *woo-woo* Makes It Possible
Only Amiga   ... Makes.. It .. Happen!
Amiga 2000, 2MB Chip RAM, OS3.9, GVP Combo 030/22 13 MB, Supra 4MB
Amiga 3000, 16 MB RAM, OS3.9, A3640 v3.2 with 060 Processor, Picasso II, A2065, PCD-50B
Dead VA2000/CX :(
 

Offline Oldsmobile_Mike

Re: Help with 1.3 ROM For WHDLoad
« Reply #1 on: August 07, 2017, 02:35:18 AM »
A500 ROM is the same as A2000 ROM.  That being said, there's plenty of places online you can download one from if you want to save the time, wear & tear on the pins, etc.  Google is your friend.  ;)
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline madgrizzle

Re: Help with 1.3 ROM For WHDLoad
« Reply #2 on: August 07, 2017, 03:10:06 AM »
Quote from: Oldsmobile_Mike;829173
Google is your friend.  ;)


Ah, my favorite saying.  I tried that route first, but unfortunately it wasn't being a good friend and what I found didn't seem to work.  Will have to dig deeper. I have been assuming the error 205 object not found was because the ROM version.  Thanks for input..  

Wish I could find my old Amiga Forever copy.. I don't know how long ago I bought it nor can't I find any emails with order information on it.
Only Amiga *woo-woo* Makes It Possible
Only Amiga   ... Makes.. It .. Happen!
Amiga 2000, 2MB Chip RAM, OS3.9, GVP Combo 030/22 13 MB, Supra 4MB
Amiga 3000, 16 MB RAM, OS3.9, A3640 v3.2 with 060 Processor, Picasso II, A2065, PCD-50B
Dead VA2000/CX :(
 

Offline Matt_H

Re: Help with 1.3 ROM For WHDLoad
« Reply #3 on: August 07, 2017, 04:28:27 AM »
Quote from: madgrizzle;829172
Can I reinsert my 1.3 ROM, boot from a floppy with grabkick, grab the 1.3 kickstart image, reinsert the 3.1 ROM and copy/rename the file I made?


Yes. Or do what Mike suggests :)
 

Offline magnetic

Re: Help with 1.3 ROM For WHDLoad
« Reply #4 on: August 08, 2017, 02:09:09 AM »
Quote from: madgrizzle;829174
Ah, my favorite saying.  I tried that route first, but unfortunately it wasn't being a good friend and what I found didn't seem to work.  Will have to dig deeper. I have been assuming the error 205 object not found was because the ROM version.  Thanks for input..  

Wish I could find my old Amiga Forever copy.. I don't know how long ago I bought it nor can't I find any emails with order information on it.


Amiga forever does have the roms if you find it...
bPlan Pegasos2 G4@1ghz
Quad Boot:Reg. MorphOS | OS4.1 U4 |Ubuntu GNU-Linux | MacOS X

Amiga 2000 Rom Switcher w/ 3.1 + 1.3 | HardFrame SCSI | CBM Ram board| A Squared LIVE! 2000 | Vlab Motion | Firecracker 24 gfx

Commodore CDTV: 68010 | ECS | 9mb Ram | SCSI -TV | 3.9 Rom | Developer EPROMs
 

Offline Oldsmobile_Mike

Re: Help with 1.3 ROM For WHDLoad
« Reply #5 on: August 08, 2017, 02:30:48 AM »
Quote from: magnetic;829194
Amiga forever does have the roms if you find it...

Can you use the AF ROM's on a real Amiga?  I thought I recall that they're hacked in some way to prevent this?
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline magnetic

Re: Help with 1.3 ROM For WHDLoad
« Reply #6 on: August 08, 2017, 02:36:47 AM »
Quote from: Oldsmobile_Mike;829195
Can you use the AF ROM's on a real Amiga?  I thought I recall that they're hacked in some way to prevent this?


yes once you own the AF you own the rom images too? Its what I use for whdload.
bPlan Pegasos2 G4@1ghz
Quad Boot:Reg. MorphOS | OS4.1 U4 |Ubuntu GNU-Linux | MacOS X

Amiga 2000 Rom Switcher w/ 3.1 + 1.3 | HardFrame SCSI | CBM Ram board| A Squared LIVE! 2000 | Vlab Motion | Firecracker 24 gfx

Commodore CDTV: 68010 | ECS | 9mb Ram | SCSI -TV | 3.9 Rom | Developer EPROMs
 

Offline madgrizzle

Re: Help with 1.3 ROM For WHDLoad
« Reply #7 on: August 08, 2017, 03:25:02 PM »
Got it working.  My 1.3 ROM was working all along, but somehow I messed something up on the extraction of a game and after staring at the directory structure/contents I figured out it was hosed.

I have 1.3 and 3.1.. so far it seems like that would work for most things.

I love the PCD-50B.  I makes life so much easier.
Only Amiga *woo-woo* Makes It Possible
Only Amiga   ... Makes.. It .. Happen!
Amiga 2000, 2MB Chip RAM, OS3.9, GVP Combo 030/22 13 MB, Supra 4MB
Amiga 3000, 16 MB RAM, OS3.9, A3640 v3.2 with 060 Processor, Picasso II, A2065, PCD-50B
Dead VA2000/CX :(