Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: AFA OS and Amiga OS 3.2  (Read 1509 times)

0 Members and 1 Guest are viewing this topic.

Offline Tumbleweed

AFA OS and Amiga OS 3.2
« on: November 03, 2021, 11:12:58 AM »
Hi all

I have OS3.2 and OS3.2 Roms. I downloaded AF_OS 4.9 from Aminet. Installation says I need to patch RAWBINFO v1.35 but I cant get hold of the file. I have OS3.9 CD and BB1,2,3 & 4. The OS3.9 CD has RAWBINFO v1.36 - where can I get v1.35?

Best.

Weed
A3000T, Cybervision64, CSMKII 060; A3000D, PicassoII, Z3 Fastlane; A2000D, 040, PicassoII; A4000D, A1200, Blizzard 030 MKIV - both not working :(
 

Offline walkero

Re: AFA OS and Amiga OS 3.2
« Reply #1 on: November 03, 2021, 02:26:30 PM »
Why does this need to be patched?
 

Offline Matt_H

Re: AFA OS and Amiga OS 3.2
« Reply #2 on: November 03, 2021, 02:37:24 PM »
I only see version 4.8 on Aminet which is from 2017. I would expect problems if you install that over the newer OS3.2.

That said, the version of RAWBInfo you’re looking might be part of OS3.5 or its BoingBags rather than OS3.9.
 

Offline walkero

Re: AFA OS and Amiga OS 3.2
« Reply #3 on: November 03, 2021, 03:11:51 PM »
There are some issues with AmigaOS 3.2 which I covered in my streams. But some things are quite usable. The videos from these streams can be found at https://www.youtube.com/watch?v=PDyaiy1l7gQ and https://www.youtube.com/watch?v=ItyA4zJ5EV4, with extra information on how to make the AmigaOS 3.2 Workbench look incredible.
 
The following users thanked this post: Tumbleweed

Offline Tumbleweed

Re: AFA OS and Amiga OS 3.2
« Reply #4 on: November 03, 2021, 05:28:36 PM »
Matt you are correct its v4.8 I have - typo on my part.

v1.35 is part of one of the boing bas (BB3 I think). Problem is you cat get to this file easily as the BB1 & 2 bags have a password on the .zip archive. The solution I have settled on is to install OS3.9 and then the Boing Bag and copy RAWBINFO v1.35 from there. The problem with this though is I dont think you cant install OS 3.9 on a machine with 3.2 ROMS (not easily anyway).

So my solution is to install OS3.9 BB1 & BB2 on my A2000 with 3.1 Roms. Copy RAWBINFO from the A2000 onto a floppy disk and use that to transfer the file to my 3000T. Then run the patch as per the AFAOS install instructions and see what happens.

As a thought is it possible to softkick the KS 3.1 ROM so that you can run OS3.9 on a machine with 3.2 ROMS?

Best.

Weed.
A3000T, Cybervision64, CSMKII 060; A3000D, PicassoII, Z3 Fastlane; A2000D, 040, PicassoII; A4000D, A1200, Blizzard 030 MKIV - both not working :(
 

Offline Matt_H

Re: AFA OS and Amiga OS 3.2
« Reply #5 on: November 03, 2021, 06:28:29 PM »
That sounds unnecessarily complicated! The passwords to the BoingBag archives are known - check this EAB thread for some leads.
 

Offline Tumbleweed

Re: AFA OS and Amiga OS 3.2
« Reply #6 on: November 04, 2021, 11:17:16 AM »
Thanks Matt I saved a bit of time by doing some googling and reading the EAB threads. I go the v1.35 version off BB2 and patched it successfully.

Getting AfA-OS to work though is proving a challenge though. I have added C:morelibspace (first line) and c:AFA_OS_Loader (just after datatypes) to my startup sequence but the AFA prefs options are ghosted out. Cant select the new skins.

I have read that AfA may only work with older versions of setpatch and workbench.library. Reading through the OS3.2 FAQ's looks like both of these changed from the OS3.9 versions. Maybe its not possible to run AfA_OS in OS 3.2. It seems to work though on 3.1.4 (there is a youtube vid of it running on a vampire v2).

That said I found this:

https://ae.amigalife.org/index.php?topic=720.0

More reading needed.

Best.

Weed.
« Last Edit: November 04, 2021, 11:24:55 AM by Tumbleweed »
A3000T, Cybervision64, CSMKII 060; A3000D, PicassoII, Z3 Fastlane; A2000D, 040, PicassoII; A4000D, A1200, Blizzard 030 MKIV - both not working :(
 

Offline Tumbleweed

Re: AFA OS and Amiga OS 3.2
« Reply #7 on: November 04, 2021, 01:41:37 PM »
Awesome vids! Off to get myself birdie and visual prefs.
A3000T, Cybervision64, CSMKII 060; A3000D, PicassoII, Z3 Fastlane; A2000D, 040, PicassoII; A4000D, A1200, Blizzard 030 MKIV - both not working :(