Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: AmiVNC won't connect  (Read 976 times)

0 Members and 1 Guest are viewing this topic.

Offline Michele31415

AmiVNC won't connect
« on: October 22, 2021, 05:15:29 PM »
I'm trying to get an AmiVNC server running, but I'm getting:
Code: [Select]
3.FS3:AmiVNC/Executables/RTG & Planar> run AmiVNC.020 -v
[CLI 4]
3.FS3:AmiVNC/Executables/RTG & Planar> AmiVNC 68K 1.0.0 Aug 30th 2001 (StormC4/GCC)
(c) 1999-2001 stephane.guillard@steria.fr
main : parameter values :
 - listen port set to 5900
 - endian set to little
 - initial xfer limit set to FFFFFFFF
 - color bitshifts : red 8, green 16, blue 24
 - log file set to stdout
 - VVA BGR233 encoding : no
 - user command on client login : none
 - user command on client logout : none
main : Creating listener socket
main : Binding socket on port 5900
main : Listening set on port 5900
main : Waiting for client connection
Genesis is running, I can ping the Amiga, and both ftp and AWeb-II work OK.  But if I try to open a vncviewer from my PC to the Amiga's IP:5900, it goes "connection refused".   The Genesis log creates a line "Access from 192.168.0.xx to port 5900 denied".  Same thing trying to connect from the Sun.  What am I doing wrong?

UPDATE
The answer to that problem was here: https://forum.amiga.org/index.php?topic=50301  I just needed to add a line for port 5900 in AmiTCP:db/inet.access

Now I can connect and open a vncviewer window but it's all black, so we're not quite there yet.

But this was with amivnc 1.0.0, so I downloaded amivnc4.  This one won't even start up:

Code: [Select]
3.FS3:AmiVNC4> list
AmiVNC4                         173523 ----rwed 03-Jan-10 18:46:42
AmiVNC4.info                      2508 ----rwed 19-Nov-09 17:10:50
AmiVNC4_cmd_relnotes.txt         13905 ----rwed 23-Apr-10 21:59:00
AmiVNC4_debug                    80813 ----rwed 12-Mar-08 14:21:26
src                                Dir ----rwed Today     15:07:38
4 files - 1 directory - 536 blocks used
3.FS3:AmiVNC4> amivnc4 -h
amivnc4: file is not executable
3.FS3:AmiVNC4>

« Last Edit: October 22, 2021, 08:18:25 PM by Michele31415 »
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091
 

Offline Thomas

Re: AmiVNC won't connect
« Reply #1 on: October 22, 2021, 10:20:04 PM »
Genesis is running

Genesis has a port filter which by default rejects all incoming connections. You have to add an exception for port 5900 to that filter. Or remove the default rule.


see also:
https://forum.amiga.org/index.php?topic=50301.msg530465#msg530465
https://forum.amiga.org/index.php?topic=17865.msg648379#msg648379
« Last Edit: October 22, 2021, 10:29:34 PM by Thomas »
 

Offline Michele31415

Re: AmiVNC won't connect
« Reply #2 on: October 23, 2021, 01:12:13 AM »
Thanks, yes that fixed that.  Now I can open a connection but with amivnc 1.0.0 all I get is a black window in my vncviewer and with 4.0 it says amivnc isn't even an executable file.
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091
 

Offline nbache

Re: AmiVNC won't connect
« Reply #3 on: October 23, 2021, 12:00:52 PM »
AmiVNC4 is AFAIK only for OS4+.

Best regards,

Niels
 
The following users thanked this post: Michele31415

Offline Michele31415

Re: AmiVNC won't connect
« Reply #4 on: October 23, 2021, 05:03:12 PM »
Arrgh - thanks, you're right - and it says so right in the readme.  I skipped right over that.  Duh.

So now we're back to v. 1.0.0.  I thought maybe it didn't like my display mode.  In the readme it says:
Quote
To run AmiVNC you need :
- any native planar Amiga screenmode (PAL, NTSC, AGA etc.)
  or 15, 16, 24 or 32 bit RTG mode (CGFX or Picasso96)
I had Picasso96 running on my Spectrum at 1024x768, 8 colors.  That produced a black window of 1024x768 in vncviewer.  I switched the screen mode to 1024x768, 256 colors.  Now when I run vncviewer I get a window that's 1024x8, and then it quickly closes itself.  The amivnc log is now:
Code: [Select]
3.FS3:AmiVNC/Executables/RTG & Planar> AmiVNC 68K 1.0.0 Aug 30th 2001 (StormC4/GCC)
(c) 1999-2001 stephane.guillard@steria.fr
main : parameter values :
 - listen port set to 5900
 - endian set to little
 - initial xfer limit set to FFFFFFFF
 - color bitshifts : red 8, green 16, blue 24
 - log file set to stdout
 - VVA BGR233 encoding : no
 - user command on client login : none
 - user command on client logout : none
main : Creating listener socket
main : Binding socket on port 5900
main : Listening set on port 5900
main : Waiting for client connection
main : accept()ed connection from 192.168.0.78 on socket 1
main : Negociating protocol version
main : Protocol supported by server : 3.3, by client : 3.3
main : Authentication
main : ClientInitialisation
main : SharedFlag = 0 (multiple clients : No)
main : Screen set to [] (RTG)
main : RTG mode Pic96/0 @ 0x008C84F0, 1024x8, 1 Bpp, size 16384
vProcessIncomes runs on socket 0
So there must be some screen mode issue going on here.  Does anyone have amivnc running with Picasso96?  In what screen mode?
« Last Edit: October 23, 2021, 07:20:46 PM by Michele31415 »
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091
 

Offline nbache

Re: AmiVNC won't connect
« Reply #5 on: October 23, 2021, 10:31:59 PM »
If it wants 15 bits as the lowest RTG mode, 256 colors doesn't sound like enough. 15 bits would be 32768 colors.

But I dont remember exactly how those modes work under classic. I use ARGB32 on my OS 4.1 WB.

It's been a long time since I dabbled with VNC, though.

Best regards,

Niels
 

Offline Michele31415

Re: AmiVNC won't connect
« Reply #6 on: October 25, 2021, 05:04:42 PM »
If it wants 15 bits as the lowest RTG mode, 256 colors doesn't sound like enough. 15 bits would be 32768 colors.
I guess that's the key then.  However, I can't seem to be able to find a 1024x768 mode higher than 256 color that doesn't end with either "Screen too large for this card! Sorry.", "Signal over range" (on the monitor), or no signal at all.  I've tried HiColor and TrueColor, both interlaced and non-interlaced.  Maybe I'll try a different monitor.  I don't really want to have to run in a lower resolution just to please AmiVNC (which apparently runs very slow anyway).

UPDATE:

It appear from reading the Spectrum manual (p. 1.8 ) that 8 bit color is all you get for a Workbench display at any resolution, even down to 320x200.  1024x768 16 bit color is only available on an EGS display.  And since I'm using Picasso96 and not EGS, I guess you can't get there from here.  No AmiVNC for you!
« Last Edit: November 14, 2021, 07:24:16 PM by Michele31415 »
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091