Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: OS 3.9 Cannot open "resource.library"  (Read 3232 times)

0 Members and 1 Guest are viewing this topic.

Offline zipper

Re: OS 3.9 Cannot open "resource.library"
« Reply #15 on: September 26, 2021, 06:29:28 PM »
ClassAct spoils Reaction.
 

Offline Matt_H

Re: OS 3.9 Cannot open "resource.library"
« Reply #16 on: September 26, 2021, 07:15:06 PM »
Are you still getting the resource.library error? If so, yes, re-copy those files from the CD. (I'm assuming that your OS installation is basically stock apart from AmiFTP, MUI, Trident.)
Yes, it's still throwing that error, and the fuelgauge.gadget error from AmiFTP too.  So copy all the library files from the CD back to FS3:libs?

Yes, but it's the contents of the Classes directory on the CD to SYS:Classes, not the contents of Libs on the CD to SYS:Libs. It's a 2-part shell operation:
Code: [Select]
copy AmigaOS3.9:OS-Version3.9/Workbench3.5/Classes/#? SYS:Classes ALL CLONE
copy AmigaOS3.9:OS-Version3.9/Workbench3.9/Classes/#? SYS:Classes ALL CLONE

Quote
Lost cause, I'm afraid. If you resize a partition you need to reformat it. But it might be worth undertaking that operation (back up to another partition first!) to prevent problems like what kolla describes. You're playing with fire with a 4GB boot partition.

Well then I'll have to do that.  Is it OK to try to fix the library problem first?

Yes, get the system stable first. Then use Thomas's check4gb which will give you precise info on whether you need to undertake this operation.

Quote
This is a strange one. Start by re-downloading the Boing Bag, re-copying it to your system, re-extracting it and trying again.
My only other guess is that you have an old version of Installer that can't correctly parse the install script. In a shell, type 'which installer' - it will probably report C:Installer or SYS:Utilities/Installer. Whatever it tells you, now type 'version SYS:Utilities/Installer full' (but use whatever path the 'which' command gave you) and report back.
Code: [Select]
FS3: > which installer
FS3:Utilities/Installer
FS3: > version FS3:Utilities/Installer full
installer 44.10 (10/01/1999)

I should add that the problems began after installing AmiFTP, but AmiFTP requires ClassAct, so I installed that too.  Classes?  Hmmm...   Maybe ClassAct is the culprit here.

Yes, as zipper says, it's ClassAct that's responsible for the resource.library and fuelgauge problems. That's what I was trying to say in my first post. Your Installer is the correct version. I don't think ClassAct would affect the BoingBag installation, but it's possible (depending on how the internal checks of the installation operate). Fix the other problems first, then come back to this one.
 

Offline Michele31415

Re: OS 3.9 Cannot open "resource.library"
« Reply #17 on: September 28, 2021, 07:52:55 PM »
Well now this is odd.  Figuring I'd just give up on AmiFTP, I installed gui-ftp.  It goes into execution and I can connect to a server but it won't download anything.  Next up was rsync-2.5.5.  That refused to run without ixemul-48.0 so I installed that too.  rsync also started running but something is wrong with its handshaking with the remote machine and it just hangs.  Oh well.  So then jsut for laughs I tried AmiFTP again - and this time it worked!  No "can't open library" errors.  ???  Go figure.
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091
 

Offline Matt_H

Re: OS 3.9 Cannot open "resource.library"
« Reply #18 on: September 28, 2021, 10:04:01 PM »
Well now this is odd.  Figuring I'd just give up on AmiFTP, I installed gui-ftp.  It goes into execution and I can connect to a server but it won't download anything.  Next up was rsync-2.5.5.  That refused to run without ixemul-48.0 so I installed that too.  rsync also started running but something is wrong with its handshaking with the remote machine and it just hangs.  Oh well.  So then jsut for laughs I tried AmiFTP again - and this time it worked!  No "can't open library" errors.  ???  Go figure.

Did you restore the contents of SYS:Classes from the 3.9 CD? If so, AmiFTP and any other ClassAct programs should work out-of-the-box. ReAction (i.e., the contents of SYS:Classes on OS3.9) replaces/supersedes ClassAct. Since you had installed ClassAct over 3.9, you ended up with a mix of ClassAct and ReAction classes, which caused your original problem.
 

Offline Michele31415

Re: OS 3.9 Cannot open "resource.library"
« Reply #19 on: September 29, 2021, 05:08:51 PM »
Yes, but it's the contents of the Classes directory on the CD to SYS:Classes, not the contents of Libs on the CD to SYS:Libs. It's a 2-part shell operation:
Code: [Select]
copy AmigaOS3.9:OS-Version3.9/Workbench3.5/Classes/#? SYS:Classes ALL CLONE
copy AmigaOS3.9:OS-Version3.9/Workbench3.9/Classes/#? SYS:Classes ALL CLONE
OK, I did both of those and then a cold boot.  It boots OK but version reports Workbench 40.42 and AmiFTP is back to complaining about version 42 of gadgets/layout.gadget.  version layout.gaget reports 45.4.  Interesting that it's not complaining about fuelgauge now - this is a different gadget.

Yes, get the system stable first. Then use Thomas's check4gb which will give you precise info on whether you need to undertake this operation.
It says:
Quote

Name     Volume       Size Device       Unit Version  DosType  Version   Big Check
DH1      FS3         4095G gvpscsi         0 3.7      DOS1     40.1      yes * S
DH0      FS4         4030M gvpscsi         1 3.7      DOS1     40.1       no ok
SDH1     FS5         2047M gvpscsi         3 3.7      DOS3     40.1       no ok
CD0      AmigaOS3.9   467M gvpscsi         6 3.7      ASIM     3.6        no ok
PC0                   720K mfm             0 40.9     MSD0     40.19      no ok
DF0                   880K trackdisk       0 40.1     DOS0     40.1       no ok
DF1      AsimCDFS_v3_Instal880K   880K trackdisk       1 40.1     DOS0     40.1       no ok

Yes, as zipper says, it's ClassAct that's responsible for the resource.library and fuelgauge problems. That's what I was trying to say in my first post. Your Installer is the correct version. I don't think ClassAct would affect the BoingBag installation, but it's possible (depending on how the internal checks of the installation operate). Fix the other problems first, then come back to this one.
I also tried running BoingBag3.9-1 again.  This time it doesn't complain about the CD-ROM but when I click Proceed, the install window disappears and then nothing happens - no errors, no messages, nothing.
« Last Edit: September 29, 2021, 05:15:30 PM by Michele31415 »
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091
 

Offline Matt_H

Re: OS 3.9 Cannot open "resource.library"
« Reply #20 on: September 30, 2021, 08:00:57 PM »
I can't tell from here what it is exactly, but your system has some serious software issues. It looks like 3.9 is not correctly/fully installed. Workbench should be 45.x. Your filesystem version (as reported in check4gb) should also be 45.x rather than 40.1.
 

Offline Michele31415

Re: OS 3.9 Cannot open "resource.library"
« Reply #21 on: September 30, 2021, 08:35:51 PM »
Why don't I just try the install from the 3.9 CD over again.  It would be nice if I could do that without killing my x-surf and Deneb installations but at this point it may be quicker to just rebuild those than continuing to try and untangle this mess.
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091
 

Offline QuikSanz

Re: OS 3.9 Cannot open "resource.library"
« Reply #22 on: October 01, 2021, 01:04:29 AM »

 I have to install 3.9 twice and even then it write protects some stuff and won't reinstall them. At that point I go to Dopus or Dir Work to move/copy files and get rid of the write protect.

Chris

PS: A similar speced 2000 6.2 machine 030/40 combo.
 

Offline Michele31415

Re: OS 3.9 Cannot open "resource.library"
« Reply #23 on: October 01, 2021, 01:11:22 AM »
Oh, that's good to know.  Could you tell me a bit more?  I odn't know what Dopus or Dir Work is.  How do I get rid of write protect?
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091
 

Offline QuikSanz

Re: OS 3.9 Cannot open "resource.library"
« Reply #24 on: October 01, 2021, 03:34:00 AM »
Directory Opus is very configurable but may be difficult, Dir Work is just 1 thing, 2 windows side by side, to and from with buttons for protect, executable and so on. It's old and on aminet.

Chris
 

Offline Thomas

Re: OS 3.9 Cannot open "resource.library"
« Reply #25 on: October 01, 2021, 07:30:02 AM »
It says:

You've got a serious issue with that FS3 partition. It is reported as almost 4TB, that's far beyond an Amiga's capability. Not to mention that FFS V40 can only access less than 4GB. This is also the reason why it gurus after loading the OS 3.9 ROM update.

I checked with UAE. It happens if you use HDToolbox of OS 3.1 and cylinder numbers overflow. You should recreate the partition with HDToolbox of OS 3.9. And you should update FFS to version 45.


Offline QuikSanz

Re: OS 3.9 Cannot open "resource.library"
« Reply #26 on: October 01, 2021, 07:06:16 PM »

Lol, good catch Thomas, didn't even notice the G at the end.  :o
 

Offline Michele31415

Re: OS 3.9 Cannot open "resource.library"
« Reply #27 on: October 01, 2021, 08:36:57 PM »
Heh!  Me either.  I ran the check4gb program, copied its output to my PC, then copied it into my post here, and in not one of those operations did I notice it said G instead of M for DH1.  Obviously that's impossible since the entireSD card is only 16 GB.  I'd say excellent catch, Thomas!

So I repartitioned DH1 using the 3.9 HDToolBox and made it smaller this time, and ran check4gb again.  Now it shows:

Quote
Name     Volume       Size Device       Unit Version  DosType  Version   Big Check
DH1                   985M gvpscsi         0 3.7      DOS1     45.9       no ok
DH0                  4030M gvpscsi         1 3.7      DOS1     45.9       no ok
QDH0     QDH0        2169M gvpscsi         2 3.7      DOS3     45.9       no ok
SDH1     FS5         2047M gvpscsi         3 3.7      DOS3     45.9       no ok
EMERGENCY_CD AmigaOS3.9   512M gvpscsi         6 3.7      CD01     42.19      no ok
DF0      Emergency-Disk   880K trackdisk       0 40.1     DOS0     45.9       no ok
DF1      AsimCDFS_v3_Instal880K   880K trackdisk       1 40.1     DOS0     45.9 

Then I formatted DH1 as FS3, did a complete install of 3.9 from the CD-ROM and CTL-A-A rebooted.  This time FS3 booted fine with no gurus, WB reported 45.1, and AmiDock started without errors.  Then I tried installing BB1.  That worked fine too.  No complaints about the CD-ROM, everything installed fine.

So I rebooted, installed BB2 and rebooted again.  This time I got a yellow "Recoverable error" box.  I clicked left and got the error again.  I clicked left again and then it booted into FS3 correctly.  I tried a cold boot and got the same error.  So what's up with that?  FWIW I said Yes when BB2 offered to update my Amiga OS ROM Update.  Was that a mistake?  Here's the log:

Quote
******* Installation Log *******
User Level: AVERAGE
Pretend: No


>On which partition should Boing Bag 2 for AmigaOS 3.9 be installed?
Ask Drawer: Result was "FS3:".
Run Program: "C/Version "FS3:Libs/xadmaster.library" FILE VERSION 10"

>
>BoingBag 3.9-2 contains a new AmigaOS ROM Update. Although it has been
>tested thoroughly it may fail on some hardware configurations. Do you
>wish to install it?
>
>IMPORTANT: Please REALLY read the help text. ROM Update is provided with
>only limited warranty and support! Neither Amiga Inc. nor HAAGE&PARTNER
>are obliged to make sure that it will work on your system. Please also
>read the Readme file.
>
>The AmigaOS ROM Update is installed on your system. So generally, it
>should be safe for you to update it.
Ask Question: Result was "Install ROM Update".
Run Program: "C/Updater AmigaOS-Update "FS3:""
Run Program: "C/Updater XAD-Update "FS3:""
Copy file "FS3:Devs/AmigaOS ROM Update" to "FS3:Devs".
Copy file "FS3:Devs/AmigaOS ROM Update.BB39-2" to "FS3:Devs".
Copy file "C/Installer" to "FS3:C".
Copy file "C/Installer" to "FS3:Utilities".
Run Program: "C/RemoveResident"
Exiting script...


In any event aside from that things are looking much better now.
« Last Edit: October 01, 2021, 08:39:05 PM by Michele31415 »
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091
 

Offline Thomas

Re: OS 3.9 Cannot open "resource.library"
« Reply #28 on: October 01, 2021, 09:33:32 PM »
This time I got a yellow "Recoverable error" box.

What's the error number?

Offline Michele31415

Re: OS 3.9 Cannot open "resource.library"
« Reply #29 on: October 01, 2021, 10:13:58 PM »
It says:

Recoverable Alert.  Press left mouse button to continue.
Error: 0100 0003    Task: 00212E18

Oddly enough, when I cold-booted it this time, I only saw that once.  After clicking left, it continued to boot normally.  Was BB2 a bag too far?

UPDATE: Apparently, the error message goes away on its own after about 20 seconds even if you don't click on anything.  It then proceeds to finish booting normally.
« Last Edit: October 03, 2021, 09:50:06 PM by Michele31415 »
Active: B2000 4.4, A2630, GVP 2000 HC+8, DKB 2632, SCSI2SD, Gotek, Deneb USB, XSurf 3cc, CD ROM, Megachip 2000, ECS Agnus, Denise, OS 3.9, GVP Spectrum EGS 28/24, Silicon Springs GOMF
Retired: A2088, 8-Up, A2090a, Oktagon 2008, Kitchen Sync
Busted: A2091