Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

 



My AmigaOS Desktop
My AmigaOS Desktop
Previous Image | Next Image
Description: Simple configured AmigaOS running on Escom A1200HD only expanded with 4MB of Fast RAM. There is also WiFi Netork Card plugged in and the chatting / browsing is possible...
Picture Stats:
Views: 2062
Filesize: 65.97kB
Height: 768 Width: 1024
Posted by: czarek at November 18, 2006, 07:06:23 PM

0 Members and 1 Guest are viewing this picture.

Comments (12)

leirbag28
Posts:1793
January 22, 2008, 10:49:43 PM
@czarek

Dude...can you PMail me?  I want that backrop!

I use 64 colors too and my 1200 runs like a breeze. yours looks nice
czarek
Posts:74
November 24, 2006, 03:34:19 PM
Cool! Thanks a lot AMIGAZ. I'm going to test all of this after work.
I wish I had my apollo now but I have to wait 3 weeks for my holiday :madashell:
Amigaz
Posts:1944
November 24, 2006, 01:16:49 PM
@czarek

Nope but if you search for it at English Amiga Board in the forum you'll find it..I can send it to you in the worst case.
Maybe you don't need fastexec..check with sysinfo, if exec.library isnt in fastram you should use fastexec
PS. you don't need CGX for cyberbugfix..you'll get cybergraphics.library with it ;)
czarek
Posts:74
November 24, 2006, 09:42:30 AM
Thanks for advice AMIGAZ - I will try it for sure. Is it available on aminet? Does it require CybergraphX software installed? If it does i don't think it's worth spending $$ for CybergraphX just to save 200k of chip.
Do you know FastExec? I'm just about to test it. AFAIK it's a patch loading some exec routines to fast instead of chip to make system run faster and save some chipram.
Amigaz
Posts:1944
November 23, 2006, 08:15:12 PM
@czarek

When you'll have more ram with the Apollo 1240 try cyberbugfix which is a monitordriver using CybergraphX libs which will save lots of more chipram and speed up things ;)
I run it along with FBlit and systempatch..it saved me another 200kbyte of chipram  ;-)
czarek
Posts:74
November 21, 2006, 12:24:12 PM
Yes Hyperion states 8MB minimum Fast RAM is required but apparently it's not true ;)
To save some CPU power and memory I converted all background pattenrs (2 only used- dark and light - troughout all system - in MUI, classACT/reAction, Workbench) to uncompressed ILBM IFFS. They are also very small (256x256).
I am using FBlit and SystemPatch to speed up some system's graphics routines. I also have IconsBeFast from aminet installed which speeds up loading of full color icons.
Internet stuff is in fact not very demanging. Prism2 driver takes just few KBs of memory and genesis stack when running without GUI (switched off in genesis prefs) takes about 150KB of RAM.
Obviously browsers have image loading swiched off and I can't use more than one window when browsing (RAM is running out so quickly). Also all other apps (email, jabber) have to be swiched off when browser is running.
I don't think running OS 3.9 on such poor config is as big achievement as running it on A500.
But anyways I just ordered Apollo 1240 with 32MB of Fast RAM for my amiga. Let's see how fast will my workbench be on this config :-D
philipj
Posts:61
November 20, 2006, 02:20:34 PM
Ah I see; that is interesting. I had no idea so little fast-ram was needed if you really know what you are doing.

Are there some kind of patches that can improve performance with this kind of spec.? (I'm guessing that is what the initial poster was talking about, but I'm not very well up on 3rd party patches).
derringer3
Posts:368
November 20, 2006, 01:14:50 PM
IT IS possible. AFAIK os3.9 needs only 68020.
The minimum ram size is 6mb, but I installed os3.9 to my old a500. (Of course i have an mtec 68030 accelerator) And I have only 5.5Mb ram. (1,5Chip, 4Mb Fast)
So when the system booted up i have about 300k chip and 500k fast as free memory. Of course it was painfully slow, so i decided to use OS3.1 instead.
philipj
Posts:61
November 19, 2006, 04:28:05 PM
Hmmz, forgive my ignorance but i didn't think this was possible on a standard A1200 with 4mb expansion. I thought OS3.9 needed at least a 030 and a bit more fast ram.

How did you get it to run okay on your minimal system? Because I certainly like the idea of keeping everything simple and still managing to do internet stuff on OS3.9! :-)
cv643d
Posts:1197
November 18, 2006, 10:53:45 PM
Empy-GUI is a classic.
czarek
Posts:74
November 18, 2006, 08:26:56 PM
Yes. There is Birdie running. I also use System Patch and FBlit that makes everything usable with 64 color pallete on my poor config. Background patterns are converted by myselft to ILBM IFFs to save some memory and CPU power. That's it. Everything else is just stock pure AmigaOS.
Amigaz
Posts:1944
November 18, 2006, 08:10:44 PM
Simple and tasteful  :-)

Any patches used? I think I can spot at least Birdie running  ;-)


Powered by: SMF Gallery