Amiga computer related discussion => Amiga Hardware Issues and discussion => Topic started by: giZmo350 on March 24, 2018, 10:56:12 PM

Title: SCSI2SD v5 Update Firmware...
Post by: giZmo350 on March 24, 2018, 10:56:12 PM
Never Mind.... it works.

So just received the SCSI2SD v5 board and am trying to update the firmware. I downloaded the flash tool and the latest firmware. However, nothing happens after connecting the board to a USB cable.

Followed these steps...

1. Run the scsi2sd-util line utility.
2. Select "Upgrade Firmware" from the scsi2sd-util File menu, and select the firmware file. Click OK.
3. Connect the USB cable.

The log window should show the device found and the firmware updated. NOPE.

The utility just shows a progress bar continually searching for a "bootloader"
I saw the boot loader files on their website but it is not a file that I can download. When I click the bootloader file, it opens in the browser with a very long string of hex. I also can't download it by clicking "save file as" either.

I'm stumped. The troubleshooting remarks only state to try another USB cable. I tried with 4 different cables.* Hmmmmmm :(

Any suggestions?

Also tried this......

Using scsi2sd-util, with the USB cable connected to the SCSI2SD board, and with the log window showing that the SCSI2SD device has been detected, click [Load from device] to get the current configuration.

No worky either.... never detects the board. BTW, what position is the jumper supposed to be in? There's nothing in the user doc page for that either. I tried both positions; ON=flash of a yellow LED. OFF=LED glows from dim to bright and the turns off but still no detection.

OK, never mind all that.... dug up a 5th cable and it works. :)

*Maybe I should not thrown away all those cheap cell phones that wouldn't charge! :lol: