Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Is this fixable, or does anyone know where I can have it fixed?  (Read 1049 times)

0 Members and 1 Guest are viewing this topic.

Offline carvedeye

Is this fixable, or does anyone know where I can have it fixed?
« on: December 29, 2020, 07:22:19 PM »
my towered amiga 1200 was working fine, then i got a fishy burning smell and amiga decided to restart itself. so i need to know is this going to be an easy fix if  i send it off to amigakit?
A1200T: M1230XA 50Mhz 68030 w/64mb,DVDRom, 80gb hdd, Realtek LAN Card, Mediator LT4 + Radeon 9250 128mb(used for fast ram), Spider USB Card, Voodoo 3 3000 OS 3.9 +bb 1-3
 

Offline carvedeye

Re: Is this fixable, or does anyone know where I can have it fixed?
« Reply #1 on: December 29, 2020, 10:05:38 PM »
33 views and no reply?
A1200T: M1230XA 50Mhz 68030 w/64mb,DVDRom, 80gb hdd, Realtek LAN Card, Mediator LT4 + Radeon 9250 128mb(used for fast ram), Spider USB Card, Voodoo 3 3000 OS 3.9 +bb 1-3
 

Offline giZmo350

Re: Is this fixable, or does anyone know where I can have it fixed?
« Reply #2 on: December 29, 2020, 10:25:22 PM »
Where are you located?   8)
A500: 2MB Chip, 8MB Fast, IndiECS, MiniMegi, IDE4ZorroII on Z-500, KS1.3/KS3.1, WB3.1&BWB
 
A2000HD: 2MB Chip, 128MB Fast, P5:Blizz 2060@50MHz, PCD-50B/4GBCF, XSurf100, RapidRoad, IndiECS, Matze RTG, MiniMegi, CD-RW, SunRize AD516, WB3.9
 
A1200: 2MB Chip, 64MB Fast, 4GBCF, GVP Typhoon 030 @40MHz w/FPU, Subway USB, EasyNet Ethernet, Indi AGA MKI, FastATA MK-IV, Internal Slim CD/DVD-RW, WB3.5

Surfing The Web With AMIGA Is Fun Again!
 

Offline nadoom

Re: Is this fixable, or does anyone know where I can have it fixed?
« Reply #3 on: December 30, 2020, 12:47:56 AM »
Ahh nothing like the smell of a fishy a1200, the damage those caps can do is legendary sadly!

?وإلل وإلل وإلل, وأت د وي هف هر ثهن
 

Offline Crackpot

Re: Is this fixable, or does anyone know where I can have it fixed?
« Reply #4 on: December 30, 2020, 07:57:41 AM »
I'm just a dumb terminal that has managed to keep a classic A3000 alive in her Elbox Tower these last twenty years, but check out the skills of this guy here. Looks to me like your board's 'wound' would be just another day at the office for him or others like him.

https://www.youtube.com/watch?v=vx50YtEC2S8

'RetroGameModz' did advertise his doctoring services on AmiBay/EAB a few years ago - not sure about now. But he was/is not the only one. There are several - as well as the guys at AmiKit. Sniff about. You will find them.

Good luck. Hope it works out.
 

Offline AndyFC

Re: Is this fixable, or does anyone know where I can have it fixed?
« Reply #5 on: December 30, 2020, 08:33:47 AM »
I agree with Nadoom - the fishy smell is caused by burnt capacitors. It will be repairable by someone skilled.
A1200 in DIY Tower. 3.2 ROMs, 3.5" HD, CD RW and IDE to SD adapter running off the internal IDE port (using the A4000 4-port IDE adapter from Amigakit), Blizzard 1230-IV, with 32MB 60ns RAM and 50MHz 68882 FPU. 3COM PCMCIA Network card running with Miami DX. https://www.youtube.com/watch?v=1PrGdL6XjmE

MorphOS on PowerMac G5 and ATI 9600 pro
 

Offline F0LLETT

Re: Is this fixable, or does anyone know where I can have it fixed?
« Reply #6 on: December 30, 2020, 11:15:27 AM »
That area, will cause damage to the Audio circuit and also effect right mouse button. It can also cause random popping on audio and when ever right mouse button is pressed.
If you have none of these issues, then it needs to be cleaned up and caps replaced before it does start causing problems.
Quote from: Hungry Horace
Resolute and Industrious Grand ruler of the yellow people and the Ultimate Amiga Empire
Ultimate Amiga Network (Home of SONY PSP Amiga Emulator and AMOS Factory)

Quote from:  He who shall not be named
"Chris is that you!!!"
My all time favorite quote.