Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

 



Contrary to popular myth...
Contrary to popular myth...
Previous Image | Next Image
Description: Due to a recent "it could only happen to a developer" misadventure, I accidentally the whole thing. So, I had to reinstall 4.1 from a backup I had, which was only Update 5.

It's a common belief among certain detractors that both AmiUpdate will fall flat on it's behind and the only thing it has updates for is itself ;)

Here's proof to the contrary
Picture Stats:
Views: 630
Filesize: 198.8kB
Height: 768 Width: 1024
Posted by: Karlos at April 28, 2013, 03:36:50 PM

0 Members and 1 Guest are viewing this picture.

Comments (3)

Karlos
Posts:16807
April 28, 2013, 05:56:23 PM
@Nik

It doesn't, or at least not as far as I know. I believe that the server only hosts components known not to conflict with each other (after the testers OK them). However, the rollback feature exists for that purpose. I've not had to use it yet though :)
nicholas
Posts:8825
April 28, 2013, 04:40:34 PM
Shh! You'll spoil the fun of certain "HypeOS" stalkers! ;)

On a serious note, is AmiUpdate based on an existing package management system or is it written from scratch?

How does it resolve dependencies? Is it a case of just checking the version string of each component in true Amiga fashion?
Karlos
Posts:16807
April 28, 2013, 03:37:44 PM
And only three of the packages didn't have an auto installer and were extracted to RAM instead.


Powered by: SMF Gallery