Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: I'm a hoarder! C64 crustyness inside!  (Read 2947 times)

0 Members and 1 Guest are viewing this topic.

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #15 on: September 04, 2013, 04:08:25 AM »
VIC chip gets warm after being on for a few minutes, not hot, just warm.

I assume that means its running right...

All the rom chips have been tested, cpu has been tested, one cia chip has been tested.

So, to recap.

working:
Basic ROM (switchable)
Kernal ROM
Character ROM
VIC II
Clock Generator
PLA
CPU
CIA x2

Probably should have come up with a better test method... :p
« Last Edit: September 04, 2013, 04:51:19 AM by AmmoJammo »
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #16 on: September 04, 2013, 07:35:55 AM »
swapped the memory from the "barnyard" board onto the "DolphinDOS" board... not that I know if this memory works, as I have no working motherboards that only have the two ram chips..

doesn't work...
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #17 on: September 04, 2013, 11:38:40 AM »
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #18 on: September 04, 2013, 09:53:40 PM »
yeah, well, silly me....

I had +5v, +12v and the unregulated +9v....

What I didn't have was the +5v from the external supply itself?!?

The switch was bad, only switching the 9v AC.... :(

And the final C64 is this breadbin, which can probably be fixed too....

"The Barnyard" and "The Little Mermaid" look too far gone to me.... (or maybe it was just the baryard, I forget now...)

 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #19 on: September 11, 2013, 09:15:44 PM »


Top three on the left work, top one on the right works too ;)

The bottom on the left has "dead" written on a piece of tape stuck to the case, but while trying to get the top right board working, I realised what was wrong with it..

The kernal rom AND clock generator chips are both dead.... so that board is also now working, but I won't put it in that case, as its been stepped on...

One of the board has been deemed spare parts only... unfortunately, it was also the newest board out of the lot, which also means most of the ICs aren't compatible with the older boards... :(
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #20 on: September 14, 2013, 09:12:49 AM »
Quote from: commodorejohn;746878
Huh; looks from what I can find on Dolphin DOS like you need some kind of parallel cable and a modification board for the 1541 to get a speed-up; did you get such a drive with these, by any chance?

SNAP!



And some 1571 goodness, if it works...

But none of the slim 1541's came with a power supply... and in this lot (from the same person) there is a single C64 power supply... an Amiga 500 power supply... a Commodore 128 manual.... and a Commodore 16...

hmmm...
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #21 on: September 14, 2013, 09:57:20 AM »
mmm... dolphin dos...



this drive had a heap of seed shells in it... and the dolphin dos cable has been chewed on.... I think either by a bird, or mice.... I also think the corrosion and residue is from some creatures pee... :?



**click this link, image shack, or maybe I, didn't resize this pic... :p**
http://imageshack.us/a/img51/9921/8qdc.jpg
« Last Edit: September 22, 2013, 08:53:53 PM by AmmoJammo »
 

Offline commodorejohn

Re: I'm a hoarder! C64 crustyness inside!
« Reply #22 on: September 14, 2013, 05:22:03 PM »
Well, golly, look at that. Could use a cleaning, though! (I wouldn't bother with the rust on the case interior, since you don't want loose iron oxide particles hanging around in your disk drive, but I'd make sure the tracks are clear and swab down the drive head with rubbing alcohol.)
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73
Synthesizers: Roland JX-10/MT-32/D-10, Oberheim Matrix-6, Yamaha DX7/FB-01, Korg MS-20 Mini, Ensoniq Mirage/SQ-80, Sequential Circuits Prophet-600, Hohner String Performer

"\'Legacy code\' often differs from its suggested alternative by actually working and scaling." - Bjarne Stroustrup
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #23 on: September 14, 2013, 09:35:49 PM »
If I was to clean the chassis, which I might, I'd strip everything out of it, and use a wire brush (wire wheel on a drill actually) then probably paint it, just because...

Of course, that would only be if the drive actually worked :P

« Last Edit: September 14, 2013, 10:21:25 PM by AmmoJammo »
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #24 on: September 16, 2013, 04:08:10 AM »
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #25 on: September 22, 2013, 08:51:57 PM »
The Dolphin Dos drive ended up being rather unreliable, so I might put the DD board in another drive and see how it goes ;)

 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #26 on: November 30, 2014, 10:47:58 AM »
mmm...

 

Offline gertsy

  • Lifetime Member
  • Hero Member
  • *****
  • Join Date: May 2006
  • Posts: 2310
  • Country: au
  • Total likes: 6
    • http://www.members.optusnet.com.au/~gbakker64/
Re: I'm a hoarder! C64 crustyness inside!
« Reply #27 on: December 01, 2014, 07:06:08 AM »
Yes you have the bug. Look out life!
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #28 on: December 01, 2014, 07:20:40 AM »
Quote from: gertsy;778769
Yes you have the bug. Look out life!

I paid $45 for the SX-64, so I'm happy ;)

I don't intend to keep all the C64's either... currently putting together a package for a friend... :hammer: I've just been saving them!
 

Offline gertsy

  • Lifetime Member
  • Hero Member
  • *****
  • Join Date: May 2006
  • Posts: 2310
  • Country: au
  • Total likes: 6
    • http://www.members.optusnet.com.au/~gbakker64/
Re: I'm a hoarder! C64 crustyness inside!
« Reply #29 on: December 01, 2014, 07:24:37 AM »
Quote from: AmmoJammo;778771
I paid $45 for the SX-64, so I'm happy ;)

I don't intend to keep all the C64's either... currently putting together a package for a friend... :hammer: I've just been saving them!


$45. OMG. Good get. And obviously working too.  Well done!