Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: I'm a hoarder! C64 crustyness inside!  (Read 3090 times)

0 Members and 1 Guest are viewing this topic.

Offline AmmoJammo

I'm a hoarder! C64 crustyness inside!
« on: September 03, 2013, 03:17:36 AM »
Found this lot on Gumtree "make an offer"

Asked how much they wanted, they said $100, I offered $30... they said $50... I paid $30 :p

Anyhoo!

as well as the four C64's, there's also six tape drives, and one power supply, all missing their cords.... as well as a monitor that I wouldn't trust to power up right now...



One of them rattled, so of course that was the first one I dismantled...



Does anyone know what this is? used to be connected to a switch on the rear panel, but its been snapped off...



 

Offline commodorejohn

Re: I'm a hoarder! C64 crustyness inside!
« Reply #1 on: September 03, 2013, 03:35:16 AM »
A ROM replacement of some kind; I'd guess JiffyDOS, probably.

Sweet haul :D
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73
Synthesizers: Roland JX-10/MT-32/D-10, Oberheim Matrix-6, Yamaha DX7/FB-01, Korg MS-20 Mini, Ensoniq Mirage/SQ-80, Sequential Circuits Prophet-600, Hohner String Performer

"\'Legacy code\' often differs from its suggested alternative by actually working and scaling." - Bjarne Stroustrup
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #2 on: September 03, 2013, 04:00:51 AM »
Next I pulled apart the one that appeared to be in the best condition... it was also heavier than the other two wedges, which made me curious...

But, looks can be deceiving! Its possible the case was the cleanest, as it had been rained on! :nervous:







 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #3 on: September 03, 2013, 05:26:32 AM »
None of these computers do anything...

Well, they appear to output a black screen on the S-Video output, but thats it....
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #4 on: September 03, 2013, 05:39:27 AM »
Starting with the first C64 picture, I started swapping chips from another faulty board, that I already had (really not the best fault finding technique, I know!)

Put a standard rom chip back in, swapped the vic chip?

Then I swapped the clock generator thats next to the vic chip... and didn't even get a black screen anymore... oops, I think I found the issue with the "old" faulty board... lol

SO I guess its safe to say that the vic chip and clock generator are probably working...

Maybe I should at least check voltages :P kinda being lazy...
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #5 on: September 03, 2013, 06:08:46 AM »
Quote from: commodorejohn;746869
A ROM replacement of some kind; I'd guess JiffyDOS, probably.

Sweet haul :D

Its DolphinDOS!? Motherboard doesn't work, I plugged it into another motherboard...

The motherboard has also had one of the CIA chips replaced for some reason? Its now a 6526A for some reason?
 

Offline commodorejohn

Re: I'm a hoarder! C64 crustyness inside!
« Reply #6 on: September 03, 2013, 06:37:55 AM »
Huh; looks from what I can find on Dolphin DOS like you need some kind of parallel cable and a modification board for the 1541 to get a speed-up; did you get such a drive with these, by any chance?
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73
Synthesizers: Roland JX-10/MT-32/D-10, Oberheim Matrix-6, Yamaha DX7/FB-01, Korg MS-20 Mini, Ensoniq Mirage/SQ-80, Sequential Circuits Prophet-600, Hohner String Performer

"\'Legacy code\' often differs from its suggested alternative by actually working and scaling." - Bjarne Stroustrup
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #7 on: September 03, 2013, 06:42:33 AM »
Ah, no i didnt. But its red! :p
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #8 on: September 03, 2013, 07:12:41 AM »
I've dubbed this one "BarnYard"

Thing is though, its the newer board, only one I've got actually... but it still has the old SID chip... might have been changed at some time...









 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #9 on: September 03, 2013, 08:26:48 AM »


Also came with these cartridges... but no VIC-20 :p

 

Offline gertsy

  • Lifetime Member
  • Hero Member
  • *****
  • Join Date: May 2006
  • Posts: 2312
  • Country: au
  • Total likes: 6
    • http://www.members.optusnet.com.au/~gbakker64/
Re: I'm a hoarder! C64 crustyness inside!
« Reply #10 on: September 03, 2013, 10:33:56 AM »
Unbelievable mess. Just a simple plastic bag for storage would have helped.
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #11 on: September 03, 2013, 10:45:43 AM »
"Pirates Cove" was still wet under the label... :/
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #12 on: September 03, 2013, 11:29:17 AM »
Socketed the PLA, no good!
 

Offline Hattig

Re: I'm a hoarder! C64 crustyness inside!
« Reply #13 on: September 03, 2013, 03:37:38 PM »
That's certainly a farmyard of a computer. Get some compressed air on that mess!

Hopefully you'll get a couple of working systems out of them in the end.
 

Offline AmmoJammo

Re: I'm a hoarder! C64 crustyness inside!
« Reply #14 on: September 03, 2013, 09:30:59 PM »
Quote from: Hattig;746912
That's certainly a farmyard of a computer. Get some compressed air on that mess!

Hopefully you'll get a couple of working systems out of them in the end.

At the very least, for $30, It seems I'll have quite a few spare chips.

In the first board I've tried to fix, all the following parts seem to work...

Basic ROM (switchable)
VIC II
Clock Generator
PLA

Maybe I should replace the crystal... just because the clock generator works in another board, doesn't mean its generating the clock in the bad board...