Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

 



Battery damage on A3000
Battery damage on A3000
Previous Image | Next Image
Description: Pretty bad huh!
Picture Stats:
Views: 1489
Filesize: 173.43kB
Height: 768 Width: 1024
Posted by: mauidj at April 16, 2008, 08:53:33 PM

0 Members and 1 Guest are viewing this picture.

Comments (10)

paul1981
Posts:2139
May 13, 2016, 09:00:49 PM
That's some hardcore computer porn...
freqmax
Posts:2179
April 26, 2009, 03:35:23 AM
Maybe there's some chemical that will neutralize those nasty battery residues ..?
tokyoracer
Posts:1590
April 19, 2008, 10:15:24 PM
Gwion, I doubt the battery was saying much at all by the looks of things!
mauidj
Posts:126
April 19, 2008, 04:59:14 AM
Is this a salt and battery  :lol:
Sorry couldn't resist.
Gwion
Posts:466
April 17, 2008, 11:01:49 PM
Yum says Mr.Battery
mauidj
Posts:126
April 17, 2008, 10:15:55 PM
Believe it or not it still works (haven't checked all the functions yet) although the right mouse button and one mouse port are dead.
I can still get around using right Alt/Amiga!
And this is after asking the seller if there was any battery leakage   :getmad:
tokyoracer
Posts:1590
April 17, 2008, 06:10:06 PM
Is it battery damage? Looks like a crator to me.
Ral-Clan
Posts:1974
April 17, 2008, 04:11:38 PM
Eee Gad!  That is the worst I've ever seen.  Neutralize that blue stuff quick with some baking soda paste!
xPhilx
Posts:97
April 17, 2008, 02:33:45 PM
OUCH!

I've got battery damage to the tracks on my A3K, got a friend looking at it for me so fingers crossed it'll be up and running again.

Damn those batteries to hell!
Andeda
Posts:594
April 17, 2008, 01:00:28 PM
Does it work? looks like there is almost a hole in your mobo  :-o


Powered by: SMF Gallery