Welcome, Guest. Please login or register.

Recent Posts

Pages: 1 2 [3] 4 5 ... 10
Amiga Hardware Issues and discussion / Re: A500 GVP HD+ Memory Expansion Issues
« Last post by Matt_H on March 16, 2023, 08:16:23 PM »
Hmmm. Seems like the next diagnostic step would be to try some different sticks of RAM in the GVP. Or different slots? I imagine the RAM needs to be inserted in a specific order.
Amiga Magazines / Amiga Future: New full versions online
« Last post by AndreasM on March 16, 2023, 12:53:41 PM »
The download area of the Amiga Future was updated today. So, you can now find the following full versions online:

Evil Garden
Mission Andromeda
Pacific Islands


An overview of the recent uploads and changes to the download database of Amiga Future is also available from this link:


Of course we also want to be able to offer you many more full versions online, but to be able to achieve this, for you, we need your help, so ...

We are on the lookout for the Copyright holders for Amiga games and applications.
Do you know of any such person or can you actively help us in our search?
If so, then please contact us by email.

We are looking for extra support in order to revise the full versions download area of the Amiga Future webpage.
In particular, to check whether all those full versions formats (ADF, IPF, WHDLoad, AGA, CD releases, etc.) are complete.
In addition, a short description, in 2 sentences or less, about each of their system requirements and some screenshots need to be created.
If you want to help us, then please send us an email.

Amiga Hardware Issues and discussion / Cyberstorm MK2 Boot Issue
« Last post by tpd67 on March 16, 2023, 12:12:19 PM »

I picked up a Cyberstorm MK2 060 recently, (no SCSI module fitted), :( for my 4000 but have an issue on booting. If i boot and run Trace Startup-Sequence it is hanging here:

Mount DEVS:DOSDrivers/(#?.info)

See attached picture.

I can only get it to boot by turning off the CPU caches in the Early Startup Menu, it will then, at the 2nd attempt boot to a low res workbench. I can turn the cpu caches back on using SysInfo and most programmes run ok, Lightwave for example some crash and have to be suspended.

I'm using the latest Phase 5 libraries, (as far as i can tell), downloaded from here:


68040old.library   37.30
68040new.library 46.5
68040.library       46.5
68060.library       46.70

Any advice would be appreciated.

I'm running AmigaOS 3.2.2 from a CF card on the built in IDE interface. ZZ9000 fitted. The main board jumpers are set to 'Internal', no RAM on main board.

Amiga Gaming / Re: Rogue
« Last post by klx300r on March 16, 2023, 07:06:06 AM »
problem solved and it was an ACA500+ profile configuration issue where I didn’t have the fast ram on board and AUX_CF slots configured properly.
Amiga Gaming / Re: Rogue
« Last post by denis2342 on March 15, 2023, 11:49:40 PM »
one last thing: if you start manually you should put a "stack 10240" in front.
Amiga Gaming / Re: Rogue
« Last post by klx300r on March 15, 2023, 11:43:10 PM »
just dumped everything in the ADF to a folder and it worked fine on my A1200 & A4000.
Amiga Gaming / Re: Rogue
« Last post by denis2342 on March 15, 2023, 09:45:02 PM »
the new rogue needs the .lz4 files as images, you know that right?
Amiga Hardware Issues and discussion / Re: A500 GVP HD+ Memory Expansion Issues
« Last post by AndrewP on March 15, 2023, 08:58:03 PM »
Hi Matt, thank you for the welcome, much appreciated  :)

The jumpers are definitely set correctly. Based on what you said though, I disconnected the 2mb trapdoor expansion so there was just 512kb chip ram and verified this in Sysinfo. I then connected up the GVP then rebooted the machine. No change in the errors and only the 512kb was shown in Sysinfo.

Just to check, I then moved the GVP jumpers to the 4MB position (despite only the 2MB being fitted) and Sysinfo reports the memory to still be 512kb but in the 'boards' tab it shows 4MB....meaning Sysinfo is detecting the ram board and the jumper settings but not the memory itself.

Based on this and the info in the page you linked to, I think either both sticks of ram are faulty, or the chip ram mod to the Gary chip is causing the errors, since the board is being detected in Sysinfo (but not in the Expansion Diagnostic Tool on boot though). The page also mentions cutting a trace to fix it, but doesn't give any further details sadly.
Amiga Gaming / Re: Rogue
« Last post by denis2342 on March 15, 2023, 06:52:39 PM »
tested with 46.143, no problems. even with only 512 chip and nothing else.
Amiga Gaming / Re: Rogue
« Last post by klx300r on March 15, 2023, 05:55:25 PM »
Its running OS3.2 same as my other AGA miggies
Pages: 1 2 [3] 4 5 ... 10