Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Let me present the A3660  (Read 6279 times)

0 Members and 1 Guest are viewing this topic.

Offline darksun9210

Re: Let me present the A3660
« Reply #15 on: February 14, 2019, 04:02:20 PM »
int2 is only for any extra onboard devices like scsi controllers etc.
I have a cyberstorm Mk3 060 running in my A3k with no int2 mod - just means I have to boot off the internal scsi.

if I recall in the dim and distant past, that there was ram board for the A3640, plugged into the cpu socket and the cpu plugged into that....

found it:-
https://bboah.com/index.php?action=artikel&cat=45&id=2094&artlang=en&highlight=X%5C-Calibur

A500 Vampire2/minimegachip/lazarus/indyECS, (+GVP A530,SupraTurbo28,GVP HD8)
A600 Vampire2/604n/subway/IndyECS, (+ACA630)
A1200 Vampire2/IndyAGA, (+Bliz030+scsi)
A1200 Bliz040+scsi/subway/indyAGA
A1200 BlizPPCscsi/Bvision/subway
A3k CSmk3-060/CV64-3D/Xsurf100+RRoadUSB/Zoram256/acard scsi-ide-CF/IndyECS,
A4k C=040/CV64-3D/Xsurf100+RRoadUSB/Bigram256/IndyAGA, (also mediator+pci cards)
CD32 TF330/IndyAGA
Plus an SGI O2 & consoles.
 

Offline madgrizzle

Re: Let me present the A3660
« Reply #16 on: February 15, 2019, 06:35:55 PM »
Try squeezing that into a 3000D.
Only Amiga *woo-woo* Makes It Possible
Only Amiga   ... Makes.. It .. Happen!
Amiga 2000, 2MB Chip RAM, OS3.9, GVP Combo 030/22 13 MB, Supra 4MB
Amiga 3000, 16 MB RAM, OS3.9, A3640 v3.2 with 060 Processor, Picasso II, A2065, PCD-50B
Dead VA2000/CX :(
 

Offline midway

Re: Let me present the A3660
« Reply #17 on: March 11, 2020, 01:15:52 AM »
Anyone upgraded a Warpengine to 68060 ? what libraries have you guys been using for the 3660 ? should work for the warpengine too ?
 

Offline trixster

Re: Let me present the A3660
« Reply #18 on: March 11, 2020, 07:45:45 PM »
You can use an 040-060 adapter to upgrade a warpengine. As the warpengine uses a 1:2 oscillator to clock ratio for cpu and 1:1 for ram, a 40mhz oscillator will give you an 80mhz 060 with 40mhz ram speed.
[SIGPIC][/SIGPIC]A1200 + 80Mhz B1260 + Indi AGA2 + Ide-fix Express | A500 | A3000 + 50Mhz A3660 + CV64 + Deneb + 486SLC + ZorRam
A4000/040 + 66Mhz  Cyberstorm Mk2 + Indi AGA + Voodoo 3 + Sonnet G3 + Deneb + Prisma | SNES | C64 | CPC6128 | MD | 3DO
Acorn A3020 | A3000 | A420/1 | Atom | Master Turbo | BBC B | Atari Falcon + 100Mhz CT60e | PS1 | PS2 | Saturn | Atari Jaguar
 

Offline JKD

Re: Let me present the A3660
« Reply #19 on: January 25, 2021, 11:23:28 PM »
Anyone test these things in an A4000T (esoteric I know)...it seems they're incompatible with NCR SCSI.device and no way of sidloading it seems to work (GURU 8000 0004 I think...but the system boot loops)
 

Offline mechy

Re: Let me present the A3660
« Reply #20 on: January 29, 2021, 11:42:19 PM »
Anyone test these things in an A4000T (esoteric I know)...it seems they're incompatible with NCR SCSI.device and no way of sidloading it seems to work (GURU 8000 0004 I think...but the system boot loops)

yes i have 3 of them. one worked at 50mhz in the 4000T
one worked with 55mhz in the 4000T,but not at 50Mhz or 60mhz.
one didnt work at all in the A4000T at any speed.
All 3 work flawless in the 4000D
my only guess and this is only a guess,is when chucky reverse engineered the pcb he changed a few traces around here and there and it throws off the picky 4000T timing somehow?
These cards are also hit and miss in 3000D's
Not sure if this was ever solved or new revision of the 3660 came out etc.
Are you sure its a problem with the scsi?  If so it seems maybe you could install 4000D roms in the tower and try that?
4000t's are notorious for bad caps also. might be a good idea to recap if it hasnt been.

Offline JKD

Re: Let me present the A3660
« Reply #21 on: March 12, 2021, 10:21:36 PM »
Anyone test these things in an A4000T (esoteric I know)...it seems they're incompatible with NCR SCSI.device and no way of sidloading it seems to work (GURU 8000 0004 I think...but the system boot loops)

I'm currently running like this in my A4000D, it's very fast!

WarpEngine 4060/80MHz, using the onboard SCSI to boot....as it turns out from this thread , also:

I'm using my A4000T ROMs in the Desktop and the A4000D ROMs in my A4000T to workaround the NCR SCSI device issues because the 4000T has an A3660 :D

I was reading some of SpeedGeeks stuff and there's probably a timing clue in the CLK SRC for the onboard SCSI...it could probably be fixed with a GAL/PAL or even a wire mod...way beyond my skill.