Amiga computer related discussion => Amiga Hardware Issues and discussion => Topic started by: scuzzb494 on April 03, 2021, 09:50:36 PM

Title: A600 Mouse Problem
Post by: scuzzb494 on April 03, 2021, 09:50:36 PM
Kinda fearing the worst but here goes.

When I boot the A600 I can click a few drawers and icons and then the left mouse button stops working. Reboot same again. I can use for a short while then stops. That is the left mouse.

The keyboard buttons can move the pointer but the combo for click doesn't work. It works for a short time after boot but like the main mouse doesn't click after a while.

Changed mouse and remeoved everything but still same problem.

Before I chuck the thing out the window, maybe I missed something. There are no leaky capacitors. If it were just dead I could imagine a busted chip but this thing just goes off after a minute or so after each reboot. Most likely a dying capacitor, dunno.
Title: Re: A600 Mouse Problem
Post by: Pat the Cat on April 03, 2021, 10:42:52 PM
Way more likely to be malware than hardware if both options crap out after a few tries. They use totally different hardware.

You could try monitoring the CIA pin with a logic probe to see if it bounces up and down when you click.

There's not much in the way of components - one resistor inline with the button, one debounce capacitor  between ground and the connector pin on the back.
Title: Re: A600 Mouse Problem
Post by: scuzzb494 on April 04, 2021, 02:36:37 AM
I tried a small utility I have that checks the buttons on the mouse and joystick. And all were working fine and to the point I could click like mad with the mouse and she did not hang. The joystick also works a charm and I was playing R-Type for ages and she didn't kick out. The problem is the activation of icons and after about ten clicks the mouse click stops working and then the mouse locks up. If I click the CLI just after boot I can resize the window and move it around for ages. Plus the keyboard works. But as soon as I activate an icon the thing stops responding and then will freeze. Its not the mouse its the display of the icon at fault. If this was a 500 I would be swapping out the Denise.

One of the chips has gone bad. The only one I could swap out was the ROM but that didn't work. Same problem. She is a gonner sadly. Lost to the void. I can do no more as I am not an electrician. So its Coopers Ducks I'm afraid. She had a good innings. Never mind.
Title: Re: A600 Mouse Problem
Post by: Pat the Cat on April 04, 2021, 03:23:52 AM
Makes no sense at all scuzz. If a utility shows it as working, but a Workbench does not, it's got to be a software problem with that Workbench disk.

Denise doesn't read the button, it reads the position (mouse quads). That's all working.

OK, no sockets, you can't swap the CIA chips to test the button press. BUT you can check the button with Early startup menu at least.
Title: Re: A600 Mouse Problem
Post by: Pat the Cat on April 04, 2021, 03:59:46 AM

Might not be the CIA, can be the connections and components leading to it.

I would at least try changing the components between the CIA and the mouse port before  writing off the CIA chip as bad.

That capacitor, if its Esr was too high, could cause the issue. Increased resistance rather than no contact at all.
Title: Re: A600 Mouse Problem
Post by: TribbleSmasher on April 04, 2021, 09:03:08 AM
Get a virus killer disk, let it run, just in case.

Get AmigaTestKit from here
make it a bootable disk and try and test the machine before ripping parts out.
Title: Re: A600 Mouse Problem
Post by: scuzzb494 on April 04, 2021, 05:02:33 PM
Its not a virus. Trust me. I have a big box of disks that I use including install disks, Workbench disks etc and these disks get swapped out on other machines. I've been using the same disks on a 600 this morning and she installed and ran fine. Same again with another 600. Its not a virus.

The mouse only works on none Workbench windows. I can play Lemmings on the mouse no problem. I can play any number of games that need mouse and keyboard and joystick no problem. My little application for testing the ports lets me click as many times as I like. But when I close that window and try to click the icon it refuses to click and then the mouse freezes.

If I boot from an external floppy drive I get a lot longer with the mouse, but only a matter of ten seconds. It isn'the movement of the mouse and I can also hover over icons. The joystick is woring without fault, but that isn't clicking icons. Also as I said the ALT-LA or ALT-RA doesn't click an icon if the process has halted.

There is an issue with one of the chips and its busted. Everything is surface mounted and I am not an electrical engineer. I have no skills at all. Best I can do is go through the motions and check the processes and see patterns of behaviour. I use the same disks on another 600, doing exactly the same and I get no problems. I have tried two other 600s and have not been able to replicate the problem.

This computer has a dodgy floppy drive. It will only boot with the disk inserted.  So if you try to boot by inserting at the initial boot screen it refuses to recognise the disk. However, the external drive works with no problem. I will have a look at the drive. The hardware isn't kicking the drive out, it's not working properly. Its not related to keyboard cus I booted without the keyboard attached and that just threw up the same problem. Like I said I even changed the ROM. Also swinging around my head with the power cord and smashing into the wall didn't help, but it made me feel better.

I had to give up with the computer cus to add more pain to my problems, I removed the cable from the interface for the hard drive and three pins came out. Totally random, not at the ends just three from the middle. I just couldn't believe my bad luck. The A600 is mothballed and labelled busted. So I'm not troubling myself with it anymore. I have to say the 600 is the worst Amiga ever made. Give me a 500 Plus any day. I can diagnose and swap chips no problem. This thing would be working by now. And I still think its the graphics chip or something to do with timing signals from that area of the machine. Could be the CIA maybe but the lack of failure within windowed applications and games, plus no other associated problems makes me reflect on issues I have had with the Denise in the past on the Plus.

Never mind... I have others so its no biggy. Its all getting a little too old, long past its sell by date in truth. I had my moneys worth. Ar hum.
Title: Re: A600 Mouse Problem
Post by: scuzzb494 on April 05, 2021, 12:17:38 AM

Just a last update. The problem is the reset circuit around U14. If you look at this pic the capacitor is shot and taken out the tracks to C611. All three there are linked to U14 and the keyboard reset circuit. The mouse is a red herring its the keyboard reset that locks the machine. When you first switch on cold you get a longer time before the machine locks up. Then as the capacitors get warm they fail and the circuit I guess isn't closed or opened. Dunno, not an expert.

Like I say not something I can fix. So its Coopers ducks for this A600.

Thanks for the comments.