Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: "Executable - File not executable" ... Suggestions?  (Read 3149 times)

0 Members and 1 Guest are viewing this topic.

Offline Hodgkinson

"Executable - File not executable" ... Suggestions?
« on: January 19, 2008, 09:49:36 AM »
Hi there,
I've just been and installed StarFighter:D'Yammen's Reign on my A1200D WB3.0 KS3.0 system. Without the patches, the game works fine. But with the patches applied (More specifically the new "Executable" file in the "Starfighter" drawer) once rebooted the system stops abruptly and says that the "Executable" file isn't executable :crazy:

The game works fine with the patches providing that the old executable file is left alone.

I've tried resetting all the protection bits on the new patched executable file to no avail.

Anyone any ideas?

EDIT: The executable files in both the LHA group of files at the top of the game download page (http://www.drewfx.com/Star/star.htm) and the LHA patches in the "LoadWB" file section at the bottom of the page seem to have the same problem.
Trying to run the executable just on its own without the game loaded also has the same problem.

Thanks,
Hodgkinson.
Main A1200D: WB3.0, 3.1 ROMs, 2GB HDD, Blizzard 1230IV (64MB RAM + FPU) and a whole load of custom heatsinks... :flame:
 

Offline motorollin

Re: "Executable - File not executable" ... Suggestions?
« Reply #1 on: January 19, 2008, 10:08:47 AM »
Is the file really an executable? Or is it a script which is calling other executables, one of which may not have the executable bit set? Or maybe it is a project with some default tool set which has lost its executable bit?

If none of that works, ISTR there were problems getting that archive to decompress without corruption (in the "Please stop copying Starfighter" thread). You may want to contact the author and try to get a new copy of that file in case it is corrupt.

--
moto
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline jmbattle

Re: "Executable - File not executable" ... Suggestions?
« Reply #2 on: January 19, 2008, 02:03:27 PM »
Ensure that the file's 'execute' protection bit is set correctly - it may have been lost if copied from a non-Amiga filesystem.

From a shell, type:

protect e

Then try running the file again.

Cheers,
James
x
 

Offline Caius

Re: "Executable - File not executable" ... Suggestions?
« Reply #3 on: January 19, 2008, 03:02:48 PM »
That would be: protect +e

If you ommit the plus sign you'll reset the other bits.
Theology is just a debate over who to frame for creating reality.
 

Offline motorollin

Re: "Executable - File not executable" ... Suggestions?
« Reply #4 on: January 19, 2008, 03:05:42 PM »
Before we get too sidetracked by the protect command, Hodgkinson did say he has already set the protection bits for the file.

--
moto
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline Hodgkinson

"Executable - File not executable" ... Suggestions?
« Reply #5 on: January 19, 2008, 08:06:09 PM »
Thanks for the replies.

OK - A question for anyone who's got the patches running on the game - :lotsacoffee: - What extractor did you use, and which patch files did you download?

I used the latest version of LHA on aminet, and as I say both the executable in the "lha" bunch of patches at the top of the download page (The redux repacked LHA file) and the lha patches in the "LoadWB" section at the bottom of the download page both seem to have the same problem.

EDIT: Is there a manual online for this game?

Thanks,
Hodgkinson.
Main A1200D: WB3.0, 3.1 ROMs, 2GB HDD, Blizzard 1230IV (64MB RAM + FPU) and a whole load of custom heatsinks... :flame:
 

Offline Hodgkinson

Re: "Executable - File not executable" ... Suggestions?
« Reply #6 on: January 19, 2008, 09:17:03 PM »
:bump:
Main A1200D: WB3.0, 3.1 ROMs, 2GB HDD, Blizzard 1230IV (64MB RAM + FPU) and a whole load of custom heatsinks... :flame:
 

Offline meega

Re: "Executable - File not executable" ... Suggestions?
« Reply #7 on: January 19, 2008, 10:19:54 PM »
Maybe OT, but what is/are the version number(s) of Lha that you are using?
:)
 

Offline rkauer

Re: "Executable - File not executable" ... Suggestions?
« Reply #8 on: January 20, 2008, 07:22:02 AM »
 Hello Hodg.

 Remember just one thing: lha 2.xx is pure crap.

 Use the old and good 1.38 version, who don't have the bad habit of trashing the output files.

 The new version must be deleted from aminet, in my opinion.

 BTW: look for lha.run on aminet!
Goodbye people.

I\'ll pop on from time to time, RL is acting up.
 

Offline weirdami

Re: "Executable - File not executable" ... Suggestions?
« Reply #9 on: January 20, 2008, 07:24:16 AM »
If it doesn't execute, then execute it. Get out the firing squad! Don't stand for such insubordination!!!!

 :oops:
----
Binding Polymer: Keeping you together since 1892.
 

Offline MadMonkey

Re: "Executable - File not executable" ... Suggestions?
« Reply #10 on: January 20, 2008, 08:52:37 AM »
It's probably lack of memory.

The patches work fine for me.

Try booting with no startup and running it then.

There are some files that are supposed to reboot and then run the game to solve memory problems. I think these were included in the patches and are in the top directory.

These didn't work correctly on my Amiga but if I rebooted, the game then ran automatically on boot.

I'd be v. careful with these because on my Amiga instead of using RAD: it used DH0: and overwrote my startup-sequence and various files in C:

Took me ages to get the computer working again. Only to discover I had enough memory to run it from the exe anyway.
 

Offline Hodgkinson

Re: "Executable - File not executable" ... Suggestions?
« Reply #11 on: January 20, 2008, 06:53:44 PM »
Quote

I'd be v. careful with these because on my Amiga instead of using RAD: it used DH0: and overwrote my startup-sequence and various files in C:

ouch ouch ouch...
N.B. I’m actually having to force my A1200 to reboot with RAD: at the moment as the RAD boot priority is lower than that of the system drive :roll:

Re LHA, im using v2.12 of LHA at the moment. I had to update from an older version to even be able to extract the archive files (I used v2.12 to extract both the game and all the patches).

@MadMonkey: What did you use to extract your patches?

Thanks,
Hodgkinson.
Main A1200D: WB3.0, 3.1 ROMs, 2GB HDD, Blizzard 1230IV (64MB RAM + FPU) and a whole load of custom heatsinks... :flame:
 

Offline MadMonkey

Re: "Executable - File not executable" ... Suggestions?
« Reply #12 on: January 21, 2008, 06:37:54 PM »
LHA 2.12

SF_PATCH.lha is corrupt.

StarFighter_Patch1.lha and StarFighter_Patch1.lzx are OK and contain the same files so use these.

Just apply StarFighter_Patch1.lha and SFP10991.LHA is what I did.

Helps if you don't follow the instructions. Lol
 

Offline Hodgkinson

Re: "Executable - File not executable" ... Suggestions?
« Reply #13 on: January 21, 2008, 08:30:31 PM »
StarFighter_Patch1.lha... The one from the bottom "LoadWB" section of the download page?

What is you're system spec (Revisions...)?

(Btw, PM sent)

Thanks,
Hodgkinson.
Main A1200D: WB3.0, 3.1 ROMs, 2GB HDD, Blizzard 1230IV (64MB RAM + FPU) and a whole load of custom heatsinks... :flame: