Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: "Dual" PNG icons  (Read 2285 times)

0 Members and 1 Guest are viewing this topic.

Offline Amigaz

Re: "Dual" PNG icons
« Reply #15 on: March 22, 2007, 07:52:30 AM »
Quote

motorollin wrote:
Hmm I installed it as described in the document but my system just hangs when the Workbench screen opens. I tried adding "Set USESEMAPHORES 0" to the startup-sequence just before afa_os_loader but this made no difference  :-?

[EDIT]And yes I commented out VisualPrefs and PowerIcons[/EDIT]

--
moto


Show us yer startup-sequence
 

Offline motorollin

Re: "Dual" PNG icons
« Reply #16 on: March 22, 2007, 08:01:25 AM »
; $VER: Startup-Sequence_HardDrive 45.2 (19.1.2001)
; Startup-Sequence for AmigaOS 3.9

SetPatch QUIET

C:Version >NIL:
C:AddBuffers >NIL: DF0: 15
FailAt 21

C:MakeDir RAM:T RAM:Clipboards RAM:ENV RAM:ENV/Sys
C:Copy >NIL: ENVARC: RAM:ENV ALL NOREQ

Resident >NIL: C:Assign PURE
Resident >NIL: C:Execute PURE

Assign >NIL: ENV: RAM:ENV
Assign >NIL: T: RAM:T
Assign >NIL: CLIPS: RAM:Clipboards
Assign >NIL: REXX: S:
Assign >NIL: PRINTERS: DEVS:Printers
Assign >NIL: KEYMAPS: DEVS:Keymaps
Assign >NIL: LOCALE: SYS:Locale
Assign >NIL: LIBS: SYS:Classes ADD
Assign >NIL: HELP: LOCALE:Help DEFER

BindDrivers
C:Mount >NIL: DEVS:DOSDrivers/~(#?.info)

C:LoadMonDrvs

SetEnv Language "english"
SetEnv Workbench $Workbench
SetEnv Kickstart $Kickstart
UnSet Workbench
UnSet Kickstart

C:AddDataTypes REFRESH QUIET
Run >NIL: C:PowerIcons
;Set USESEMAPHORES 0
;Run >NIL: C:AfA_OS_Loader
Run >NIL: C:VisualPrefs
C:IPrefs
C:ConClip

Path >NIL: RAM: C: SYS:Utilities SYS:Rexxc SYS:System S: SYS:Prefs SYS:WBStartup SYS:Tools SYS:Tools/Commodities

SYS:System/REXXMast >NIL:

IF EXISTS S:User-Startup
  Execute S:User-Startup
EndIF

Resident Execute REMOVE
Resident Assign REMOVE

C:LoadWB
EndCLI >NIL:




--
moto
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline AmiKit

Re: "Dual" PNG icons
« Reply #17 on: March 22, 2007, 01:21:37 PM »
Add Assign >NIL: AfA_OS_Libs: pointing to AfA_OS_Libs directory. Add it before the AfA_OS_Loader line.

If it doesn't help either, try to remove some files from AfA_OS_Libs directory to find out which one hangs.

Offline motorollin

Re: "Dual" PNG icons
« Reply #18 on: March 25, 2007, 12:55:29 PM »
Adding the assign didn't help so I moved all of the libraries in to a temporary folder and moved them back one by one. It turns out the graphics library was making it hang. Also, even with just the afa_system_lib present, the 3.9 version of workbench.library doesn't seem to take effect as Amidock doesn't load and my dialogs (e.g. Execute Command) all change back to the 3.1 versions  :-?

--
moto
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline Flashlab

Re: "Dual" PNG icons
« Reply #19 on: June 22, 2007, 09:35:52 PM »
I tried AfA but man those icons are slow. Beautiful but slow... Definately slower than my OS3.9 icons with the IconBeFast library. Am I doing something wrong?
Amiga 4000D Cyberstorm PPC 060@50 604@200 SCSI 130Mb Ram G-Rex Voodoo3 PicassoIV Paloma Ariadne Delfina Lite

Online Flash version of BoulderDash: Offline...
 

Offline AJS

Re: "Dual" PNG icons
« Reply #20 on: June 22, 2007, 10:17:59 PM »
If they are Kens Icons from amikit, you can download his latest lot from the link here   From the man himself
hope that helps :-)
Too often, we lose sight of life’s simply pleasures. Remember, When someone annoys you it takes 42 muscles to frown, BUT it only takes 4 to extend your arm and bitch slap that mother *’##@*&% upside the head .