The "Not Quite Amiga but still computer related category" => Amiga Emulation => Topic started by: Obi-Wan on April 05, 2021, 08:41:36 PM

Title: Pimiga 1.5 > Guru Meditation errors at boot >
Post by: Obi-Wan on April 05, 2021, 08:41:36 PM
Hi there guys.

I was hoping that you could shed some light on an issue for me please

I've just obtianed the absolutley aweseome Pimiga 1.5 package for my
Raspberry Pi 4.

I imaged the sd card with etcher (on linux)
I copied accross my ROMs to the Kicks folder

Things worked brilliantly, for about 30 mins.
I played a couple of games (quickly as a test)
Opened a couple of apps / programmes - They all opened and worked properly.
Everything seemed to be working well.

I was going to have a go on a few more games, and I wanted to use my
X-Box (360 ?) wired gamepad.

I plugged it in to one of the USB ports on the Pi, (It wasnt recognised
which I was half expecting). I then turned off the Pi
re-insterted the gamepad and rebooted, I got to the Pimiga desktop
but the gamepad still wasnt recognised.

I performed another powercycle, with the gamepad attatched
and then I stared to get the Guru meditation errors when trying to boot
into the main Pimiaga desktop (see trouble shooting steps below for error).

Trouble shooting:
01. The Pi will boot.
02. Get a basic text screen that scrolls with some device info
03. Displays the "Rainbow" box for 0.5 secs
04. Displays the Pimiga 1.5 splash screen

05. Then I get a nice big honking Guru meditation error
and the screen hangs (see error message below)

06. I can hit F12 and get into the config screen for UAE
I can then restart or quit the programme, and either drop into the CLI
or restart the "Amiga" from the UAE config screen.

07. If I restart the "Amiga", I get back to the splash screen.
and I'll either get the Guru meditation error or I'll sometimes get into
a  WB screen (but its massivley corrupt and the screen resolutions and
dimesions are warped.

But I cannot get back into the main Pimiaga Amiga desktop anymore

08. I've tried booting both with and without the gamepad attached
and neither works, I get the Guru meditation error message

09. I've ran a FS check using both (G-Parted & K-Partion manager)
on the boot and kicks partitions on the sd card.

However, I'm getting some strange results -

G-Parted is throwing out some errors (see bottom of this post)
However G-Parted has been twitchy for a while now, when trying to perform
FS checks on (Non-Linux) based FS - So I'm not entirley convinced that
there are any FS errors. (But I've included them for completeness)

K-Partition manager scans the FS and comes back clean with no errors
on the FS or partitions.

Device: Raspberry Pie 4 (4GB RAM)

Guru meditation error codes
Error: 8000 0004 Task: 40401868

Host PC
OS: Linux - Ubuntu 18.04
DE: KDE version 5.12.9
Kernel: 4.15.0-140-generic

G Parted error message when trying to perform a FS check on the
"Boot" and "Kicks" partitions.

Code: [Select]
GParted 0.30.0 --enable-libparted-dmraid --enable-online-resize

Libparted 3.2

Check and repair filesystem (fat32) on /dev/sdh1  00:00:01    ( ERROR )
calibrate /dev/sdh1  00:00:00    ( SUCCESS )
path: /dev/sdh1 (partition)
start: 8192
end: 532479
size: 524288 (256.00 MiB)
check filesystem on /dev/sdh1 for errors and (if possible) fix them  00:00:01   
fsck.fat -a -w -v '/dev/sdh1'  00:00:01    ( SUCCESS )
fsck.fat 4.1 (2017-01-24)
Checking we can access the last sector of the filesystem
Boot sector contents:
System ID "mkfs.fat"
Media byte 0xf8 (hard disk)
512 bytes per logical sector
512 bytes per cluster
32 reserved sectors
First FAT starts at byte 16384 (sector 32)
2 FATs, 32 bit entries
2064896 bytes per FAT (= 4033 sectors)
Root directory start at cluster 2 (arbitrary size)
Data area starts at byte 4146176 (sector 8098)
516190 data clusters (264289280 bytes)
32 sectors/track, 64 heads
0 hidden sectors
524288 sectors total
Reclaiming unconnected clusters.
Checking free cluster summary.
/dev/sdh1: 338 files, 94358/516190 clusters
grow filesystem to fill the partition  00:00:00    ( ERROR )
using libparted
libparted messages    ( INFO )
GNU Parted cannot resize this partition to this size. We're working on it!

TIA for any help or advice that you can provide.
Title: Re: Pimiga 1.5 > Guru Meditation errors at boot >
Post by: Pat the Cat on April 05, 2021, 11:04:00 PM
Did you remove the Microsoft repository check from the Pi?

Probably not, but it's the sort of thing Chris Edwards would do... and then when Microsoft hardware gets plugged in, Mr Pi falls flat on his face.

This may or may not be correct. It would explain the behaviour though,

EDIT: To check, try this line on a Pi shell;-

sudo nano /etc/hosts

Check for an entry that begins That turns it off off, which means that's exactly what Chris did).

Mind you, Microsoft don't have a license to make their hardware compatible with the Amiga Os...  ::)

This is Pi issue, I suggest you try asking on a Pi forum about turning it back on again if that turns out to be the case.
Title: Re: Pimiga 1.5 > Guru Meditation errors at boot >
Post by: Pat the Cat on April 06, 2021, 05:48:06 AM
I did find this on explicity adding an xbox controller (Not plug and play on Pi);-