Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: vbcc and aos 3.1  (Read 1790 times)

0 Members and 1 Guest are viewing this topic.

Offline yakumo9275

vbcc and aos 3.1
« on: September 11, 2011, 01:17:37 AM »
I have latest vbcc/vlink/vasm compiled just tonight and I have NDK 3.1 from the dev cd from vesalia. Trying to compile some stuff has thrown a bunch of errors.

I tracked it to in vbcc using CONST_STRPTR which appeared in exec/types.h v44... only NDK 3.1, exec/types.h shows v40.1...

found a def for that for
next one missing was a definition of CONST so I just #defined CONST const

now I'm missing the structs for AVL trees... cant find that anywhere in ndk 3.1 :(

so can vbcc not compile for aos3.1? :( the m68k-target seems full of non 3.1 stuff....
--/\\-[ Stu ]-/\\--
Commodore 128DCR, JiffyDOS, Ultimate 1541 II, uIEC/SD, CBM 1902A  Monitor
 

Offline x303

Re: vbcc and aos 3.1
« Reply #1 on: September 11, 2011, 02:56:04 AM »
Upgrade to NDK3.9 first, from this site: http://os.amigaworld.de/index.php?lang=en&page=12

Yes, you can compile for 3.1, you can even compile for 1.3 if you want to.
Just report back if you can't get it working.
 

Offline yakumo9275

Re: vbcc and aos 3.1
« Reply #2 on: September 11, 2011, 03:09:07 AM »
thanks, I have the ndk's they are all on the dev cd. So the 3.5ndk is fully 3.1 backward compat? I thought 3.5 was only for AOS/Workbench 3.5? etc, each NDK tied to the version of workbench?
--/\\-[ Stu ]-/\\--
Commodore 128DCR, JiffyDOS, Ultimate 1541 II, uIEC/SD, CBM 1902A  Monitor
 

Offline matthey

Re: vbcc and aos 3.1
« Reply #3 on: September 11, 2011, 04:03:35 AM »
Quote from: yakumo9275;658840
thanks, I have the ndk's they are all on the dev cd. So the 3.5ndk is fully 3.1 backward compat?


They are supposed to be backward compatible but there can always be bugs.
 

Offline Thomas

Re: vbcc and aos 3.1
« Reply #4 on: September 11, 2011, 08:25:50 AM »
If you use functions which only exist in 3.5, your program will crash on 3.1 You have to read the autodocs carefully to avoid this. Other than that, there is no incompatibility. I use the 3.9 NDK to develop for 1.3, no problem.