Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: Amiga 3000 SCSI problem  (Read 1123 times)

0 Members and 1 Guest are viewing this topic.

Offline oguzog

Amiga 3000 SCSI problem
« on: May 23, 2021, 09:47:17 AM »
Amiga 3000
Mobo Rev 9
500MB scsi disk
Original KS 2.04

boots works fine.

on HDD there are devices like WB_2x. etc. (Something about superkickstart i think, but i've heard that it is only for early mobos?)

I've changed roms and installed 3.1.4. chips.

Now i can't boot because it says can't find WB_2x.

and when i boot from 3.1.4 install disk. Then i go for hddtoolbox, it cannot find my disk? (on early startup menu i can see partitions).

I've tried with 3.1 install disk either but it says some library's are missing.

How can i clean install 3.1.4. now?

Offline Pat the Cat

Re: Amiga 3000 SCSI problem
« Reply #1 on: May 23, 2021, 06:07:52 PM »
Can you boot from the Early startup menu and just install from there? Probably not, because will not find workbench,library or intuition,library on your hard drive.

From the 3.2 FAQ;-

2.2 * How do I setup a new drive with HDToolBox? I do not see the
      drive in the selection box at all; what is wrong?

HDToolBox is a little bit old-fashioned, we know. To configure a new

   1. Check the tool types. There should be one reading
   2. Verify that scsi.device is the proper driver interface name that
      that your disk controller uses. If not, adjust it accordingly.
   3. Click on "Change Drive Type".

Another thing you might try if the above doesn't help... Boot from the WB3.14 install disk. After loading, put in the 3.1 install disk and copy it to RAM. Run it from the RAM disk.

EDIT: Compared to the 3.14 FAQ, identical entry.

« Last Edit: May 23, 2021, 08:41:05 PM by Pat the Cat »
"To recurse is human. To iterate, divine."

A1200, Vanilla, Surf Squirrel, SD Card, KS 3.0/3.z, PCMCIA dev
A500, Vanilla, A570, Rev 5, KS 1.2/1.3 Testbench system
Rasp Pi, UAE4ARM, 3D laser scanner, experimental, hoping for AmigaOS4Arm, based on Watterott Fabscan Pi

Offline oguzog

Re: Amiga 3000 SCSI problem
« Reply #2 on: May 24, 2021, 08:51:37 AM »
@Pat the Cat i tried that, saw the disk but was saying unsupported :)


Problem solved.

I put that scsi disk to my pc which is equipped with SCSI PCI card.

Using winuae, using 3.1 kickrom and 3.1.4. installation disk i have accessed the disk from hddtoolbox. Destroyed all partitions.

Put disk back to amiga 3000. now 3.1.4. install disk hddtoolbox sees it well. I have partitioned it and installed it.

No problems.