The "Not Quite Amiga but still computer related category" => Amiga Emulation => Topic started by: Ral-Clan on April 02, 2021, 05:41:00 PM

Title: USB gamepad not working with WinUAE
Post by: Ral-Clan on April 02, 2021, 05:41:00 PM

I've just set up a new computer with WinUAE 4.4.0 and while the configuration panel can "see" my USB gamepad, it won't actually do anything when the emulation is running (i.e. I can't control a game).
I've used WinUAE for years under both Windows XP, and after switching to Linux, under WINE. It has always worked flawlessly. Now that I'm setting up this new computer with WinUAE, I can't seem to get it to work and don't know why. The gamepad is good. It works in VICE, FS-UAE and all other software.

Under the "Host/Game ports" config panel, the gamepad is listed in the drop down list for Port 1 and Port 2. I've tried it in both virtual ports (and tried "swap ports").
It's also present in the "Host/Input" config panel. However, in both of those panels, when I press the "Remap/Test" button none of the D-pad or button presses register, although keyboard and mouse clicks register.

I can't figure out why it won't work!  Any clues? As I've said before, I've had it working before for the past 5 years on my previous Linux computer. The distro I use is Lubuntu.

I found this thread ( on English Amiga board where the same problem is described, and Tony Wilen (the WinUAE author) suggests: " Try -norawhid command line. It probably fixes gamepad/joystick problem". That seemed to fix the issue for the person who was having the problem, but I'm not sure how to implement this parameter.

wine -norawhid winuae4400.exe
...does not work, so I must be implementing it wrong.


I've attached screenshots of my setup.
(see screenshots).
Title: Re: USB gamepad not working with WinUAE
Post by: Ral-Clan on April 02, 2021, 06:00:12 PM
Solution found:

wine winuae4400.exe -norawhid

is the correct syntax to use (so the parameter is passed to the winuae executable.

So if you make a desktop launcher for WinUAE in Linux, it can look something like this:

[Desktop Entry]
Comment=Windows Amiga emulator
Exec=wine "/home/brent/.wine/drive_c/Program Files (x86)/WinUAE/winuae64_4400.exe" -norawhid

Just leaving this thread here for anyone else who has the same problem.